Loading ...
Sorry, an error occurred while loading the content.

Problems getting Apache::ASP samples running (win32)

Expand Messages
  • David Lightman
    We were running apache 1.3 + mod_perl (can t remember version) + jserv 1.1.2 for a couple of years on a Win2K and we have moved to Apache2 (also on Win2K) some
    Message 1 of 1 , May 14, 2002
    • 0 Attachment
      We were running apache 1.3 + mod_perl (can't remember version) + jserv 1.1.2 for a couple of years on a Win2K and we have moved to Apache2 (also on Win2K) some weeks ago. We also installed mod_perl, ActiveState ActivePerl 5.6.1 build 631 and jakarta-tomcat-4.0.3 for running java servlets. Summing up, the final combination is:

      SERVER_SOFTWARE="Apache/2.0.35 (Win32) mod_perl/1.99_02-dev Perl/v5.6.1 mod_jk/1.2.0"

      After a while, doing tests, we realised that we had to modify all cgi-scripts she-bang-lines to match the current location of perl.exe (i.e. #!C:/Perl/bin/perl.exe ). So, (I guess) mod_perl is ready and running (the majority of samples work).

      Now we are trying to install Apache-ASP-2.33, but I can't get the asp samples be run. I have modified she-bang line in index.html, index.htm, default.htm of scripts in /site/eg and now they are:

      #!C:\Perl\bin\perl.exe C:\Perl\bin\asp-perl

      Needless to say that I have copied asp-perl file bundled into Apache-ASP-2.33 in C:\Perl\bin and also ASP.pm into C:\Perl\site\lib\Apache. For all that I have read around and guessed by myself, it seems only those 2 files are needed.

      None of the samples work... in fact, i can't even get the site/eg/index.html file (which is the first script). All I get is an internal server error (500) in the browser:

      The server encountered an internal error and was
      unable to complete your request. The server is either
      overloaded or there was an error in a CGI script.

      No trace of any error in apache's error logs nor Win2K's eventlog (I don't know where else to look for). The service still runs and serves other html requests (I mean that it is not a dangerous fault, which makes apache end or anything weird).


      The rest of my configurations follows:


      ------------ httpd.conf ------------
      [...]
      LoadModule perl_module modules/mod_perl.so
      [...]
      PerlModule Apache2
      [...]
      # My website docs are in the default IIS
      # directory, but IIS services are not enabled.
      <Directory "C:/InetPub/wwwRoot/site/eg">
      Options FollowSymLinks
      AllowOverride All
      </Directory>
      -------- end of httpd.conf ---------


      -------- C:\Inetpub\wwwRoot\site\eg\.htaccess --------
      #I have modified only these lines...
      PerlSetVar StateDir C:\Inetpub\wwwRoot\site\eg
      <Files ~ (\.asp)>
      SetHandler perl-script
      PerlHandler Apache::ASP
      [...]
      </Files>
      [...] Same changes for the rest of <Files...>
      -------- C:\Inetpub\wwwRoot\site\eg\.htaccess --------


      I have also tried with SetHandler modperl and PerlResponseHandler Apache::ASP instead of original SetHandler perl-script and PerlHandler Apache::ASP, but I still have the same problem.

      I have also seen comments about running a startup.pl script, and I have also tried it:

      ---------- startup.pl ----------
      #!C:\Perl\bin\perl.exe -w

      # to load this file when the server starts, add this to httpd.conf:
      # PerlRequire /path/to/startup.pl

      #use Apache2 ();
      use Apache::compat ();
      #use lib ...;

      1;
      ------- end of startup.pl -------
      With this configuration (using this startup script), the browser waits and waits for the index.html page that is not served out (I guess) until the connection times-out. I have also tried uncommenting the former two lines, without luck.

      What am I doing wrong? Any idea would be greatly appreciated. Ah, thanks in advance to you all who read this out to the end, even though you don't know how to help me. Thanks :)
      --
      _______________________________________________
      Sign-up for your own FREE Personalized E-mail at Mail.com
      http://www.mail.com/?sr=signup


      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    Your message has been successfully submitted and would be delivered to recipients shortly.