Loading ...
Sorry, an error occurred while loading the content.

Problems setting up Apache::ASP 2.33 (Win32)

Expand Messages
  • David Lightman
    We were running apache 1.3 + mod_perl (can t remember version) + jserv 1.1.2 for a couple of years on a Win2K and we have moved to Apache2 (also on Win2K) some
    Message 1 of 2 , May 14, 2002
    • 0 Attachment
      We were running apache 1.3 + mod_perl (can't remember version) + jserv 1.1.2 for a couple of years on a Win2K and we have moved to Apache2 (also on Win2K) some weeks ago. We also installed mod_perl, ActiveState ActivePerl 5.6.1 build 631 and jakarta-tomcat-4.0.3 for running java servlets. Summing up, the final combination is:

      SERVER_SOFTWARE="Apache/2.0.35 (Win32) mod_perl/1.99_02-dev Perl/v5.6.1 mod_jk/1.2.0"

      After a while, doing tests, we realised that we had to modify all cgi-scripts she-bang-lines to match the current location of perl.exe (i.e. #!C:/Perl/bin/perl.exe ). So, (I guess) mod_perl is ready and running (the majority of samples work).

      Now we are trying to install Apache-ASP-2.33, but I can't get the asp samples be run. I have modified she-bang line in index.html, index.htm, default.htm of scripts in /site/eg and now they are:

      #!C:\Perl\bin\perl.exe C:\Perl\bin\asp-perl

      Needless to say that I have copied asp-perl file bundled into Apache-ASP-2.33 in C:\Perl\bin and also ASP.pm into C:\Perl\site\lib\Apache. For all that I have read around and guessed by myself, it seems only those 2 files are needed.

      None of the samples work... in fact, i can't even get the site/eg/index.html file (which is the first script). All I get is an internal server error (500) in the browser:

      The server encountered an internal error and was
      unable to complete your request. The server is either
      overloaded or there was an error in a CGI script.

      No trace of any error in apache's error logs nor Win2K's eventlog (I don't know where else to look for). The service still runs and serves other html requests (I mean that it is not a dangerous fault, which makes apache end or anything weird).


      The rest of my configurations follows:


      ------------ httpd.conf ------------
      [...]
      LoadModule perl_module modules/mod_perl.so
      [...]
      PerlModule Apache2
      [...]
      # My website docs are in the default IIS
      # directory, but IIS services are not enabled.
      <Directory "C:/InetPub/wwwRoot/site/eg">
      Options FollowSymLinks
      AllowOverride All
      </Directory>
      -------- end of httpd.conf ---------


      -------- C:\Inetpub\wwwRoot\site\eg\.htaccess --------
      #I have modified only these lines...
      PerlSetVar StateDir C:\Inetpub\wwwRoot\site\eg
      <Files ~ (\.asp)>
      SetHandler perl-script
      PerlHandler Apache::ASP
      [...]
      </Files>
      [...] Same changes for the rest of <Files...>
      -------- C:\Inetpub\wwwRoot\site\eg\.htaccess --------


      I have also tried with SetHandler modperl and PerlResponseHandler Apache::ASP instead of original SetHandler perl-script and PerlHandler Apache::ASP, but I still have the same problem.

      I have also seen comments about running a startup.pl script, and I have also tried it:

      ---------- startup.pl ----------
      #!C:\Perl\bin\perl.exe -w

      # to load this file when the server starts, add this to httpd.conf:
      # PerlRequire /path/to/startup.pl

      #use Apache2 ();
      use Apache::compat ();
      #use lib ...;

      1;
      ------- end of startup.pl -------
      With this configuration (using this startup script), the browser waits and waits for the index.html page that is not served out (I guess) until the connection times-out. I have also tried uncommenting the former two lines, without luck.

      What am I doing wrong? Any idea would be greatly appreciated. Ah, thanks in advance to you all who read this out to the end, even though you don't know how to help me. Thanks :)
      --
      _______________________________________________
      Sign-up for your own FREE Personalized E-mail at Mail.com
      http://www.mail.com/?sr=signup


      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Joshua Chamas
      ... =================== This email involves mod_perl 2.0. For more on this, please see:
      Message 2 of 2 , May 15, 2002
      • 0 Attachment
        David Lightman wrote:
        >
        > We were running apache 1.3 + mod_perl (can't remember version) + jserv 1.1.2 for a couple of years on a Win2K and we have moved to Apache2 (also on Win2K) some weeks ago. We also installed mod_perl, ActiveState ActivePerl 5.6.1 build 631 and jakarta-tomcat-4.0.3 for running java servlets. Summing up, the final combination is:
        >
        > SERVER_SOFTWARE="Apache/2.0.35 (Win32) mod_perl/1.99_02-dev Perl/v5.6.1 mod_jk/1.2.0"
        > ...
        > Now we are trying to install Apache-ASP-2.33, but I can't get the asp samples be run. I have modified she-bang line in index.html, index.htm, default.htm of scripts in /site/eg and now they are:
        >

        ===================

        This email involves mod_perl 2.0. For more on this, please see:
        http://perl.apache.org/preview/modperl-docs/dst_html/docs/2.0/user/index.html

        ===================

        mod_perl 2 has been released as experimental I believe, and from my working
        with it, I would agree that at least running Apache::ASP on it is unstable.
        It would crash repeatedly under a load test pretty quickly for ASP scripts,
        it seems that this had mostly to do with running in threaded mode and setting

        ThreadsPerChild 1

        made it stable, at least on the eg/counting.htm & eg/session.asp examples.
        Please note that other examples bundled with Apache2 below ran perfectly
        under load, like the /hello and /perl/printenv tests, so I suspect there
        is something with what Apache::ASP is doing that trips up in threaded mode.

        I was able to configure Apache 2 & mod_perl 2 successfully just now using
        the following steps, and resulting in a server with this as its header:

        Server: Apache/2.0.37-dev (Win32) mod_perl/1.99_02-dev Perl/v5.6.1

        Install latest windows perl from
        http://www.activestate.com/Products/ActivePerl/index.plex

        Install Apache2 + mod_perl2 from Apache2.tar.gz
        Please see Apache2.readme for more information
        ftp://theoryx5.uwinnipeg.ca/pub/other/

        Install Apache::ASP into perl using ppm installer
        c:/perl/bin/ppm.bat
        PPM> install Apache::ASP
        PPM> install MLDBM
        PPM> install MLDBM::Sync

        Then I copied the ./site directory from the latest Apache::ASP distribution
        at CPAN to /apache2/asp-perl, and added this to the bottom of the httpd.conf:

        # PerlInterpMax 1
        KeepAlive Off
        ThreadsPerChild 1
        Alias /asp-perl "/Apache2/asp-perl"
        PerlModule Apache::compat
        PerlModule Apache::ASP
        <Directory />
        AllowOverride All
        </Directory>

        As you can see I had tried setting PerlInterpMax 1 to make the
        Apache::ASP scripts stable under mod_perl 2, but it was the
        ThreadsPerChild that did it in the end. There may very well
        be some module that Apache::ASP relies on like Digest::MD5
        that is not thread safe, or this may be a problem with
        Apache::ASP or mod_perl 2 themselves causing the crashes
        under the load test, I do not know.

        I'll probably check things out on linux in the next few weeks
        and see how mod_perl2 and Apache::ASP are running there. If
        there are problems there too, it will be much easier to fix
        for me, so I will defer further investigation until that time.

        --Josh
        _________________________________________________________________
        Joshua Chamas Chamas Enterprises Inc.
        NodeWorks Founder Huntington Beach, CA USA
        http://www.nodeworks.com 1-714-625-4051

        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      Your message has been successfully submitted and would be delivered to recipients shortly.