Loading ...
Sorry, an error occurred while loading the content.

Win98 -- Apache::ASP 2.33 -- Errors

Expand Messages
  • Arul, Rex
    Hello Friends, The only progress I made was that the HTTPD did respond to invocations after I changed the path information without double quotes. I am not sure
    Message 1 of 5 , May 8, 2002
    • 0 Attachment
      Hello Friends,

      The only progress I made was that the HTTPD did respond to invocations
      after I changed the path information without double quotes. I am not
      sure if that solved the problem. That enabled my other scripts to run.

      But I just cannot make Apache::ASP to work, because of this error:
      flock() unimplemented on this platform at C:/Perl/site/lib/MLDBM/Sync.pm
      line 235.

      Please help. Thanks,
      Rex

      Environment: ActivePerl 629 / Apache 1.3.23/Mod_Perl1-26/ Apache::ASP
      2.33 / Windows 98
      Error Message:
      [Wed May 08 23:00:00 2002] [error] flock() unimplemented on this
      platform at C:/Perl/site/lib/MLDBM/Sync.pm line 235.
      MLDBM::Sync::Lock('MLDBM::Sync=HASH(0x1594ab4)', 1) called at
      C:/Perl/site/lib/MLDBM/Sync.pm line 226
      MLDBM::Sync::ReadLock('MLDBM::Sync=HASH(0x1594ab4)') called at
      C:/Perl/site/lib/MLDBM/Sync.pm line 77
      MLDBM::Sync::AUTOLOAD('MLDBM::Sync=HASH(0x1594ab4)', 'application')
      called at C:/Perl/site/lib/Apache/ASP/State.pm line 339
      Apache::ASP::State::FETCH('Apache::ASP::State=HASH(0x15a41a0)',
      'application') called at C:/Perl/site/lib/Apache/ASP/State.pm line 72
      Apache::ASP::State::new('Apache::ASP=HASH(0x15a2034)',
      'application', 'server') called at C:/Perl/site/lib/Apache/ASP/State.pm
      line 326
      Apache::ASP::State::TIEHASH('Apache::ASP::State',
      'Apache::ASP=HASH(0x15a2034)', 'application', 'server') called at
      C:/Perl/site/lib/Apache/ASP/Application.pm line 17
      Apache::ASP::Application::new('Apache::ASP=HASH(0x15a2034)') called
      at C:/Perl/site/lib/Apache/ASP/StateManager.pm line 73
      Apache::ASP::InitState('Apache::ASP=HASH(0x15a2034)') called at
      C:/Perl/site/lib/Apache/ASP.pm line 381
      Apache::ASP::new('Apache::ASP', 'Apache=SCALAR(0x15a1e24)') called
      at C:/Perl/site/lib/Apache/ASP.pm line 163
      Apache::ASP::handler('Apache=SCALAR(0x15a1e24)') called at nul line 0
      eval {...} called at nul line 0



      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Joshua Chamas
      ... You need to apply a work around, which you can find here: http://www.apache-asp.org/install.html#WinME%20%2F%2098%20%2Fdb672bf2 Basically, you don t need
      Message 2 of 5 , May 10, 2002
      • 0 Attachment
        "Arul, Rex" wrote:
        >
        > Hello Friends,
        >
        > The only progress I made was that the HTTPD did respond to invocations
        > after I changed the path information without double quotes. I am not
        > sure if that solved the problem. That enabled my other scripts to run.
        >
        > But I just cannot make Apache::ASP to work, because of this error:
        > flock() unimplemented on this platform at C:/Perl/site/lib/MLDBM/Sync.pm
        > line 235.
        >

        You need to apply a work around, which you can find here:

        http://www.apache-asp.org/install.html#WinME%20%2F%2098%20%2Fdb672bf2

        Basically, you don't need file locking now on win32 mod_perl
        since all requests are serialized anyway.

        Good luck! You have come quite a ways so far.

        --Josh

        _________________________________________________________________
        Joshua Chamas Chamas Enterprises Inc.
        NodeWorks Founder Huntington Beach, CA USA
        http://www.nodeworks.com 1-714-625-4051

        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      • Arul, Rex
        Josh: I already had that statement as the last statement in my httpd.conf file; nonetheless the bombs still surface. Any other ideas? Here is what I had in the
        Message 3 of 5 , May 10, 2002
        • 0 Attachment
          Josh:

          I already had that statement as the last statement in my httpd.conf file; nonetheless the bombs still surface. Any other ideas? Here is what I had in the httpd.conf:
          #As per apache-asp.org website recommendation for win95/98
           <Perl>
              *CORE::GLOBAL::flock = sub { 1 };
            </Perl>

          Am highly perfervid to make this work and hoping to hear back from you.

          Thanks,
          Rex
          .

          joshua@... wrote:
          "Arul, Rex" wrote:
          Hello Friends,

          The only progress I made was that the HTTPD did respond to invocations
          after I changed the path information without double quotes. I am not
          sure if that solved the problem. That enabled my other scripts to run.

          But I just cannot make Apache::ASP to work, because of this error:
          flock() unimplemented on this platform at C:/Perl/site/lib/MLDBM/Sync.pm
          line 235.


          You need to apply a work around, which you can find here:

          http://www.apache-asp.org/install.html#WinME%20%2F%2098%20%2Fdb672bf2

          Basically, you don't need file locking now on win32 mod_perl
          since all requests are serialized anyway.

          Good luck! You have come quite a ways so far.

          --Josh

          --------------------------------------------------------------------- To unsubscribe, e-mail: asp-unsubscribe@... For additional commands, e-mail: asp-help@...
        • Joshua Chamas
          ... Is your perl version 5.6 or greater? ( perl -v to find out ) Try that line higher in the httpd.conf, maybe before you load and perl module? Try is also
          Message 4 of 5 , May 10, 2002
          • 0 Attachment
            "Arul, Rex" wrote:
            >
            > Josh:
            >
            > I already had that statement as the last statement in my httpd.conf file; nonetheless the bombs still surface. Any other ideas? Here is what I had
            > in the httpd.conf:
            > #As per apache-asp.org website recommendation for win95/98
            > <Perl>
            > *CORE::GLOBAL::flock = sub { 1 };
            > </Perl>
            >

            Is your perl version 5.6 or greater? ( perl -v to find out )

            Try that line higher in the httpd.conf, maybe before you load
            and perl module? Try is also in the actual block that you configure
            Apache::ASP to run. This has worked for others, so I'm not sure
            why it does not work for you.

            --Josh

            _________________________________________________________________
            Joshua Chamas Chamas Enterprises Inc.
            NodeWorks Founder Huntington Beach, CA USA
            http://www.nodeworks.com 1-714-625-4051

            ---------------------------------------------------------------------
            To unsubscribe, e-mail: asp-unsubscribe@...
            For additional commands, e-mail: asp-help@...
          • Arul, Rex
            Wow! That did the trick. I will keep it in my mind, and maybe you can update your Docs as well. By default, when Apache HTTPD is installed, it puts the
            Message 5 of 5 , May 10, 2002
            • 0 Attachment
              Wow! That did the trick. I will keep it in my mind, and maybe you can update your Docs as well.

              By default, when Apache HTTPD is installed, it puts the directive as the last one -- down in the bottom. Please update your docs in your website to reiterate to the fact that it should be prior to the config directive where you actually load Apache::ASP. It is pure serendipity that none of the other Win98 folks had any problem with, but I did have! The directive should be as this:

              #As per apache-asp.org website recommendation for win95/98
               <Perl>
                  *CORE::GLOBAL::flock = sub { 1 };
                </Perl>
              <Files ~ (\.asp)>
                SetHandler  perl-script
                PerlModule  Apache::ASP
                PerlHandler Apache::ASP
                PerlSetVar  Global /Apache/global
                PerlSetVar  StateDir /Apache/state
              </Files>

              Thanks a lot Josh. I very much appreciate your insight and this gives me the courage to get seriously started on Apache::ASP. Thanks a lot.

              Regards,
              Rex


              joshua@... wrote:
              "Arul, Rex" wrote:
              Josh:

              I already had that statement as the last statement in my httpd.conf file; nonetheless the bombs still surface. Any other ideas? Here is what I had
              in the httpd.conf:
              #As per apache-asp.org website recommendation for win95/98
              <Perl>
              *CORE::GLOBAL::flock = sub { 1 };
              </Perl>


              Is your perl version 5.6 or greater? ( perl -v to find out )

              Try that line higher in the httpd.conf, maybe before you load
              and perl module? Try is also in the actual block that you configure
              Apache::ASP to run. This has worked for others, so I'm not sure
              why it does not work for you.

              --Josh

              _________________________________________________________________
              Joshua Chamas Chamas Enterprises Inc.
              NodeWorks Founder Huntington Beach, CA USA
              http://www.nodeworks.com 1-714-625-4051

              ---------------------------------------------------------------------
              To unsubscribe, e-mail: asp-unsubscribe@...
              For additional commands, e-mail: asp-help@...


              --------------------------------------------------------------------- To unsubscribe, e-mail: asp-unsubscribe@... For additional commands, e-mail: asp-help@...
            Your message has been successfully submitted and would be delivered to recipients shortly.