Loading ...
Sorry, an error occurred while loading the content.
 

RE: Where's & which's my httpd ?

Expand Messages
  • Ismael Touama
    Hi & thx, I don t understand, I ran make install which gave me no httpd althought I ran httpd -l . What was goin worng, goin on ? bbsc, ism ... De :
    Message 1 of 6 , May 8, 2002
      Hi & thx,

      I don't understand, I ran "make install"
      'which' gave me 'no httpd' althought I ran 'httpd -l'.
      What was goin' worng, goin' on ?

      bbsc,
      ism

      -----Message d'origine-----
      De : Joshua Chamas [mailto:joshua@...]
      Envoye : mardi 7 mai 2002 20:38
      A : Ismael Touama
      Cc : asp@...
      Objet : Re: Where's & which's my httpd ?


      Ismael Touama wrote:
      >
      > Hi overthere!
      >
      > Yesterday i succeed, *not in a clear understand*,
      > to compile mod_perl and apache_1.3.24.
      > httpd -l gave me the rights modules.
      >

      When you did httpd -l and got the right modules,
      which httpd were you using?

      Try:

      prompt> which httpd

      to find the path that you executed.

      Note that at the end of compiling your own mod_perl,
      it is typical to run "make install" where it will
      install your apache usually in a location like

      /usr/local/apache

      but that might be different depending on how you
      configured your apache build I guess.

      --Josh
      _________________________________________________________________
      Joshua Chamas Chamas Enterprises Inc.
      NodeWorks Founder Huntington Beach, CA USA
      http://www.nodeworks.com 1-714-625-4051

      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Joshua Chamas
      ... which httpd will only pick up httpd in your path. If you install apache in /usr/local/apache, then it will likely not be in your PATH though may work
      Message 2 of 6 , May 13, 2002
        Ismael Touama wrote:
        >
        > Hi & thx,
        >
        > I don't understand, I ran "make install"
        > 'which' gave me 'no httpd' althought I ran 'httpd -l'.
        > What was goin' worng, goin' on ?
        >
        > bbsc,
        > ism
        >

        "which httpd" will only pick up httpd in your path.
        If you install apache in /usr/local/apache, then
        it will likely not be in your PATH though may work fine.

        If you are in the directory that the httpd resides
        in after building it, and if "." is in your path, then you
        will be able to run

        prompt> httpd -l

        While doing the "make install" for apache, watch where
        its installing into. Likely it went to /usr/local/apache
        if you were doing a static build, so then you would be
        able to do

        /usr/local/apache/bin/httpd -l

        --Josh

        _________________________________________________________________
        Joshua Chamas Chamas Enterprises Inc.
        NodeWorks Founder Huntington Beach, CA USA
        http://www.nodeworks.com 1-714-625-4051

        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      • Ismael Touama
        Hi Josh and thanks... Ok, my mod_perl is yet installed, control done via telnet command line... Let s above what s wrong now. ... which httpd will only pick
        Message 3 of 6 , May 14, 2002
          Hi Josh and thanks...
          Ok, my mod_perl is yet installed, control done
          via telnet command line...
          Let's above what's wrong now.
          --------------------------------------------
          Ismael Touama wrote:
          >
          > Hi & thx,
          >
          > I don't understand, I ran "make install"
          > 'which' gave me 'no httpd' althought I ran 'httpd -l'.
          > What was goin' worng, goin' on ?
          >
          > bbsc,
          > ism
          >

          "which httpd" will only pick up httpd in your path.
          If you install apache in /usr/local/apache, then
          it will likely not be in your PATH though may work fine.

          $ I have really misunderstoods with the way the variable
          $ environment is implmented or just use by the system ($PATH).
          $ Yesterday, just after install (_few_severals_attempts_after)
          $ httpd and apachectl worked fine after a fresh compile
          $ and then after a reboot too in my /usr/local/apache/bin.
          $ The way I understand the stuff is that the compile alters
          $ programs located in the initial apache directory.
          $ IS THAT QUITE WRITE ?
          $ What kind of process could disabled the use of its ?!!
          $ Ok I find one interessant thing. It doesn't work when
          $ we situe ourself in the current directory...so


          If you are in the directory that the httpd resides
          in after building it, and if "." is in your path, then you
          will be able to run

          prompt> httpd -l

          $ ...so, in fact no...
          $ "." is in the directory [_is_that_different_that_*path*_?]

          While doing the "make install" for apache, watch where
          its installing into. Likely it went to /usr/local/apache
          if you were doing a static build,

          $ It reaveals another problem to my head...
          $ Static build and non-static-build (DSO)...
          $ Yes i guess it was the static way no "USE_DSO=1"

          so then you would be
          able to do

          /usr/local/apache/bin/httpd -l

          $ Yes but not from the current directory...strange isn't it ?
          $ Great thx,
          $ bbsc,
          $ ism

          --Josh

          _________________________________________________________________
          Joshua Chamas Chamas Enterprises Inc.
          NodeWorks Founder Huntington Beach, CA USA
          http://www.nodeworks.com 1-714-625-4051

          ---------------------------------------------------------------------
          To unsubscribe, e-mail: asp-unsubscribe@...
          For additional commands, e-mail: asp-help@...
        • Joshua Chamas
          ... If you haven t already, I would recommend getting a book on unix since the kinds of things that we are discussing are specific to that platform and have
          Message 4 of 6 , May 14, 2002
            > $ I have really misunderstoods with the way the variable
            > $ environment is implmented or just use by the system ($PATH).
            > $ Yesterday, just after install (_few_severals_attempts_after)
            > $ httpd and apachectl worked fine after a fresh compile
            > $ and then after a reboot too in my /usr/local/apache/bin.
            > $ The way I understand the stuff is that the compile alters
            > $ programs located in the initial apache directory.
            > $ IS THAT QUITE WRITE ?
            > $ What kind of process could disabled the use of its ?!!
            > $ Ok I find one interessant thing. It doesn't work when
            > $ we situe ourself in the current directory...so
            >

            If you haven't already, I would recommend getting a book on unix
            since the kinds of things that we are discussing are specific
            to that platform and have little to do with running Apache::ASP.
            The Apache::ASP mailing list is for support of running Apache::ASP,
            but this assumes that you already know how to work with the
            platform that you are on.

            Once a program is correctly installed in a place like /usr/local/apache,
            I cannot imagine what mechanism would prevent it from working later
            if it worked before. Subtle things like which user ( root or non-root )
            you are running as can make a big difference though, as well
            as whether there is an instance of httpd already running, bound
            to port 80.

            > $ ...so, in fact no...
            > $ "." is in the directory [_is_that_different_that_*path*_?]
            >

            . represents the current working directory, so if you
            cd /usr/local/apache/bin, then . = /usr/local/apache/bin
            and if you run "./httpd" you will really be running
            /usr/local/apache/bin/httpd

            > $ It reaveals another problem to my head...
            > $ Static build and non-static-build (DSO)...
            > $ Yes i guess it was the static way no "USE_DSO=1"
            >

            Right, static build is no "USE_DSO=1"

            --Josh

            _________________________________________________________________
            Joshua Chamas Chamas Enterprises Inc.
            NodeWorks Founder Huntington Beach, CA USA
            http://www.nodeworks.com 1-714-625-4051

            ---------------------------------------------------------------------
            To unsubscribe, e-mail: asp-unsubscribe@...
            For additional commands, e-mail: asp-help@...
          Your message has been successfully submitted and would be delivered to recipients shortly.