Loading ...
Sorry, an error occurred while loading the content.

Re: Apache::ASP Installation Issue

Expand Messages
  • Warren Young
    Redirecting this back to the list. Please don t respond to me personally. I m here to support Apache::ASP, not to support you in particular. :) ... What do
    Message 1 of 6 , Aug 19, 2008
    • 0 Attachment
      Redirecting this back to the list. Please don't respond to me
      personally. I'm here to support Apache::ASP, not to support you in
      particular. :)

      Randy wrote:
      > It now has Apache::ASP installed on it, but still won't run ASP scripts.

      What do you get in the browser?

      What do you get in Apache's error log?

      What does your global.asa file contain, and where is it?

      Can you post the relevant sections of your httpd.conf file, and say what
      is in all of the directories it references?

      Do all of these directories have appropriate permissions? Especially,
      does the StateDir exist, and is it writeable by the httpd user?

      > How do I call out a directory, and specify ASP scripts to run in it, in the
      > httpd.conf file? (I think this may be the end of it).

      There is an answer, but it's the wrong question. If you configure
      Apache::ASP to run on the server as a whole and it doesn't work,
      restricting it to a single directory won't make it work.

      Once you get ASP working globally, we can talk about tightening it down
      to a single directory. Let's not complicate things yet.

      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Randy
      Sorry for the personal reply. I m not used to this list yet. In the browser, I get the asp script. In the error log, I get nothing. (It seems the server thinks
      Message 2 of 6 , Aug 19, 2008
      • 0 Attachment
        Sorry for the personal reply. I'm not used to this list yet.

        In the browser, I get the asp script.

        In the error log, I get nothing. (It seems the server thinks it's cool to
        just throw the script out there.)

        I don't seem to have a global.asa file anywhere on the server. (Did a search
        for it...came up empty.)

        Directories:

        <Directory "D:\Xxxxxxx\xxxxxx">
        Options FollowSymlinks Includes
        AllowOverride None
        Order allow,deny
        Allow from all
        </Directory>

        That directory is the "home" directory for my site. It contains index.php
        and several other php scripts

        <Directory "C:/IndigoPerl/apache/htdocs">
        Options Indexes FollowSymLinks
        AllowOverride None
        Order allow,deny
        Allow from all
        </Directory>

        That directory is what came pre-installed on IndigoPerl as the "home".
        There's nothing there.

        <Directory "C:/IndigoPerl/apache/cgi-bin">
        AllowOverride None
        Options None
        Order allow,deny
        Allow from all
        </Directory>

        <Directory "C:/IndigoPerl/php">
        AllowOverride None
        Options None
        Order allow,deny
        Allow from all
        </Directory>

        The previous two directories seem to be where Apache is supposed to look for
        cgi's or php.exe.

        <Directory "C:/IndigoPerl/apache/htdocs">
        Options Indexes FollowSymLinks MultiViews ExecCGI +Includes
        </Directory>

        That one seems to tell Apache that in htdocs which options to use.

        <Directory "C:/IndigoPerl/apache/htdocs">
        <IfModule mod_perl.c>
        # Files directive is only valid in Directory section
        <Files ~ "\.(pl|cgi)$">
        SetHandler perl-script
        PerlHandler ModPerl::Registry
        Options ExecCGI
        allow from all
        PerlSendHeader On
        </Files>
        </IfModule>
        </Directory>

        That one seems to tell Apache how to handle Perl scripts in the htdocs
        directory.

        As for permissions, all of the directories above seem to be configured
        properly...at least as far as I understand Apache.

        What is the StateDir? Never heard of it.

        By "the httpd user" to whom do you refer?

        Thanks.


        -----Original Message-----
        From: Warren Young [mailto:warren@...]
        Sent: Tuesday, August 19, 2008 8:44 PM
        To: Apache-ASP List
        Subject: Re: Apache::ASP Installation Issue

        Redirecting this back to the list. Please don't respond to me
        personally. I'm here to support Apache::ASP, not to support you in
        particular. :)

        Randy wrote:
        > It now has Apache::ASP installed on it, but still won't run ASP scripts.

        What do you get in the browser?

        What do you get in Apache's error log?

        What does your global.asa file contain, and where is it?

        Can you post the relevant sections of your httpd.conf file, and say what
        is in all of the directories it references?

        Do all of these directories have appropriate permissions? Especially,
        does the StateDir exist, and is it writeable by the httpd user?

        > How do I call out a directory, and specify ASP scripts to run in it, in
        the
        > httpd.conf file? (I think this may be the end of it).

        There is an answer, but it's the wrong question. If you configure
        Apache::ASP to run on the server as a whole and it doesn't work,
        restricting it to a single directory won't make it work.

        Once you get ASP working globally, we can talk about tightening it down
        to a single directory. Let's not complicate things yet.

        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...


        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      • Warren Young
        ... That means Apache::ASP isn t even being called for the page, which is an Apache configuration problem, not a problem with Apache::ASP. (Problems with
        Message 3 of 6 , Aug 19, 2008
        • 0 Attachment
          Randy wrote:
          >
          > In the browser, I get the asp script.

          That means Apache::ASP isn't even being called for the page, which is an
          Apache configuration problem, not a problem with Apache::ASP. (Problems
          with Apache::ASP or the ASP pages themselves show up as complaints in
          error_log.)

          In all of what you posted about your httpd.conf contents, I don't see
          that you've actually configured Apache to use Apache::ASP. This is from
          the top of the configuration section of the manual:

          PerlModule Apache::ASP
          <Files ~ (\.asp)>
          SetHandler perl-script
          PerlHandler Apache::ASP
          PerlSetVar Global .
          PerlSetVar StateDir /tmp/asp
          </Files>

          I posted something much like it in my initial reply to you. It applies
          just as well on Windows as on Linux. Apache is Apache.

          > I don't seem to have a global.asa file anywhere on the server.

          I don't know that Apache::ASP fails to work without it, but you do want
          it. Here's the default one:

          http://apache-asp.org/eg/global.asa

          Search for global.asa on apache-asp.org for more on what it does.

          Also see the documentation for the Global configuration option to see
          how to change where global.asa lives:

          http://apache-asp.org/config.html#Global

          In the snippet above, it appears it's telling Apache::ASP to look in the
          same directory as your .asp files, which may not be a good thing if you
          want the contents of your global.asa to be secret. You can use the
          Global directive to put global.asa outside the document tree, so Apache
          won't serve it. Alternately, you can configure Apache to never serve *.asa.

          > <Directory "D:\Xxxxxxx\xxxxxx">

          Are you sure this section actually works? From the Apache platform
          notes for Windows:

          > because Apache uses Unix-style names internally, you must use forward
          > slashes, not backslashes

          http://httpd.apache.org/docs/2.0/platform/windows.html

          > What is the StateDir? Never heard of it.

          It's in the manual: http://apache-asp.org/config.html#StateDir

          > By "the httpd user" to whom do you refer?

          The user that Apache runs under. It might not be your user account. If
          you run it as a Windows service, by default, it runs as the SYSTEM user.

          ---------------------------------------------------------------------
          To unsubscribe, e-mail: asp-unsubscribe@...
          For additional commands, e-mail: asp-help@...
        • Randy
          Thanks a bunch! I ll get right on these configuration changes, and let you know how they worked out. I had a feeling (being so inexperienced with Apache
          Message 4 of 6 , Aug 19, 2008
          • 0 Attachment
            Thanks a bunch! I'll get right on these configuration changes, and let you
            know how they worked out.

            I had a feeling (being so inexperienced with Apache configuration) that it
            wasn't even set up. Somehow, being a long-time Windows user, I sort of
            expected the installer to take care of basic configuration.

            I will definitely look into what global.asa does and where to put it, as
            well as how to secure it. Thanks!

            <Directory "D:\Xxxxxxx\xxxxxx"> refers to the home directory of my website
            (the names were changed to protect the innocent) and they do work.

            I will also look into what State.Dir is.

            Since this is a Windows box...yes, it's probably using the system user by
            default.

            Thanks again.

            R

            -----Original Message-----
            From: Warren Young [mailto:warren@...]
            Sent: Tuesday, August 19, 2008 11:20 PM
            To: Apache-ASP List
            Subject: Re: Apache::ASP Installation Issue

            Randy wrote:
            >
            > In the browser, I get the asp script.

            That means Apache::ASP isn't even being called for the page, which is an
            Apache configuration problem, not a problem with Apache::ASP. (Problems
            with Apache::ASP or the ASP pages themselves show up as complaints in
            error_log.)

            In all of what you posted about your httpd.conf contents, I don't see
            that you've actually configured Apache to use Apache::ASP. This is from
            the top of the configuration section of the manual:

            PerlModule Apache::ASP
            <Files ~ (\.asp)>
            SetHandler perl-script
            PerlHandler Apache::ASP
            PerlSetVar Global .
            PerlSetVar StateDir /tmp/asp
            </Files>

            I posted something much like it in my initial reply to you. It applies
            just as well on Windows as on Linux. Apache is Apache.

            > I don't seem to have a global.asa file anywhere on the server.

            I don't know that Apache::ASP fails to work without it, but you do want
            it. Here's the default one:

            http://apache-asp.org/eg/global.asa

            Search for global.asa on apache-asp.org for more on what it does.

            Also see the documentation for the Global configuration option to see
            how to change where global.asa lives:

            http://apache-asp.org/config.html#Global

            In the snippet above, it appears it's telling Apache::ASP to look in the
            same directory as your .asp files, which may not be a good thing if you
            want the contents of your global.asa to be secret. You can use the
            Global directive to put global.asa outside the document tree, so Apache
            won't serve it. Alternately, you can configure Apache to never serve *.asa.

            > <Directory "D:\Xxxxxxx\xxxxxx">

            Are you sure this section actually works? From the Apache platform
            notes for Windows:

            > because Apache uses Unix-style names internally, you must use forward
            > slashes, not backslashes

            http://httpd.apache.org/docs/2.0/platform/windows.html

            > What is the StateDir? Never heard of it.

            It's in the manual: http://apache-asp.org/config.html#StateDir

            > By "the httpd user" to whom do you refer?

            The user that Apache runs under. It might not be your user account. If
            you run it as a Windows service, by default, it runs as the SYSTEM user.

            ---------------------------------------------------------------------
            To unsubscribe, e-mail: asp-unsubscribe@...
            For additional commands, e-mail: asp-help@...


            ---------------------------------------------------------------------
            To unsubscribe, e-mail: asp-unsubscribe@...
            For additional commands, e-mail: asp-help@...
          Your message has been successfully submitted and would be delivered to recipients shortly.