Loading ...
Sorry, an error occurred while loading the content.

Running the asp demo example files

Expand Messages
  • Andrew Yu
    Hi, I am having problems with running the demo asp example files, essentially the source code is being shown in the web browser . The system setup is Linux
    Message 1 of 3 , Oct 24, 2005
    • 0 Attachment

      Hi,

         I am having problems with running the demo asp example files, essentially the source code is being shown in the web browser .

       

      The system setup is Linux based

       

      Fedora Core 4

      Apache 2.0.55

      Mod Perl 2.0.2 compiled statically within Apache.

       

      Apache is installed under /usr/local/apache2 and the example site in /usr/local/apache2/asp/eg

       

      For testing purposes I did a chmod –R 777 on the asp directory. I also checked the .htaccess is present in the asp/eg directory

       

      For the httpd.conf file I added these settings to the bottom of the httpd.conf file

       

      PerlModule Apache::ASP

      <Files ~ (\.asp)>

      SetHandler perl-script

      PerlHandler Apache::ASP

      PerlSetVar Global .

      PerlSetVar StateDir /tmp/asp

      </Files>

       

      <Directory $DOCUMENT_ROOT/asp/eg>

      Options FollowSymlinks

      AllowOverride ALL

      </Directory>

       

       

      This is the output from the site:

       

      #!/usr/bin/perl /usr/bin/asp-perl

      [0]%>>   ([0]%>>source)

       

      There appear to be no errors from the apache error_log

       

      Any ideas or clues to this behaviour?

       

      Thanks,

       

      Andrew

       

       

       

    • Philip_Pereira@e-s-p.com
      Hey all, Is it possible to complete a cookieless Redirect, but still holding the current SessionID? from my global.asa file, I run this command from a sub:
      Message 2 of 3 , Oct 24, 2005
      • 0 Attachment

        Hey all,

        Is it possible to complete a cookieless Redirect, but still holding the current SessionID?

        from my global.asa file, I run this command from a sub:

        $Response->Redirect( $Server->URL('test.asp', { err => 2 }) );

        I call the sub at the start of an asp page

        What seems to be the problem is that it results in a new Session-id being created, which is not what I want - I want to keep the same session-id. Where am I going wrong?

        thanks

        Phil.
      • Warren Young
        ... I don t see that you changed the DirectoryIndex directive. Are you certain that mod_perl is working? Can you try a simple Hello, world! type program to
        Message 3 of 3 , Oct 24, 2005
        • 0 Attachment
          Andrew Yu wrote:
          > For the httpd.conf file I added these settings to the bottom of the
          > httpd.conf file

          I don't see that you changed the DirectoryIndex directive.

          Are you certain that mod_perl is working? Can you try a simple "Hello,
          world!" type program to prove it?

          ---------------------------------------------------------------------
          To unsubscribe, e-mail: asp-unsubscribe@...
          For additional commands, e-mail: asp-help@...
        Your message has been successfully submitted and would be delivered to recipients shortly.