Loading ...
Sorry, an error occurred while loading the content.

Installing Apache::ASP Problems

Expand Messages
  • Richard The Goalie
    trying to install apache::asp. perl Makefile.PL, make, make install went fine, but ASP is still not useable. i put the instructions in, and it
    Message 1 of 5 , Feb 24, 2002
    View Source
    • 0 Attachment
      trying to install apache::asp. perl Makefile.PL, make, make install went
      fine, but ASP is still not useable. i put the <Files ~ /.asp> instructions
      in, and it still doesn't work. the error i recieve is Can't locate
      Apache/ASP.pm in @INC. First, it's looking in perl5.6.0 libs, not the 5.6.1
      libs that i've installed for it. how can i chnage this. and also, does
      ASP.pm have to be compiled in with apache?

      darkwater3@...
      Richard

      _________________________________________________________________
      Chat with friends online, try MSN Messenger: http://messenger.msn.com


      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Maurice Aubrey
      ... It sounds like you need to recompile mod_perl using perl 5.6.1. ... No. Maurice ... To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org For additional
      Message 2 of 5 , Feb 24, 2002
      View Source
      • 0 Attachment
        On Sun, Feb 24, 2002 at 05:38:18PM -0500, Richard The Goalie wrote:
        > trying to install apache::asp. perl Makefile.PL, make, make install went
        > fine, but ASP is still not useable. i put the <Files ~ /.asp> instructions
        > in, and it still doesn't work. the error i recieve is Can't locate
        > Apache/ASP.pm in @INC. First, it's looking in perl5.6.0 libs, not the 5.6.1
        > libs that i've installed for it. how can i chnage this.

        It sounds like you need to recompile mod_perl using perl 5.6.1.

        > and also, does ASP.pm have to be compiled in with apache?

        No.

        Maurice

        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      • Ruggero Manzoni
        Hi, You can try to copy Apache::ASP in the directory where your perl5.6.0 libs are located. You must pay attention that all the libs that Apapache::ASP
        Message 3 of 5 , Feb 25, 2002
        View Source
        • 0 Attachment
          Hi,
          You can try to copy Apache::ASP in the directory where
          your perl5.6.0 libs are located.
          You must pay attention that all the libs that
          Apapache::ASP requires are also installed in your
          perl5.6.0 libs (ex MLDBM::Sync)
          Hope this can help you.
          Ruggero




          ______________________________________________________________________

          Guarda il nuovo video di Kylie Minogue!
          http://it.docs.yahoo.com/kylie/

          ---------------------------------------------------------------------
          To unsubscribe, e-mail: asp-unsubscribe@...
          For additional commands, e-mail: asp-help@...
        • Joshua Chamas
          ... Weird, I thought this got answered by someone else, but it popped up in my mailbox just now!! This scenario looks like you have a perl installed ( 5.6.1 )
          Message 4 of 5 , Feb 27, 2002
          View Source
          • 0 Attachment
            Richard The Goalie wrote:
            >
            > trying to install apache::asp. perl Makefile.PL, make, make install went
            > fine, but ASP is still not useable. i put the <Files ~ /.asp> instructions
            > in, and it still doesn't work. the error i recieve is Can't locate
            > Apache/ASP.pm in @INC. First, it's looking in perl5.6.0 libs, not the 5.6.1
            > libs that i've installed for it. how can i chnage this. and also, does
            > ASP.pm have to be compiled in with apache?
            >

            Weird, I thought this got answered by someone else, but it popped up
            in my mailbox just now!!

            This scenario looks like you have a perl installed ( 5.6.1 ) that is
            different from the perl that mod_perl was compiled into apache with.
            The best thing to do is to get mod_perl compiled with the perl version
            you are using now. 2nd to that, you need to find this old perl on your
            system, and hopefully the old executables are still somewhere like
            /usr/local/bin/perl5.6.0 that you can install the Apache::ASP module
            into by something like:

            cd Apache-ASP-*
            /usr/local/bin/perl5.6.0 Makefile.PL

            this will start the install process for that old perl.

            --Josh
            _________________________________________________________________
            Joshua Chamas Chamas Enterprises Inc.
            NodeWorks Founder Huntington Beach, CA USA
            http://www.nodeworks.com 1-714-625-4051

            ---------------------------------------------------------------------
            To unsubscribe, e-mail: asp-unsubscribe@...
            For additional commands, e-mail: asp-help@...
          Your message has been successfully submitted and would be delivered to recipients shortly.