Loading ...
Sorry, an error occurred while loading the content.

Fwd: RE: View contents of loaded global.asa

Expand Messages
  • Nicholas Schuetz
    ... This is my problem. I couldn t get custom subroutines to load from global.asa using GlobalPackage. When I go to _use_ it the compiler per the documentation
    Message 1 of 1 , Jul 20, 2004
    • 0 Attachment
      See my reply below:

      > I think you have it right that the documentation needs some revising. What
      > you
      > do *not* need to do is set "package Apache::ASP::TYPHOON" in your scripts,
      > since this happens automatically when GlobalPackage is used.

      This is my problem. I couldn't get custom subroutines to load from global.asa
      using GlobalPackage. When I go to _use_ it the compiler per the documentation
      complains that it isn't there. If you look back in this thread I have explained
      this in detail.

      > Also, don't ever use the Apache::ASP::* namespace itself. Better in your
      > case
      > to just use the name TYPHOON for the module name.

      Good Call.

      > But let's look at the motivation for naming the GlobalPackage namespace for
      > your
      > Apache::ASP application. Perhaps you want to reference a subroutine defined
      > in
      > your global.asa from another module like &TYPHOON::sub(), or perhaps you
      > want
      > to have an actual TYPHOON.pm module that you can load via "use TYPHOON;"
      > whose
      > subroutines you can then access directly from your scripts.
      >
      > It is possible that in your case that you do not even need to use the
      > GlobalPackage setting, and you might try running your application without
      > it.

      The only reason I am using this method is because in our previous implemetation
      this is how they, the developers of our app, did it. And it worked. It just
      alarmed me that when I upgraded things broke. I made sure everything including
      the non-mod_perl specific modules tested out without error. My intension is
      ensure the most stable system as possible of course. Then I began to worry if it
      was my or Apache::ASP wasn't stable.

      Bottom line is I have been looking for the reason this no longer works as it did
      in the previous version of Apache::ASP (2.19) we where using. I looked through
      the release notes and nothing caught my eye, though. Maybe I will just take your
      suggestion and create the TYPHOON.pm and load that.



      >
      > ---------------------------------------------------------------------
      > To unsubscribe, e-mail: asp-unsubscribe@...
      > For additional commands, e-mail: asp-help@...
      >
      >



      ----- End forwarded message -----



      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    Your message has been successfully submitted and would be delivered to recipients shortly.