Loading ...
Sorry, an error occurred while loading the content.
 

Random Internal Server Error

Expand Messages
  • Baden Grey
    I am using apache 2.0.47 and apache::asp with mod_perl. It serves asp pages ok but when I include perlscript in the .asp file it still works but most of the
    Message 1 of 2 , Jun 7, 2004
      I am using apache 2.0.47 and apache::asp with mod_perl.  It serves asp pages ok but when I include perlscript in the .asp file it still works but most of the time it tacks on an error message at the end of the page.  For example if I have a .asp file with the following:
       
      <%@ Language=PerlScript %>
      <%
      print "Hello World"; 
      %>
       
      the Hello World will always show but underneath I randomly get the following error message:
       

      OK

      The server encountered an internal error or misconfiguration and was unable to complete your request.

      Please contact the server administrator, xxx@... and inform them of the time the error occurred, and anything you might have done that may have caused the error.

      More information about this error may be available in the server error log.


      Apache/2.0.47 (Win32) mod_perl/1.99_13 Perl/v5.8.3 Server at localhost Port 80
       
      Sometimes it displays the whole error message, sometimes just part of it and sometimes not at all.  This is what I have in the httpd.conf file, just under all the LoadModule lines:
       
      LoadFile "C:\Perl\bin\perl58.dll"
      LoadModule perl_module modules/mod_perl.so
      PerlModule Apache::ASP
      <Files ~ (\.asp)>   
         SetHandler  perl-script
         PerlHandler Apache::ASP
         PerlSetVar  Global .
      </Files>
       
      Also, there is no error in the log file.
    • Josh Chamas
      ... Make sure to upgrade to Apache::ASP 2.57, as the problem was fixed in that release. Regards, Josh
      Message 2 of 2 , Jun 7, 2004
        Baden Grey wrote:
        > I am using apache 2.0.47 and apache::asp with mod_perl. It serves asp
        > pages ok but when I include perlscript in the .asp file it still works
        > but most of the time it tacks on an error message at the end of the
        > page. For example if I have a .asp file with the following:
        >
        > <%@ Language=PerlScript %>
        > <%
        > print "Hello World";
        > %>
        >
        > the Hello World will always show but underneath I randomly get the
        > following error message:
        >

        Make sure to upgrade to Apache::ASP 2.57, as the problem was fixed
        in that release.

        Regards,

        Josh

        ________________________________________________________________________
        Josh Chamas, Founder | NodeWorks - http://www.nodeworks.com
        Chamas Enterprises Inc. | NodeWorks Directory - http://dir.nodeworks.com
        http://www.chamas.com | Apache::ASP - http://www.apache-asp.org


        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      Your message has been successfully submitted and would be delivered to recipients shortly.