Loading ...
Sorry, an error occurred while loading the content.
 

RE: I see only the text of the script rather than whatever the script is supposed to produce

Expand Messages
  • Randy Kobes
    ... This was probably from a mod_perl 1 document - for Apache 2, you want mod_perl 2 (http://perl.apache.org/ has separate mod_perl 1 and 2 sections, including
    Message 1 of 4 , Dec 23, 2003
      On Tue, 23 Dec 2003, Ted Byers wrote:

      > Hi Randy,
      >
      > Thanks.
      >
      > This is the perl-5.8/Apache-2 distribution.
      >
      > I will therefore change "<Location /perl>" to:
      > PerlModule ModPerl::Registry
      > <Location /perl>
      > SetHandler perl-script
      > PerlHandler ModPerl::Registry
      > Options +ExecCGI
      > PerlSendHeader On
      > allow from all
      > </Location>
      >
      > I had used "Apache::Registry" because that is what I saw in the
      > documentation, so someone probably wants to ensure that the documentation is
      > updated WRT this.

      This was probably from a mod_perl 1 document - for Apache 2,
      you want mod_perl 2 (http://perl.apache.org/ has separate
      mod_perl 1 and 2 sections, including some Win32 specific
      information).

      > The "the sample mod_perl registry, hello-world handler,
      > and Apache::ASP" don't work. When I try to go to them, I
      > get an error message saying they can't be found (though
      > the registy handler gives a configuration error instead).
      > But, I am puzzled as to why http://localhost/perl-status
      > works (or seems to).
      >
      > I wonder if the problem might lie in the following:
      >
      > <IfModule mod_perl.c>
      > Include conf/perl.conf
      > </IfModule>
      >
      > I start Apache using "Apache2\bin\apache -DSSL -k start",
      > and I am wondering if the reason it isn't working is that
      > Apache isn't processing perl.conf when it is started. If
      > this is true, how would I change the command I use to
      > start Apache (or can I safely get rid of the IfModule
      > lines above and below it).

      This is probably a bit off-topic for the asp list. What I'd
      suggest is, starting from the original configuration files
      that came with the distribution, trying to start things up
      (which should pull in conf/perl.conf, as mod_perl is enabled
      by default), and then try the sample ModPerl::Registry and
      Apache::ASP pages. If these don't work, send me (privately)
      what happens for each, and also what is recorded in
      Apache2's logs/error.log. Thanks.

      --
      best regards,
      randy

      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    Your message has been successfully submitted and would be delivered to recipients shortly.