Loading ...
Sorry, an error occurred while loading the content.

MLDBM error

Expand Messages
  • Tim Pushor
    Hi, I am having a weird problem. We had a server that was running a few Apache::ASP applications - had being the key word. After upgrading apache, and
    Message 1 of 3 , May 14 2:42 PM
    • 0 Attachment
      Hi,

      I am having a weird problem. We had a server that was running a few
      Apache::ASP applications - had being the key word. After upgrading
      apache, and rebuiding with the newest mod_perl, I installed the lastest
      Apache::ASP from CPAN (using the bundle), which installed MLDBM.

      Now, when I try to access one of the sites, I get the '500' error, and
      the apache log shows:

      [Wed May 14 14:47:51 2003] [error] sdbm store returned -1, errno 0, key
      "application" at /usr/local/lib/perl5/site_perl/5.005/MLDBM.pm line 161.
      MLDBM::STORE('MLDBM=HASH(0x87a4598)', 'application',
      'HASH(0x879f568)') called at
      /usr/local/lib/perl5/site_perl/5.005/MLDBM/Sync.pm line 87
      MLDBM::Sync::AUTOLOAD('MLDBM::Sync=HASH(0x879f694)',
      'application', 'HASH(0x879f568)') called at
      /usr/local/lib/perl5/site_perl/5.005/Apache/ASP/State.pm line 350
      Apache::ASP::State::STORE('Apache::ASP::State=HASH(0x879f43c)',
      'application', 'HASH(0x879f568)') called at
      /usr/local/lib/perl5/site_perl/5.005/Apache/ASP/State.pm line 93
      Apache::ASP::State::new('Apache::ASP=HASH(0x85cd58c)',
      'application', 'server') called at
      /usr/local/lib/perl5/site_perl/5.005/Apache/ASP/State.pm line 321
      Apache::ASP::State::TIEHASH('Apache::ASP::State',
      'Apache::ASP=HASH(0x85cd58c)', 'application', 'server') called at
      /usr/local/lib/perl5/site_perl/5.005/Apache/ASP/Application.pm line 17
      Apache::ASP::Application::new('Apache::ASP=HASH(0x85cd58c)')
      called at
      /usr/local/lib/perl5/site_perl/5.005/Apache/ASP/StateManager.pm line 70
      Apache::ASP::InitState('Apache::ASP=HASH(0x85cd58c)') called at
      /usr/local/lib/perl5/site_perl/5.005/Apache/ASP.pm line 398
      Apache::ASP::new('Apache::ASP', 'Apache=SCALAR(0x868d168)',
      '/var/spool/www/evolving/htdocs/Index.html') called at
      /usr/local/lib/perl5/site_perl/5.005/Apache/ASP.pm line 169
      Apache::ASP::handler('Apache=SCALAR(0x868d168)') called at
      /dev/null line 0
      eval {...} called at /dev/null line 0


      the funny thing is that I have state disabled on this particular vhost:

      AddHandler perl-script .html
      PerlHandler Apache::ASP
      PerlSetVar Global /var/spool/www/csa-pdk/global
      PerlSetVar StateDir /tmp
      PerlSetVar CookiePath /
      PerlSetVar SessionTimeout 10
      PerlSetVar AllowSessionState 0
      PerlSetVar AllowApplicationState 0
      PerlSetVar FileUploadTemp 1

      I have 4 virtual hosts setup this way, none work. I do have another
      application though, that does use sessions (AllowSessionState 1) and it
      works!

      I don't really know where to turn, as I'm not really sure why MLDBM is
      being used anyway?

      Any help would be greatly appreciated.

      Thanks,
      Tim



      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Josh Chamas
      ... Set either NoState to 1, or AllowSessionState to Off, and AllowApplicationState to Off. Per a previous post, it seems that 0 values may not be getting
      Message 2 of 3 , May 14 3:07 PM
      • 0 Attachment
        Tim Pushor wrote:
        > Hi,
        >
        > I am having a weird problem. We had a server that was running a few
        > Apache::ASP applications - had being the key word. After upgrading
        > apache, and rebuiding with the newest mod_perl, I installed the lastest
        > Apache::ASP from CPAN (using the bundle), which installed MLDBM.
        >
        > Now, when I try to access one of the sites, I get the '500' error, and
        > the apache log shows:
        > ...

        > AddHandler perl-script .html
        > PerlHandler Apache::ASP
        > PerlSetVar Global /var/spool/www/csa-pdk/global
        > PerlSetVar StateDir /tmp
        > PerlSetVar CookiePath /
        > PerlSetVar SessionTimeout 10
        > PerlSetVar AllowSessionState 0
        > PerlSetVar AllowApplicationState 0
        > PerlSetVar FileUploadTemp 1
        >

        Set either NoState to 1, or AllowSessionState to Off,
        and AllowApplicationState to Off.

        Per a previous post, it seems that 0 values may not be getting returned
        properly from dir_config() settings.

        Regards,

        Josh
        ________________________________________________________________
        Josh Chamas, Founder phone:925-552-0128
        Chamas Enterprises Inc. http://www.chamas.com
        NodeWorks Link Checking http://www.nodeworks.com


        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      • Tim Pushor
        Josh, You were absolutely correct. I changed both AllowSessionState and AllowApplicationState to Off, and it worked. Thanks for the extremely quick response,
        Message 3 of 3 , May 14 7:32 PM
        • 0 Attachment
          Josh,

          You were absolutely correct. I changed both AllowSessionState and
          AllowApplicationState to Off, and it worked.

          Thanks for the extremely quick response, and the great support.

          Tim


          Josh Chamas wrote:

          > Tim Pushor wrote:
          >
          >> Hi,
          >>
          >> I am having a weird problem. We had a server that was running a few
          >> Apache::ASP applications - had being the key word. After upgrading
          >> apache, and rebuiding with the newest mod_perl, I installed the
          >> lastest Apache::ASP from CPAN (using the bundle), which installed MLDBM.
          >>
          >> Now, when I try to access one of the sites, I get the '500' error,
          >> and the apache log shows:
          >> ...
          >
          >
          >> AddHandler perl-script .html
          >> PerlHandler Apache::ASP
          >> PerlSetVar Global /var/spool/www/csa-pdk/global
          >> PerlSetVar StateDir /tmp
          >> PerlSetVar CookiePath /
          >> PerlSetVar SessionTimeout 10
          >> PerlSetVar AllowSessionState 0
          >> PerlSetVar AllowApplicationState 0
          >> PerlSetVar FileUploadTemp 1
          >>
          >
          > Set either NoState to 1, or AllowSessionState to Off,
          > and AllowApplicationState to Off.
          >
          > Per a previous post, it seems that 0 values may not be getting returned
          > properly from dir_config() settings.
          >
          > Regards,
          >
          > Josh
          > ________________________________________________________________
          > Josh Chamas, Founder phone:925-552-0128
          > Chamas Enterprises Inc. http://www.chamas.com
          > NodeWorks Link Checking http://www.nodeworks.com
          >
          >
          > ---------------------------------------------------------------------
          > To unsubscribe, e-mail: asp-unsubscribe@...
          > For additional commands, e-mail: asp-help@...
          >



          ---------------------------------------------------------------------
          To unsubscribe, e-mail: asp-unsubscribe@...
          For additional commands, e-mail: asp-help@...
        Your message has been successfully submitted and would be delivered to recipients shortly.