Loading ...
Sorry, an error occurred while loading the content.

Strange behavoir with an ASP application

Expand Messages
  • Marcos.Nobre@stj.gov.br
    I have added lines bellow, in my Vhosts.conf file NameVirtualHost 127.0.0.1 ServerName alliance DocumentRoot /var/www/html/alliance
    Message 1 of 2 , Jan 24, 2002
    • 0 Attachment
      I have added lines bellow, in my Vhosts.conf file

      NameVirtualHost 127.0.0.1
      <VirtualHost 127.0.0.1>
      ServerName alliance
      DocumentRoot /var/www/html/alliance
      <Files ~ (\.asp)>
      SetHandler perl-script
      PerlModule Apache::ASP
      PerlHandler Apache::ASP
      PerlSetVar Global .
      PerlSetVar StateDir /tmp/asp
      <Files>
      </VirtualHost>

      and when a call ./httpd restart I have receiving the error :

      Syntax error on line 51 of /etc/httpd/conf/vhosts/Vhosts.conf :
      "Invalid command 'PerlModule', perhaps mis-spelled or defined
      by a module not included in the server configuration"

      The <Files> directive was suggested by a Apache-Asp config
      information over its web-site.

      Any Clue ? It seems that perl module isn't enabled. My Apache
      instalation was drived by my distro (Mandrake 8.1) and I installed
      the Apache_ASP package and many things correlated with perl.
      My httpd (service) always start httpd-perl prior to httpd.

      It is enough to get ASP running ?

      I heard something like



      "mod_gzip_on No"
      entry be necessary. Where and How ?

      10ks.

      Marcos Nobre.









      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Joshua Chamas
      ... Your httpd-perl is probably driven off of different config data than your httpd service, & you probably added the PerlModule to the httpd server conf where
      Message 2 of 2 , Jan 26, 2002
      • 0 Attachment
        Marcos.Nobre@... wrote:
        > ...
        > Syntax error on line 51 of /etc/httpd/conf/vhosts/Vhosts.conf :
        > "Invalid command 'PerlModule', perhaps mis-spelled or defined
        > by a module not included in the server configuration"
        >
        > The <Files> directive was suggested by a Apache-Asp config
        > information over its web-site.
        >
        > Any Clue ? It seems that perl module isn't enabled. My Apache
        > instalation was drived by my distro (Mandrake 8.1) and I installed
        > the Apache_ASP package and many things correlated with perl.
        > My httpd (service) always start httpd-perl prior to httpd.
        >
        > It is enough to get ASP running ?

        Your httpd-perl is probably driven off of different config
        data than your httpd service, & you probably added the
        PerlModule to the httpd server conf where mod_perl was not
        loaded ( DSO ) or compiled in.

        So make sure you know where your httpd-perl service gets
        its config data from... this might be from a block like:

        <IfDefine Perl>
        PerlModule Apache::ASP
        </IfDefine>

        where httpd-perl is started with -D Perl, or might be
        an entirely different config file like httpd-perl.conf,
        but this seems dependent on how your system is configured.
        One thing you can try is to grep your *.conf files for
        PerlModule to see where mod_perl conf should be working.

        -- Josh
        _________________________________________________________________
        Joshua Chamas Chamas Enterprises Inc.
        NodeWorks Founder Huntington Beach, CA USA
        http://www.nodeworks.com 1-714-625-4051

        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      Your message has been successfully submitted and would be delivered to recipients shortly.