Loading ...
Sorry, an error occurred while loading the content.

Redirection Limit Exceeded

Expand Messages
  • Richard Curtis
    This is slightly off topic so firstly I apologies for that. I am developing a web application in Apache::ASP with Apache2 on linux. Everything was going fine,
    Message 1 of 4 , Feb 10, 2003
    • 0 Attachment
      This is slightly off topic so firstly I apologies for that.
      I am developing a web application in Apache::ASP with Apache2 on linux.

      Everything was going fine, until this morning.
      I go to use the application, and my session had timed out, so the code
      tried to redirect me to a login page.

      All my pages use a header.inc which includes a menu for example.
      The problem is, if I point my browser at <url>/login.asp (or any other
      page for that matter), it goes into an endless redirect loop :(
      Mozilla says "Redirect Limit Exceeded" and IE just fails to load the page.

      Now I have obviously introduced a bug somewhere, but does anyone have
      any suggestions as to how I can go about debugging it ?

      Richard


      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Josh Chamas
      ... Try setting PerlSetVar Debug -1, which will tell you more of what is going on at the system level in the error_log, and then you can add a hook like
      Message 2 of 4 , Feb 10, 2003
      • 0 Attachment
        Richard Curtis wrote:
        > This is slightly off topic so firstly I apologies for that.
        > I am developing a web application in Apache::ASP with Apache2 on linux.
        >
        > Everything was going fine, until this morning.
        > I go to use the application, and my session had timed out, so the code
        > tried to redirect me to a login page.
        >
        > All my pages use a header.inc which includes a menu for example.
        > The problem is, if I point my browser at <url>/login.asp (or any other
        > page for that matter), it goes into an endless redirect loop :(
        > Mozilla says "Redirect Limit Exceeded" and IE just fails to load the page.
        >
        > Now I have obviously introduced a bug somewhere, but does anyone have
        > any suggestions as to how I can go about debugging it ?
        >

        Try setting PerlSetVar Debug -1, which will tell you more of what is
        going on at the system level in the error_log, and then you can add
        a hook like $Response->Debug(...) into your global.asa Script_OnStart
        for further debugging information.

        Regards,

        Josh

        ________________________________________________________________
        Josh Chamas, Founder phone:925-552-0128
        Chamas Enterprises Inc. http://www.chamas.com
        NodeWorks Link Checking http://www.nodeworks.com


        ---------------------------------------------------------------------
        To unsubscribe, e-mail: asp-unsubscribe@...
        For additional commands, e-mail: asp-help@...
      • Richard Curtis
        ... Thanks for the feedback. I have solved it now. I had a test like if ($whatever == $test) but somehow I deleted 1 = so it became an assignment, leading to
        Message 3 of 4 , Feb 10, 2003
        • 0 Attachment
          >> This is slightly off topic so firstly I apologies for that.
          >> I am developing a web application in Apache::ASP with Apache2 on linux.
          >>
          >> Everything was going fine, until this morning.
          >> I go to use the application, and my session had timed out, so the code
          >> tried to redirect me to a login page.
          >>
          >> All my pages use a header.inc which includes a menu for example.
          >> The problem is, if I point my browser at <url>/login.asp (or any other
          >> page for that matter), it goes into an endless redirect loop :(
          >> Mozilla says "Redirect Limit Exceeded" and IE just fails to load the
          >> page.
          >>
          >> Now I have obviously introduced a bug somewhere, but does anyone have
          >> any suggestions as to how I can go about debugging it ?
          >>
          >
          > Try setting PerlSetVar Debug -1, which will tell you more of what is
          > going on at the system level in the error_log, and then you can add
          > a hook like $Response->Debug(...) into your global.asa Script_OnStart
          > for further debugging information.

          Thanks for the feedback.
          I have solved it now. I had a test like if ($whatever == $test) but
          somehow I deleted 1 = so it became an assignment, leading to an infinite
          loop :(

          All sorted now
          Thanks again
          Richard


          ---------------------------------------------------------------------
          To unsubscribe, e-mail: asp-unsubscribe@...
          For additional commands, e-mail: asp-help@...
        • Joel Hughes
          ... I love that mistake.... How many times have a made that one! joel ... Outgoing mail is certified Virus Free. Checked by AVG anti-virus system
          Message 4 of 4 , Feb 10, 2003
          • 0 Attachment
            >>...ed 1 = so it became an assignment,

            I love that mistake....

            How many times have a made that one!

            joel

            ---

            ---
            Outgoing mail is certified Virus Free.
            Checked by AVG anti-virus system (http://www.grisoft.com).
            Version: 6.0.445 / Virus Database: 250 - Release Date: 21/01/2003



            ---------------------------------------------------------------------
            To unsubscribe, e-mail: asp-unsubscribe@...
            For additional commands, e-mail: asp-help@...
          Your message has been successfully submitted and would be delivered to recipients shortly.