Loading ...
Sorry, an error occurred while loading the content.

2222Re: peculiar error (?)

Expand Messages
  • Thanos Chatziathanassiou
    Nov 27, 2007
      Joshua Chamas wrote:
      > Thanos Chatziathanassiou wrote:
      >> Since yesterday, apache keeps spitting stuff like this in its error log:
      >> ---snip---
      >> compilation error: file unknown-000437603808 element output
      >> invalid value for method: HTML
      >> ---snip---
      >> without further info.
      >> The error message is always like this, with only the
      >> ``unknown-XXXXXXXXXXXX'' part different. Comparing this to the
      >> access.log doesn't reveal any erred requests, i.e. all entries around
      >> that time are 200's or 304's.
      >> The lack of a timestamp on the message does not make me very
      >> confident about the no-errors part, but this is as far as I could see.
      >>
      >> Anyone know who/what might by emitting these messages (google did
      >> return something about HTML::FormValidator::Results and HTML::Lint,
      >> but I'm not using either) ?
      >>
      >>
      >> Thanos Chatziathanassiou
      >>
      >
      > Its pretty odd.
      >
      > The only references to this I find are libxml and libxslt using by
      > XML::LibXML
      >
      > http://www.google.com/search?hl=en&client=firefox-a&rls=org.mozilla%3Aen-US%3Aofficial&hs=kgF&q=%22compilation+error%3A+file+unknown%22+element+output&btnG=Search
      >
      >
      > You might be using XSLT functionality with Apache::ASP?
      You're right, I am. After several adventures with XML::Sablotron, I
      switched to XML::LibXML for our XSLT needs, mainly due to better error
      handling/reporting.
      It might be faster too, but not so much as to be noticeable.
      Still, I've run into quite few problems getting both of them and their
      respective perl modules to work.
      (e.g. if you recall ``XML::LibXSLT violent death'' from 29/03/2007)
      I have upgraded to apache-1.3.39 with mod_perl/1.30 recently...maybe
      this has something to do with. I'll investigate further and report my
      findings.
      Thanks for the tip.


      ---------------------------------------------------------------------
      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Show all 3 messages in this topic