Loading ...
Sorry, an error occurred while loading the content.

1001Re: Problem with global.asa

Expand Messages
  • Josh Chamas
    Feb 2, 2003
    • 0 Attachment
      Oleg Kobyakovskiy wrote:
      > Hello Everybody,
      > I have next problem:
      > I have 2 sites example.com and admin.example.com. They are under
      > Apache::ASP both, placed in differert path and each of then has own
      > global.asa file. Sometime when I'm trying to look at admin.example.com
      > it runs the Application_OnStart function from example.com site and fills
      > the $Application by example.com site values. So I can work with
      > admin.example.com site after application finished only or after I
      > restart apche and remove state folders.
      > I use Apache/2.0.44 (Unix) mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.44
      > OpenSSL/0.9.6g DAV/2. I had the same problem with apache-1.3.x,
      > mod_perl-1.27 and perl-5.6.1. Apache::ASP version is 2.49, OS Linux.
      > All ASP settings are in the .htaccess files in both sites.
      > Does somebody know what is wrong.

      Make sure they use different GlobalPackage settings, as that is
      the package that events like Application_OnStart are compiled into.
      So using different global.asa with the same GlobalPackage settings
      should be avoided generally.

      If you are not using GlobalPackage config, it would be helpful
      if you could post your .htaccess files & PerlSetVar settings
      from httpd.conf to figure out what the problem might be.



      Josh Chamas, Founder phone:925-552-0128
      Chamas Enterprises Inc. http://www.chamas.com
      NodeWorks Link Checking http://www.nodeworks.com

      To unsubscribe, e-mail: asp-unsubscribe@...
      For additional commands, e-mail: asp-help@...
    • Show all 3 messages in this topic