Loading ...
Sorry, an error occurred while loading the content.
 

Eclipse Plugin - Problem

Expand Messages
  • Thomas Jackson III
    Hi all, I am using the Eclipse plugin(version 1.0.3) for Antlr development and have run across an anomaly that someone hopefully has an answer to. I have the
    Message 1 of 5 , Jun 5, 2003
      Hi all,

      I am using the Eclipse plugin(version 1.0.3) for Antlr development and have
      run across an anomaly that someone hopefully has an answer to.

      I have the following tokens declared in the Lexer

      NOT : '¬';
      NG : "¬>";
      NL : "¬<";
      NE : "¬=";

      When I compile the grammar in Eclipse it returns the following errors.

      Token stream error reading grammar(s): jcl.g
      unexpected char: '''

      Now, if I go to a command prompt and run the exact same Grammar using
      antlr.jar(version 2.7.2) from the Antlr download, I get no errors.

      It has to do with the ¬ character, but why would it generate code in one and
      fail in the other?

      Any suggestions as to what may be causing this?

      Thanks
      Thomas Jackson
    • mzukowski@yci.com
      Bizarre. Is there any way to see how antlr was invoked? Any chance of seeing the version number from antlr starting up? Monty ... From: Thomas Jackson III
      Message 2 of 5 , Jun 5, 2003
        Bizarre. Is there any way to see how antlr was invoked? Any chance of
        seeing the version number from antlr starting up?

        Monty

        -----Original Message-----
        From: Thomas Jackson III [mailto:thomas.jackson@...]
        Sent: Thursday, June 05, 2003 8:08 AM
        To: antlr-interest@yahoogroups.com
        Subject: [antlr-interest] Eclipse Plugin - Problem


        Hi all,

        I am using the Eclipse plugin(version 1.0.3) for Antlr development and have
        run across an anomaly that someone hopefully has an answer to.

        I have the following tokens declared in the Lexer

        NOT : '¬';
        NG : "¬>";
        NL : "¬<";
        NE : "¬=";

        When I compile the grammar in Eclipse it returns the following errors.

        Token stream error reading grammar(s): jcl.g
        unexpected char: '''

        Now, if I go to a command prompt and run the exact same Grammar using
        antlr.jar(version 2.7.2) from the Antlr download, I get no errors.

        It has to do with the ¬ character, but why would it generate code in one and
        fail in the other?

        Any suggestions as to what may be causing this?

        Thanks
        Thomas Jackson




        Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      • lgcraymer
        I had a thought. Vanilla eclipse probably ships with the ANTLR 2.7.1 jar--ANTLR is used for the refactoring support--and the antlr plugin may use the
        Message 3 of 5 , Jun 5, 2003
          I had a thought. "Vanilla" eclipse probably ships with the ANTLR
          2.7.1 jar--ANTLR is used for the refactoring support--and the antlr
          plugin may use the built-in jar file instead of the 2.7.2 supplied.
          The error reported would be consistent with that--2.7.2 has a wider
          default character range than 2.7.1.

          --Loring


          --- In antlr-interest@yahoogroups.com, mzukowski@y... wrote:
          > Bizarre. Is there any way to see how antlr was invoked? Any chance
          of
          > seeing the version number from antlr starting up?
          >
          > Monty
          >
          > -----Original Message-----
          > From: Thomas Jackson III [mailto:thomas.jackson@m...]
          > Sent: Thursday, June 05, 2003 8:08 AM
          > To: antlr-interest@yahoogroups.com
          > Subject: [antlr-interest] Eclipse Plugin - Problem
          >
          >
          > Hi all,
          >
          > I am using the Eclipse plugin(version 1.0.3) for Antlr development
          and have
          > run across an anomaly that someone hopefully has an answer to.
          >
          > I have the following tokens declared in the Lexer
          >
          > NOT : '¬';
          > NG : "¬>";
          > NL : "¬<";
          > NE : "¬=";
          >
          > When I compile the grammar in Eclipse it returns the following
          errors.
          >
          > Token stream error reading grammar(s): jcl.g
          > unexpected char: '''
          >
          > Now, if I go to a command prompt and run the exact same Grammar
          using
          > antlr.jar(version 2.7.2) from the Antlr download, I get no errors.
          >
          > It has to do with the ¬ character, but why would it generate code in
          one and
          > fail in the other?
          >
          > Any suggestions as to what may be causing this?
          >
          > Thanks
          > Thomas Jackson
          >
          >
          >
          >
          > Your use of Yahoo! Groups is subject to
          http://docs.yahoo.com/info/terms/
        • Thomas Jackson III
          Loring, Thanks for the information. Unfortunately, I have not been able to find another JAR file which contains antlr except the 2.7.2 version of the plug-in.
          Message 4 of 5 , Jun 16, 2003
            Loring,

            Thanks for the information. Unfortunately, I have not been able to find
            another JAR file which contains antlr except the 2.7.2 version of the
            plug-in. If anyone might know of a solution or suggestion I would greatly
            appreciate it.

            Thanks
            Thomas

            -----Original Message-----
            From: lgcraymer [mailto:lgc@...]
            Sent: Thursday, June 05, 2003 4:47 PM
            To: antlr-interest@yahoogroups.com
            Subject: [antlr-interest] Re: Eclipse Plugin - Problem


            I had a thought. "Vanilla" eclipse probably ships with the ANTLR
            2.7.1 jar--ANTLR is used for the refactoring support--and the antlr
            plugin may use the built-in jar file instead of the 2.7.2 supplied.
            The error reported would be consistent with that--2.7.2 has a wider
            default character range than 2.7.1.

            --Loring


            --- In antlr-interest@yahoogroups.com, mzukowski@y... wrote:
            > Bizarre. Is there any way to see how antlr was invoked? Any chance
            of
            > seeing the version number from antlr starting up?
            >
            > Monty
            >
            > -----Original Message-----
            > From: Thomas Jackson III [mailto:thomas.jackson@m...]
            > Sent: Thursday, June 05, 2003 8:08 AM
            > To: antlr-interest@yahoogroups.com
            > Subject: [antlr-interest] Eclipse Plugin - Problem
            >
            >
            > Hi all,
            >
            > I am using the Eclipse plugin(version 1.0.3) for Antlr development
            and have
            > run across an anomaly that someone hopefully has an answer to.
            >
            > I have the following tokens declared in the Lexer
            >
            > NOT : '¬';
            > NG : "¬>";
            > NL : "¬<";
            > NE : "¬=";
            >
            > When I compile the grammar in Eclipse it returns the following
            errors.
            >
            > Token stream error reading grammar(s): jcl.g
            > unexpected char: '''
            >
            > Now, if I go to a command prompt and run the exact same Grammar
            using
            > antlr.jar(version 2.7.2) from the Antlr download, I get no errors.
            >
            > It has to do with the ¬ character, but why would it generate code in
            one and
            > fail in the other?
            >
            > Any suggestions as to what may be causing this?
            >
            > Thanks
            > Thomas Jackson
            >
            >
            >
            >
            > Your use of Yahoo! Groups is subject to
            http://docs.yahoo.com/info/terms/




            Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
          • Thomas Jackson III
            Well.....I went back to the Eclipse plugin site on sourceforge and found a later version of the ANTLR it was the final build of antlr. Installed this plugin
            Message 5 of 5 , Jun 16, 2003
              Well.....I went back to the Eclipse plugin site on sourceforge and found a
              later version of the ANTLR it was the "final build" of antlr. Installed
              this plugin and everything now works. If you haven't upgraded you should
              probably do so.

              Thanks for your help!

              Thomas

              -----Original Message-----
              From: Thomas Jackson III [mailto:thomas.jackson@...]
              Sent: Monday, June 16, 2003 2:27 PM
              To: antlr-interest@yahoogroups.com
              Subject: RE: [antlr-interest] Re: Eclipse Plugin - Problem


              Loring,

              Thanks for the information. Unfortunately, I have not been able to find
              another JAR file which contains antlr except the 2.7.2 version of the
              plug-in. If anyone might know of a solution or suggestion I would greatly
              appreciate it.

              Thanks
              Thomas

              -----Original Message-----
              From: lgcraymer [mailto:lgc@...]
              Sent: Thursday, June 05, 2003 4:47 PM
              To: antlr-interest@yahoogroups.com
              Subject: [antlr-interest] Re: Eclipse Plugin - Problem


              I had a thought. "Vanilla" eclipse probably ships with the ANTLR
              2.7.1 jar--ANTLR is used for the refactoring support--and the antlr
              plugin may use the built-in jar file instead of the 2.7.2 supplied.
              The error reported would be consistent with that--2.7.2 has a wider
              default character range than 2.7.1.

              --Loring


              --- In antlr-interest@yahoogroups.com, mzukowski@y... wrote:
              > Bizarre. Is there any way to see how antlr was invoked? Any chance
              of
              > seeing the version number from antlr starting up?
              >
              > Monty
              >
              > -----Original Message-----
              > From: Thomas Jackson III [mailto:thomas.jackson@m...]
              > Sent: Thursday, June 05, 2003 8:08 AM
              > To: antlr-interest@yahoogroups.com
              > Subject: [antlr-interest] Eclipse Plugin - Problem
              >
              >
              > Hi all,
              >
              > I am using the Eclipse plugin(version 1.0.3) for Antlr development
              and have
              > run across an anomaly that someone hopefully has an answer to.
              >
              > I have the following tokens declared in the Lexer
              >
              > NOT : '¬';
              > NG : "¬>";
              > NL : "¬<";
              > NE : "¬=";
              >
              > When I compile the grammar in Eclipse it returns the following
              errors.
              >
              > Token stream error reading grammar(s): jcl.g
              > unexpected char: '''
              >
              > Now, if I go to a command prompt and run the exact same Grammar
              using
              > antlr.jar(version 2.7.2) from the Antlr download, I get no errors.
              >
              > It has to do with the ¬ character, but why would it generate code in
              one and
              > fail in the other?
              >
              > Any suggestions as to what may be causing this?
              >
              > Thanks
              > Thomas Jackson
              >
              >
              >
              >
              > Your use of Yahoo! Groups is subject to
              http://docs.yahoo.com/info/terms/




              Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/




              Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
            Your message has been successfully submitted and would be delivered to recipients shortly.