Loading ...
Sorry, an error occurred while loading the content.

Search/Replace Single Quote Bug

Expand Messages
  • Thomas Bätzler
    This pertains to Jutoh 1.22; I haven t verified if the bug was present in earlier versions. I have gotten a Jutoh project file from somebody else that I m
    Message 1 of 5 , Jan 3, 2011
    View Source
    • 0 Attachment
      This pertains to Jutoh 1.22; I haven't verified if the bug was present
      in earlier versions.

      I have gotten a Jutoh project file from somebody else that I'm trying to
      tidy up - like, change single quote characters into apostrophe
      characters. However, I'm running into a problem when I'm trying to get
      the single quote character into the search/replace dialog. I've marked
      an offending section of text like "<single quote>d<blank>" and copied
      it. When I paste that selection to the "search" text field of either
      "search" or "search and replace" dialogs, the single quote's changed to
      an apostrophe. Typing in the text manually doesn't work either.

      Cheers,
      Thomas
    • Julian Smart
      ... Maybe turn off auto-quotes? See View - Auto-Replace Preferences, click on Custom Quotes, clear Replace single quotation marks . Regards, Julian ... --
      Message 2 of 5 , Jan 3, 2011
      View Source
      • 0 Attachment
        On 03/01/2011 13:51, Thomas Bätzler wrote:
        > This pertains to Jutoh 1.22; I haven't verified if the bug was present
        > in earlier versions.
        >
        > I have gotten a Jutoh project file from somebody else that I'm trying to
        > tidy up - like, change single quote characters into apostrophe
        > characters. However, I'm running into a problem when I'm trying to get
        > the single quote character into the search/replace dialog. I've marked
        > an offending section of text like "<single quote>d<blank>" and copied
        > it. When I paste that selection to the "search" text field of either
        > "search" or "search and replace" dialogs, the single quote's changed to
        > an apostrophe. Typing in the text manually doesn't work either.
        Maybe turn off auto-quotes? See View -> Auto-Replace Preferences, click
        on Custom Quotes, clear "Replace single quotation marks".

        Regards,

        Julian
        > Cheers,
        > Thomas
        >
        >
        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >


        --
        Julian Smart, Anthemion Software Ltd.
        28/5 Gillespie Crescent, Edinburgh, Midlothian, EH10 4HU
        www.anthemion.co.uk | +44 (0)131 229 5306
        Tools for writers: www.writerscafe.co.uk
        wxWidgets RAD: www.dialogblocks.com
        Blog: www.juliansmart.com
      • Thomas Bätzler
        Hi Julian, ... The single quote that I selected and pasted to the search/replace dialog is still shown as an apostrophe, but now at least search/replace works
        Message 3 of 5 , Jan 3, 2011
        View Source
        • 0 Attachment
          Hi Julian,

          Am 03/01/2011 15:03, schrieb Julian Smart:
          > On 03/01/2011 13:51, Thomas Bätzler wrote:
          >> This pertains to Jutoh 1.22; I haven't verified if the bug was present
          >> in earlier versions.
          >>
          >> I have gotten a Jutoh project file from somebody else that I'm trying to
          >> tidy up - like, change single quote characters into apostrophe
          >> characters. However, I'm running into a problem when I'm trying to get
          >> the single quote character into the search/replace dialog. I've marked
          >> an offending section of text like "<single quote>d<blank>" and copied
          >> it. When I paste that selection to the "search" text field of either
          >> "search" or "search and replace" dialogs, the single quote's changed to
          >> an apostrophe. Typing in the text manually doesn't work either.
          > Maybe turn off auto-quotes? See View -> Auto-Replace Preferences, click
          > on Custom Quotes, clear "Replace single quotation marks".

          The single quote that I selected and pasted to the search/replace dialog
          is still shown as an apostrophe, but now at least search/replace works ;-)

          Thanks,
          Thomas
        • Julian Smart
          ... I find it strange that a conversion between two characters is going on with the standard search/replace dialog. I can t explain that at all! Something
          Message 4 of 5 , Jan 3, 2011
          View Source
          • 0 Attachment
            On 03/01/2011 16:26, Thomas Bätzler wrote:
            > Hi Julian,
            >
            > Am 03/01/2011 15:03, schrieb Julian Smart:
            >> On 03/01/2011 13:51, Thomas Bätzler wrote:
            >>> This pertains to Jutoh 1.22; I haven't verified if the bug was present
            >>> in earlier versions.
            >>>
            >>> I have gotten a Jutoh project file from somebody else that I'm trying to
            >>> tidy up - like, change single quote characters into apostrophe
            >>> characters. However, I'm running into a problem when I'm trying to get
            >>> the single quote character into the search/replace dialog. I've marked
            >>> an offending section of text like "<single quote>d<blank>" and copied
            >>> it. When I paste that selection to the "search" text field of either
            >>> "search" or "search and replace" dialogs, the single quote's changed to
            >>> an apostrophe. Typing in the text manually doesn't work either.
            >> Maybe turn off auto-quotes? See View -> Auto-Replace Preferences, click
            >> on Custom Quotes, clear "Replace single quotation marks".
            > The single quote that I selected and pasted to the search/replace dialog
            > is still shown as an apostrophe, but now at least search/replace works ;-)
            I find it strange that a conversion between two characters is going on
            with the standard search/replace dialog. I can't explain that at all!
            Something platform-specific perhaps.

            Regards,

            Julian
            > Thanks,
            > Thomas
            >
            >
            >
            >
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
            >


            --
            Julian Smart, Anthemion Software Ltd.
            28/5 Gillespie Crescent, Edinburgh, Midlothian, EH10 4HU
            www.anthemion.co.uk | +44 (0)131 229 5306
            Tools for writers: www.writerscafe.co.uk
            wxWidgets RAD: www.dialogblocks.com
            Blog: www.juliansmart.com
          • Thomas Bätzler
            Hi Julian, ... Definitely yes :-/ It works fine on Debian Lenny, but not on Windows 7 (both times 64bit). While testing, I also noticed that undo behaves
            Message 5 of 5 , Jan 3, 2011
            View Source
            • 0 Attachment
              Hi Julian,

              Am 03/01/2011 17:33, schrieb Julian Smart:
              > On 03/01/2011 16:26, Thomas Bätzler wrote:
              >> Hi Julian,
              >>
              >> Am 03/01/2011 15:03, schrieb Julian Smart:
              >>> On 03/01/2011 13:51, Thomas Bätzler wrote:
              >>>> This pertains to Jutoh 1.22; I haven't verified if the bug was present
              >>>> in earlier versions.
              >>>>
              >>>> I have gotten a Jutoh project file from somebody else that I'm trying to
              >>>> tidy up - like, change single quote characters into apostrophe
              >>>> characters. However, I'm running into a problem when I'm trying to get
              >>>> the single quote character into the search/replace dialog. I've marked
              >>>> an offending section of text like "<single quote>d<blank>" and copied
              >>>> it. When I paste that selection to the "search" text field of either
              >>>> "search" or "search and replace" dialogs, the single quote's changed to
              >>>> an apostrophe. Typing in the text manually doesn't work either.
              >>> Maybe turn off auto-quotes? See View -> Auto-Replace Preferences, click
              >>> on Custom Quotes, clear "Replace single quotation marks".
              >> The single quote that I selected and pasted to the search/replace dialog
              >> is still shown as an apostrophe, but now at least search/replace works ;-)
              > I find it strange that a conversion between two characters is going on
              > with the standard search/replace dialog. I can't explain that at all!
              > Something platform-specific perhaps.
              Definitely yes :-/ It works fine on Debian Lenny, but not on Windows 7
              (both times 64bit).

              While testing, I also noticed that "undo" behaves (for me) unexpectedly
              after a search/replace over a multiple document project.
              I would have expected that a single undo would restore the previous
              state of all changed documents in the project. What happens is that only
              the last replace operation is undone. Having changed a hundered
              instances of some text, you realize that you'll have to keep on hitting
              "undo" for a while. However, further undo operations will undo previous
              replace operations only in the last document... and then they'll undo
              any previous changes to the last document instead of the jumping back to
              the previous document.

              Cheers,
              Thomas
            Your message has been successfully submitted and would be delivered to recipients shortly.