Loading ...
Sorry, an error occurred while loading the content.
 

Re: CP/M HEX file question

Expand Messages
  • tkaragiris
    Mike, Ok thanks. It s odd that MOVCPM is included but not configured for the APE distribution. I did manage to successfully use APEWRITE, but it only creates
    Message 1 of 41 , Jul 22, 2013
      Mike,

      Ok thanks. It's odd that MOVCPM is included but not configured for the APE distribution.

      I did manage to successfully use APEWRITE, but it only creates another cp/m system of the same size as the boot system.

      I've contacted the author so I'll see how I go with getting a response. Although as with much of this stuff it's from years ago.

      Thanks,
      Theo


      --- In altaircomputerclub@yahoogroups.com, "deramp5113" <deramp5113@...> wrote:
      >
      > Theo,
      >
      > You have the process right if MOVCPM has been modified to also move (relocate) the APE CBIOS, but I don't believe it has been.
      >
      > An unmodified MOVCPM has no clue what addresses in the APE CBIOS need to be relocated, so the CP/M image it generates is no good. If I had the source to the APE CBIOS, I could assemble it at the new address for a 56K CP/M and then patch the APE BIOS into the rest of CP/M (which MOVCPM does relocate correctly). However, neither of the BIOS source files on the APE distribution disks are actually the APE BIOS.
      >
      > Finally, I think Frank is correct in that even if you could create a valid CP/M image in memory, SYSGEN can't be used to write the CP/M boot image to the system tracks, you'd have to use APEWRITE instead at that point.
      >
      > Bottom line, you'll probably have to get the APE author to create a 48K or 56K version for you, or see if he'll send you the APE CBIOS source file.
      >
      > Mike
      >
      >
      > --- In altaircomputerclub@yahoogroups.com, "tkaragiris" <tkaragiris@> wrote:
      > >
      > > I tried to create a 56k cp/m disk but no luck. When I try to boot from it the system just hangs.
      > >
      > > Have I got the process right:
      > >
      > > - Put a blank disk in B (new file in APE on B drive).
      > >
      > > - From boot drive A (31k cp/m), I run: MOVCPM * *, this creates a 56k cp/m image in memory.
      > >
      > > - Then I run: SYSGEN, hit enter on source drive, select B for destination drive.
      > >
      > > I can see drive B being written to. On "Function complete" message, I hit enter to reboot. System reboots from A.
      > >
      > > If I then try and boot from the 56k disk, the system just hangs.
      > >
      > >
      > >
      > > --- In altaircomputerclub@yahoogroups.com, "tkaragiris" <tkaragiris@> wrote:
      > > >
      > > > Thanks for doing that Mike, so memory is the issue, that's great because it should be easy to fix.
      > > >
      > > > I did tinker a little with MOVCOP and SYSGEN in trying to make a 56k CP/M system on APE, but I've never used CP/M before so it's all new to me. The top 8k in my Altair has the 8k Bytesaver so the max memory I can run in CP/M is 56k. Hopefully that should be enough to run those bigger programs.
      > > >
      > > > I'll do some more testing and replicate the process to create a 56k CP/M system in Altair32 first.
      > > >
      > > >
      > > >
      > >
      >
    • tkaragiris
      Here s an update on the APE project posted by Frank on the VCF:
      Message 41 of 41 , Aug 8, 2013
      Your message has been successfully submitted and would be delivered to recipients shortly.