Loading ...
Sorry, an error occurred while loading the content.

Re: [Altair Computer Club] Re: Altair Checksum Loader Bugs

Expand Messages
  • Dan Roganti
    ... such as, a Teletype with a papertape option --the most common console of the day. The term bug being thrown around here is an outgrowth of the system
    Message 1 of 4 , Mar 22, 2013
    • 0 Attachment
      On Fri, Mar 22, 2013 at 5:58 PM, mfeberhard <eberhard@...> wrote:
       

      I saw this when I disassembled the loaders some years ago. (My disassebly of the 3.X and 4.X loaders are in the Files section.) I think this bug survived because most people either loaded through the console (so the ports were the same)


      such as, a Teletype with a papertape option --the most common console of the day.
      The term bug being thrown around here is an outgrowth of the system environment being used today and not then. You can always replicate the system environment back then by using a term program connected to your 2SIO and downloading, from within the Term program, the papertape *.bin files.

       
    • mfeberhard
      Well, it *is* a bug... MITS documentation says that switch A8 sets the laoader s stop bits for the 2SIO, but the code actually looks at switch A12 - which the
      Message 2 of 4 , Mar 22, 2013
      • 0 Attachment
        Well, it *is* a bug... MITS documentation says that switch A8 sets the laoader's stop bits for the 2SIO, but the code actually looks at switch A12 - which the documentation says should set the console stop bits.

        For example, If you used a MITS 88-VLCT terminal as your console (which connects to a parallel port) and you used a "MITS" 88-TTY teletype (with a paper tape reader) as your loader, then you would experience this bug - using all MITS hardware from the time of the Altair. And the Teletype loader would not work with the switches set according to the MITS documentation.

        -Martin

        --- In altaircomputerclub@yahoogroups.com, Dan Roganti <ragooman@...> wrote:
        >
        > On Fri, Mar 22, 2013 at 5:58 PM, mfeberhard <eberhard@...> wrote:
        >
        > > **
        > >
        > >
        > > I saw this when I disassembled the loaders some years ago. (My disassebly
        > > of the 3.X and 4.X loaders are in the Files section.) I think this bug
        > > survived because most people either loaded through the console (so the
        > > ports were the same)
        > >
        >
        > such as, a Teletype with a papertape option --the most common console of
        > the day.
        > The term bug being thrown around here is an outgrowth of the system
        > environment being used today and not then. You can always replicate the
        > system environment back then by using a term program connected to your 2SIO
        > and downloading, from within the Term program, the papertape *.bin files.
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.