Loading ...
Sorry, an error occurred while loading the content.

Re: Since you said it was ok to post Sol-20 questions... (power supply update)

Expand Messages
  • corey986
    Well I first want to thank Mike (deramp5113) for hanging on the phone while we took a look together at the supply on the Sol using my scope. Well looks like I
    Message 1 of 32 , Feb 18, 2013
    • 0 Attachment
      Well I first want to thank Mike (deramp5113) for hanging on the phone while we took a look together at the supply on the Sol using my scope.

      Well looks like I have a bad large cap for the 5V supply. We swapped in the large cap for the s100 bus and everything looked good. So now I have to find the right cap.

      Thanks again to everyone who helped...

      Cheers,
      Corey

      --- In altaircomputerclub@yahoogroups.com, "deramp5113" <deramp5113@...> wrote:
      >
      > Well I would have lost a bet on this one!
      >
      > For 5v out at .5 amps (your 10 ohm load), op amp pin 1 should be around 6.45 volts. Since your output voltages are still low, I assume pin 1 on the op amp is still at 5.19 volts or so?
      >
      > If Q1, Q2 failed open, you'd expect pin 1 of the op amp to be railed at +12 volts trying to get the output voltage up, but that's not the case.
      >
      > Based on previous measurements, the base-emitter junctions on Q1, Q2 seem fine, but if the transistor has lost it's gain, then one or both transistors essentially looks like a diode. In this case, pin 1 of the op amp is trying to source some or all of the current for the 5 volt supply through two diodes (or one diode and just one transistor) which, of course, it can't begin to keep up with. Possibly, this is why the op amp's output is only reaching 5.19 volts.
      >
      > Another possibility is that Q3 has failed in a partially on condition and is providing a low resistance path from op amp pin 1 straight to the 5 volt output. Again, this leaves the op amp trying to source the 5 volt supply's current draw, which it cant keep up with.
      >
      > I'd suspect and replace Q1 first, then move on to Q2, then to Q3 if necessary.
      >
      > If that doesn't work, lets get an oscilloscope and a video conference going!
      >
      > Mike
      >
      > --- In altaircomputerclub@yahoogroups.com, corey986 <no_reply@> wrote:
      > >
      > > Ok I replaced the op amp with a brand new one from mouser and everything is the same. 3.7-3.8 volts on the 5V.
      > >
      > > So it's not the tantalum caps, they have been replaced. Not the Op Amp...
      > >
      > > Bob Grieb has suggested it may be Q1 or Q2 may not be able to supply enought power or the actual SCR that is bad. So tomorrow I will grab the desoldering station and check those out. If any one else has any ideas while I have the board apart that I should check, let me know.
      > >
      > > Thanks everyone for all the help,
      > > Cheers,
      > > Corey ,
      > >
      >
    • deramp5113
      Nothing more satisfying than making some progress! Mike
      Message 32 of 32 , Feb 24, 2013
      • 0 Attachment
        Nothing more satisfying than making some progress!

        Mike

        --- In altaircomputerclub@yahoogroups.com, corey986 <no_reply@...> wrote:
        >
        > So I got a replacement 18000uf cap for about $8 plus shipping. Since there was a $15 minimum I also got a couple of exact replacement Apple II keyboard lamps I found while trying to get to $15 bucks.
        >
        > Anyway. The supply now makes a little over 5V and I plugged my personality module in and hooked my board up and I have perfect video and got a solos prompt.
        >
        > Can't do anymore testing till I rebuild my keyboard in a week or so, I have a couple of other small favor restoration/build projects to do first but this is awesome because now I'm up to the planned part of the Sol restoration, the keyboard and cosmetic cleanup for the case and motherboard.
        >
        > Thanks everyone who helped!!!
        >
        > Cheers,
        > Corey
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.