Loading ...
Sorry, an error occurred while loading the content.
 

Parasitic Engineering Power Supply Question

Expand Messages
  • WebFilter
    Hi, I m fairly new to the Club and recently acquired a nice Altair 8800 with some assembly required. (After waiting for 35 years, I finally got what I really
    Message 1 of 3 , Jan 27, 2011
      Hi,
      I'm fairly new to the Club and recently acquired a nice Altair 8800 with some assembly required.
      (After waiting for 35 years, I finally got what I really wanted for Christmas!) Anyway, I'm basically starting from "scratch" with several assembled boards, but first attempting to bring up the power supply by itself. So, it's a Parasitic Engineering "upgrade" and I found the "Errata" sheet and moved the 4.7K (R4) bleeder resistor to the proper place. I believe I have everything hooked up and the power supply is generating values slightly higher than specified.
      I'm seeing 17.5V on the +16V and 11.5V on the +8V supplies. Is this due to the fact that I don't have a load on the supply? (I don't have the front panel or backplane hooked up, yet.)
      Anyone out there an "expert" in power supplies?
      Thanks,
      Steve S.
    • k.perez@comcast.net
      Steve, The name is Keith Perez, and I am the chief restoration engineer at the Living Computer Museum in Seattle ( www.livingincomputermuseum.org ). I have
      Message 2 of 3 , Jan 27, 2011
        Steve,
        The name is Keith Perez, and I am the chief restoration engineer at the Living Computer Museum in Seattle ( www.livingincomputermuseum.org ).  I have recently restored two Altairs, an 8800 and an 8800B.  The voltages you quote are typical for an unloaded supply.  There was a rework applied to the early units and incorporated in the "B" version which put a regulator in with a series pass transistor.  I am running the vanilla 8800 without this modification, but you need a heavy load like a 16k or 32k memory card to bring the voltages into spec..
        Feel free to give me a reply if you need more direction.

        Regards,
        Keith Perez
        Senior Software Engineer
        Vulcan, Inc.

        ----- Original Message -----
        From: "WebFilter" <theprofessor@...>
        To: altaircomputerclub@yahoogroups.com
        Sent: Thursday, January 27, 2011 9:09:48 PM
        Subject: [Altair Computer Club] Parasitic Engineering Power Supply Question

         

        Hi,
        I'm fairly new to the Club and recently acquired a nice Altair 8800 with some assembly required.
        (After waiting for 35 years, I finally got what I really wanted for Christmas!) Anyway, I'm basically starting from "scratch" with several assembled boards, but first attempting to bring up the power supply by itself. So, it's a Parasitic Engineering "upgrade" and I found the "Errata" sheet and moved the 4.7K (R4) bleeder resistor to the proper place. I believe I have everything hooked up and the power supply is generating values slightly higher than specified.
        I'm seeing 17.5V on the +16V and 11.5V on the +8V supplies. Is this due to the fact that I don't have a load on the supply? (I don't have the front panel or backplane hooked up, yet.)
        Anyone out there an "expert" in power supplies?
        Thanks,
        Steve S.

      • mfeberhard
        Hi Steve, Congratulations on your new machine! You were lucky to find one with the Parasitic Engineering power supply - this was the cleanest and best-working
        Message 3 of 3 , Jan 28, 2011
          Hi Steve,

          Congratulations on your new machine! You were lucky to find one with the Parasitic Engineering power supply - this was the cleanest and best-working power supply upgrade for the Altair's original inadequate supply.

          Yes, these voltages sound about right. The power supply produces unregulated voltages, with a significant allowed voltage tolerance - every S-100 board (and your front panel) has linear regulators to bring this rough voltage down to the +5V, +12V, and -12V levels. They tend to run a little high when completely unloaded, and will probably still be a little high when only lightly loaded (3 or 4 S-100 boards). The idea is that by the time your Altair is fully loaded with boards, the unregulated voltages are still at least 3 volts higher than the outputs of the regulators - earlier linear voltage regulators required a minimum voltage drop of 3 volts.

          By the way, did you replace the row of electrolytic capacitors on the power supply board? Although you might see the right voltages on your voltmeter, the ripple will be out of spec if these capacitors have failed - and they most likely have at this age. (The particular caps that MITS used in the power supply seem to age badly.) Look closely at the positive end of these capacitors. If you see a nodule of dried-up goo brown hanging on the pressure vent of any capacitor, it is definitely bad. If you don't, it still might have dried out. I strongly suggest replacing these caps if you haven't already.

          Good luck and have fun!

          Martin

          --- In altaircomputerclub@yahoogroups.com, "WebFilter" <theprofessor@...> wrote:
          >
          > Hi,
          > I'm fairly new to the Club and recently acquired a nice Altair 8800 with some assembly required.
          > (After waiting for 35 years, I finally got what I really wanted for Christmas!) Anyway, I'm basically starting from "scratch" with several assembled boards, but first attempting to bring up the power supply by itself. So, it's a Parasitic Engineering "upgrade" and I found the "Errata" sheet and moved the 4.7K (R4) bleeder resistor to the proper place. I believe I have everything hooked up and the power supply is generating values slightly higher than specified.
          > I'm seeing 17.5V on the +16V and 11.5V on the +8V supplies. Is this due to the fact that I don't have a load on the supply? (I don't have the front panel or backplane hooked up, yet.)
          > Anyone out there an "expert" in power supplies?
          > Thanks,
          > Steve S.
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.