Loading ...
Sorry, an error occurred while loading the content.

1078Re: [Altair Computer Club] Altair 680 CSAVE Problems!@ : (

Expand Messages
  • Steve
    Jan 1, 2007
      Yeah, CSAVE"A" should work.

      Unlike the MSBASIC, PC BASIC, GW BASIC, and other BASICs that came
      later for the IBM PC, Altair BASIC wasn't finicky about spaces in
      commands, so it would treat these the same:
      CSAVE"A"
      CSAVE "A"

      I think the syntax for saving an ASCII file to tape is
      CSAVE"filename",A .

      It's a little trickier to save an ASCII file to disk. You must
      always give the drive number when using the ASCII option, such as
      SAVE"A",1,A

      The complete syntax for the SAVE (to DISK) command is
      SAVE"filename"[[,disk number],A]

      steve
      ========================

      --- In altaircomputerclub@yahoogroups.com, "H.E.Robert" <ueoguy@...>
      wrote:
      >
      > Grant,
      >
      >
      >
      > Try putting the filename in double quotes, CSAVE "A", as A is an
      integer
      > variable without quotes, and "with", is interpreted
      >
      > as an ASCII string??
      >
      >
      >
      > Just Bob!
      >
      >
      >
      > _____
      >
      > From: altaircomputerclub@yahoogroups.com
      > [mailto:altaircomputerclub@yahoogroups.com] On Behalf Of Grant
      Stockly
      > Sent: Monday, January 01, 2007 4:12 AM
      > To: altaircomputerclub@yahoogroups.com; cctalk@...
      > Subject: [Altair Computer Club] Altair 680 CSAVE Problems!@ : (
      >
      >
      >
      > I'm having a ton of trouble saving a program on a cassette tape
      using Altair
      > 680 basic. Was there a KCACR basic made without the CSAVE
      command? My
      > basic appears to have a CSAVE command, but it won't accept the
      name!!!!! :
      > (
      >
      > I'm sending this to two groups. I've been at this problem for
      hours now...
      > : (
      >
      > I'll post a transcript below. Let me know what I'm doing wrong! :
      (
      >
      > --------------------
      > .J FD00 (cassette bootstrap rom address)
      > (basic loading)
      > (basic loaded)
      > .J 0000 (run basic...)
      > MEMORY SIZE?
      > TERMINAL WIDTH? 80
      > WANT SIN-COS-TAN-ATN? YES
      >
      > 9604 BYTES FREE
      >
      > MITS ALTAIR 680 BASIC VERSION 1.1 REV 3.2
      > --KCACR--
      > COPYRIGHT 1976 BY MITS INC.
      >
      > OK
      > 10 PRINT "HELLO"
      > 20 GOTO 10
      > CSAVE A
      >
      > ?TM ERROR
      > OK
      > --------------------
      >
      > TM is a type mismatch error. SM is for a command it doesn't
      understand.
      > Watch...
      > --------------------
      > CSAVE A
      > ?TM ERROR
      > OK
      >
      > CSAVE
      > ?SN ERROR
      > OK
      >
      > AHHHH!
      > ?SN ERROR
      > OK
      >
      > AHHHH! A
      > ?SN ERROR
      > OK
      > --------------------
      >
      > Am I wrong assuming that because it gives me a TM error instead of
      SN that
      > it is "trying" to work? I get the same things for CLOAD... How in
      the
      > world are you supposed to save something to tape! : (
      >
      > If I have the wrong version of basic, anyone have the right one?
      What will
      > it take for me to get a copy! : ) (first smile in this e-
      mail... ; ) )
      >
      > Thanks,
      > Grant
      >
    • Show all 8 messages in this topic