Loading ...
Sorry, an error occurred while loading the content.

1076Altair 680 CSAVE Problems!@ : (

Expand Messages
  • Grant Stockly
    Jan 1, 2007
    • 0 Attachment
      I'm having a ton of trouble saving a program on a cassette tape using Altair 680 basic.  Was there a KCACR basic made without the CSAVE command?  My basic appears to have a CSAVE command, but it won't accept the name!!!!!  : (

      I'm sending this to two groups.  I've been at this problem for hours now...  : (

      I'll post a transcript below.  Let me know what I'm doing wrong!  : (

      --------------------
      .J FD00 (cassette bootstrap rom address)
      (basic loading)
      (basic loaded)
      .J 0000 (run basic...)
      MEMORY SIZE?
      TERMINAL WIDTH? 80
      WANT SIN-COS-TAN-ATN? YES

      9604 BYTES FREE

      MITS ALTAIR 680 BASIC VERSION 1.1 REV 3.2
      --KCACR--
      COPYRIGHT 1976 BY MITS INC.

      OK
      10 PRINT "HELLO"
      20 GOTO 10
      CSAVE A

      ?TM ERROR
      OK
      --------------------

      TM is a type mismatch error.  SM is for a command it doesn't understand.  Watch...
      --------------------
      CSAVE A
      ?TM ERROR
      OK

      CSAVE
      ?SN ERROR
      OK

      AHHHH!
      ?SN ERROR
      OK

      AHHHH! A
      ?SN ERROR
      OK
      --------------------

      Am I wrong assuming that because it gives me a TM error instead of SN that it is "trying" to work?  I get the same things for CLOAD...  How in the world are you supposed to save something to tape!  : (

      If I have the wrong version of basic, anyone have the right one?  What will it take for me to get a copy!  : )  (first smile in this e-mail...  ; )  )

      Thanks,
      Grant
    • Show all 8 messages in this topic