Loading ...
Sorry, an error occurred while loading the content.
 

Re: IE issue with 0.5.5

Expand Messages
  • iskitzdev
    Hi Thomas, It s been a while, but I have a possible solution, more like a workaround for the issue you reported. I ve uploaded my modified version of your
    Message 1 of 7 , Sep 11, 2006
      Hi Thomas,
      It's been a while, but I have a possible solution, more like a
      workaround for the issue you reported. I've uploaded my modified
      version of your sample code.

      So far, this is the only viable solution I've been able to
      successfully execute on IE consistently. That said, it still doesn't
      feel quite clean, but maybe that's just because of the try blocks.

      I'm still working on resolving the whole IE import issue. It seems to
      be one of those issues that'll take some truely creative and clear
      thinking, and maybe luck ;-).

      I've posted my changes to:

      Files > Ajile Tests > Thomas > ajile-fix-import-ie.zip

      Try it and let me know if you can work with the approach I used.

      You should be able to use the import listener + per-page loader
      approach. I remember in the past you'd said that the original shared
      loader didn't quite fit your use scenarios, but from what I
      understood, the new per-page loaders should be a better fit...

      IE, IE, IE, what can I say, it's oh so good when it works, but oh so
      painful when it doesn't. Gotta love the challenge :-)


      -Michael


      --- In ajile@yahoogroups.com, "bugitfor" <bugitfor@...> wrote:
      >
      > Hey Mike, its thomas (if you remember, i posted prev problems in the
      blog)
      >
      > I am running into another issue with IE now and just wanted to let you
      > know about it. Hopefully you catch it before you release 0.6:-
      >
      > Basically same setup based on widgets as before. I have
      > script type="text/javascript"
      > Import("v.widgets.SelectContainer","path/");
      > /script
      >
      > Once i import that I do
      > script type="text/javascript"
      > SelectContainer.testhash = {h:1,h:2}
      > /script
      >
      > The above works ok in FF but in IE it errors out saying
      > SelectContainer is not defined.
      >
      > If i use the complete name then it works in IE. But after you import
      > it , you should be able to use the imported name correct?
      >
      > I can put up a sample if you need to see the code.
      >
      > Thanks,
      > Thomas
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.