Loading ...
Sorry, an error occurred while loading the content.
 

Re: Loading index.js files

Expand Messages
  • mikeizworkin
    Hi Ben, Modify your ajile script tag s src as follows: src= /js/com/iskitz/ajile.js?mvcoff mvcoff is a load-time option that disables Ajile s automatic
    Message 1 of 2 , Apr 23, 2010
      Hi Ben,

      Modify your ajile script tag's src as follows:

      src="/js/com/iskitz/ajile.js?mvcoff"

      mvcoff is a "load-time" option that disables Ajile's automatic loading of page controller scripts. A page controller script is a JavaScript file with the same name and in the same directory as a corresponding html page but containing a ".js" extension. By default a page controller is loaded whenever a page uses Ajile and doesn't explicitly disable page controllers with mvcoff.

      Based on your setup description Ajile is automatically loading /js/index.js as your site controller script then trying to load /index.js as your index.htm(l) page controller script.

      See http://ajile.net/docs/api/Options.htm#mvc for more information.

      -Michael


      --- In ajile@yahoogroups.com, "Ben McClure" <digitalempire@...> wrote:
      >
      > All of my javascript is in /js/
      >
      > Ajile is at /js/com/iskitz/ajile.js
      > My index.js is in /js/index.js
      >
      > Ajile is working, but it's first properly loading my /js/index.js file, and then also trying to load an /index.js file.
      >
      > I don't see any problems on the page, but looking at the console I see javascript errors where it tries to load the file and gets an HTML error page instead.
      >
      > Is there a way I can prevent this while still having it auto-load the correct index.js file, or should I just turn that off and load index.js manually?
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.