Loading ...
Sorry, an error occurred while loading the content.

Re: Ajile breaks VS 2005 script debugger

Expand Messages
  • mikeizworkin
    Absolutely. The version s included in the name to make it clear at a glance what version is contained within the file. Ajile also uses that when displaying
    Message 1 of 12 , Nov 16, 2007
    • 0 Attachment
      Absolutely.

      The version's included in the name to make it clear at a glance what
      version is contained within the file. Ajile also uses that when
      displaying version information in the debug log. The upcoming release
      will allow such renaming while still preserving version information.

      Did renaming the file solve your problem?

      --- In ajile@yahoogroups.com, "jeffreyhartpierson" <jpierson@...> wrote:
      >
      > Can I remove the version specifier at least? I'd rather not have to do
      > a source control rename every time I update the library.
      >
      > com.iskitz.ajile.0.9.9.2.js
      >
      > becomes
      >
      > com.iskitz.ajile.js
      >
      > --- In ajile@yahoogroups.com, "mikeizworkin" <mikeizworkin@> wrote:
      > >
      > > Hi Jeff,
      > > It looks to me like you may have some other issues at play. Did you
      > > rename the Ajile module from com.iskitz.ajile.js to ajile.js? If you
      > > did, you should place ajile in a directory structure that accurately
      > > reflects it's fully qualified named i.e.
      > >
      > > /some/path/com/iskitz/ajile.js
      > >
      > > Ajile expects to be loaded in either of the following ways:
      > >
      > > <script ... src="some/path/com.iskitz.ajile.js"></script>
      > > or
      > > <script ... src="some/path/com/iskitz/ajile.js"></script>
      > >
      > > This is important because Ajile uses it's own location as a base
      > > location for inferring the location of other scripts.
      > >
      > > The message outputted by the debug log seems to indicate that Ajile's
      > > path is unknown.
      > >
      > > If you place Ajile.EnableCloak(false); as the first statement in your
      > > first script it should be just as effective as using the load-time
      > > option (ajile.js?debug).
      > >
      > > Once the log is up, you should be able to see Namespace informatin
      > > showing whether cloaking and other options are enabled or disabled.
      > >
      > >
      > > -Michael
      > >
      > >
      > > --- In ajile@yahoogroups.com, "jeffreyhartpierson" <jpierson@> wrote:
      > > >
      > > > This morning I tried using the cloakoff setting and
      unfortunately I'm
      > > > still having this issue. If I have some time I'll see if i can
      > > > package up an example that would let others test this same issue.
      > > >
      > > > I don't have any of the logging frameworks that you listed but I did
      > > > try to view the log using the Ajile which gave me the following
      > > > message.
      > > >
      > > > ...
      > > >
      > > > To enable debug logging, use Ajile.EnableDebug() from within any of
      > > > your scripts or use Ajile's debug load-time option as follows:
      > > >
      > > >
      > > > <script src="?debug" type="text/javascript"></script>
      > > >
      > > > ...
      > > >
      > > > This message leads me to believe that the arguments that I included
      > > > in the path must have been misformed or something meaning that the
      > > > cloakoff setting might have not made it as well. I'll test that
      > > > theory for a while in hopes that it is truely the cloaking feature
      > > > which is stopping be from being able to debug. My script include
      > > > looks as shown below.
      > > >
      > > > <script type="text/javascript"
      src="/scripts/ajile.js?cloakoff,debug">
      > > >
      > > > Curious is there some constant I can check suck as Ajile.<CloakOff>
      > > > that will show me whether the cloaking setting has been set properly
      > > > from the debugger?
      > > >
      > > > --- In ajile@yahoogroups.com, "iskitzdev" <iskitzdev@> wrote:
      > > > >
      > > > > Jeff,
      > > > > I'm glad you've found Ajile useful.
      > > > >
      > > > > The problem you've described is most-likely due to Ajile's source
      > > > code
      > > > > cloaking feature.
      > > > >
      > > > > Try loading Ajile as follows:
      > > > >
      > > > > <script type="text/javascript"
      src="/scripts/ajile.js?cloakoff">
      > > > >
      > > > > This will turn off Ajile's cloaking of all other scripts.
      > > > >
      > > > >
      > > > > If you're looking to confirm whether Ajile is loading,
      including, or
      > > > > importing scripts as expected you can load Ajile as follows:
      > > > >
      > > > > <script type="text/javascript" src="/scripts/ajile.js?
      > > > cloakoff,debug">
      > > > >
      > > > > Adding the debug option will turn on Ajile's internal debug log
      > > > which
      > > > > will output to Firebug, YUI Logger, and/or MochiKit if
      available. If
      > > > > none of those are available, use the following to display Ajile's
      > > > > debug log:
      > > > >
      > > > > Ajile.ShowLog(); // call this after the code you're debugging.
      > > > >
      > > > > You can also control cloaking and debugging using the
      following in
      > > > any
      > > > > of your scripts:
      > > > >
      > > > > Ajile.EnableCloak();// pass false to disable cloaking
      > > > > Ajile.EnableDebug();// pass false to disable debug log
      > > > >
      > > > >
      > > > > -Michael
      > > > >
      > > > > --- In ajile@yahoogroups.com, "jeffreyhartpierson"
      > > > > <jeffreyhartpierson@> wrote:
      > > > > >
      > > > > > I work on a medium sized intranet web application and recently
      > > > I've
      > > > > > been attempting to make use of Ajile for namespacing and
      > > > importing.
      > > > > > At first I was very impressed with the available features
      and the
      > > > > > attention given to subtle things like browser compatibility and
      > > > such
      > > > > > but now I've run into a debugging problem which if I can't
      solve
      > > > may
      > > > > > force me to remove Agile and the code I've written around it.
      > > > > >
      > > > > > The problem seems to be that when I have the agile .js file
      > > > included
      > > > > > in my page that in certain situations Visual Studio is not able
      > > > to
      > > > > > resolve the source location when trying to debug. My particular
      > > > > > scenario occurs in a function call on the onclick of an img
      > > > element.
      > > > > > To test I placed a debugger statement before the function
      call to
      > > > > > start up the debugger.
      > > > > >
      > > > > > <script type="text/javascript" src="/scripts/ajile.js">
      > > > > >
      > > > > > When I have the Ajile library included I get the message
      > > > following
      > > > > > message when trying to step into a the function in a
      different js
      > > > > > file that has been included via traditional means.
      > > > > >
      > > > > > "There is no source code available for the current location."
      > > > > >
      > > > > > From what I can understand other people have experienced this
      > > > type of
      > > > > > error after using document.write() to directly modify a page. I
      > > > have
      > > > > > noticed that Ajile makes use of document.write but haven't yet
      > > > looked
      > > > > > into the full readable source code on source forge yet to
      see if
      > > > I
      > > > > > can understand what it is doing.
      > > > > >
      > > > > > If there is anything that you could suggest to remedy this
      > > > problem I
      > > > > > would greatly appreciate it as I am very anxious to get rid
      of a
      > > > > > great deal of redundant code in our web app by making common
      > > > > > libraries and including them using Ajile. Since I hold the
      > > > ability to
      > > > > > debug the code at a high level of importance, if I can't solve
      > > > this
      > > > > > problem I fear that I will have to strip out Ajile and go
      back to
      > > > our
      > > > > > medieval ways.
      > > > > >
      > > > >
      > > >
      > >
      >
    • jeffreyhartpierson
      Yes, renaming the file allows the options to be set. Note that the Load and Namespace methods did work fine after renaming it all to just ajile.js. After
      Message 2 of 12 , Nov 16, 2007
      • 0 Attachment
        Yes, renaming the file allows the options to be set. Note that the
        Load and Namespace methods did work fine after renaming it all to just
        ajile.js.

        After experimenting I was very pleased to find that I can debug just
        fine after turning cloaking off. Without the cloakoff option I get the
        original issue that was described.

        Looks like we have actually addressed two issues one being the
        renaming and the other was the cloaking interfering with my debugger.

        Thanks so much for your timely repsonses. It looks like I will be able
        to keep Ajile in our project after all. Thanks again for all the hard
        work.

        --- In ajile@yahoogroups.com, "mikeizworkin" <mikeizworkin@...> wrote:
        >
        > Absolutely.
        >
        > The version's included in the name to make it clear at a glance what
        > version is contained within the file. Ajile also uses that when
        > displaying version information in the debug log. The upcoming release
        > will allow such renaming while still preserving version information.
        >
        > Did renaming the file solve your problem?
        >
        > --- In ajile@yahoogroups.com, "jeffreyhartpierson" <jpierson@> wrote:
        > >
        > > Can I remove the version specifier at least? I'd rather not have to do
        > > a source control rename every time I update the library.
        > >
        > > com.iskitz.ajile.0.9.9.2.js
        > >
        > > becomes
        > >
        > > com.iskitz.ajile.js
        > >
        > > --- In ajile@yahoogroups.com, "mikeizworkin" <mikeizworkin@> wrote:
        > > >
        > > > Hi Jeff,
        > > > It looks to me like you may have some other issues at play. Did you
        > > > rename the Ajile module from com.iskitz.ajile.js to ajile.js? If you
        > > > did, you should place ajile in a directory structure that accurately
        > > > reflects it's fully qualified named i.e.
        > > >
        > > > /some/path/com/iskitz/ajile.js
        > > >
        > > > Ajile expects to be loaded in either of the following ways:
        > > >
        > > > <script ... src="some/path/com.iskitz.ajile.js"></script>
        > > > or
        > > > <script ... src="some/path/com/iskitz/ajile.js"></script>
        > > >
        > > > This is important because Ajile uses it's own location as a base
        > > > location for inferring the location of other scripts.
        > > >
        > > > The message outputted by the debug log seems to indicate that
        Ajile's
        > > > path is unknown.
        > > >
        > > > If you place Ajile.EnableCloak(false); as the first statement in
        your
        > > > first script it should be just as effective as using the load-time
        > > > option (ajile.js?debug).
        > > >
        > > > Once the log is up, you should be able to see Namespace informatin
        > > > showing whether cloaking and other options are enabled or disabled.
        > > >
        > > >
        > > > -Michael
        > > >
        > > >
        > > > --- In ajile@yahoogroups.com, "jeffreyhartpierson" <jpierson@>
        wrote:
        > > > >
        > > > > This morning I tried using the cloakoff setting and
        > unfortunately I'm
        > > > > still having this issue. If I have some time I'll see if i can
        > > > > package up an example that would let others test this same issue.
        > > > >
        > > > > I don't have any of the logging frameworks that you listed but
        I did
        > > > > try to view the log using the Ajile which gave me the following
        > > > > message.
        > > > >
        > > > > ...
        > > > >
        > > > > To enable debug logging, use Ajile.EnableDebug() from within
        any of
        > > > > your scripts or use Ajile's debug load-time option as follows:
        > > > >
        > > > >
        > > > > <script src="?debug" type="text/javascript"></script>
        > > > >
        > > > > ...
        > > > >
        > > > > This message leads me to believe that the arguments that I
        included
        > > > > in the path must have been misformed or something meaning that the
        > > > > cloakoff setting might have not made it as well. I'll test that
        > > > > theory for a while in hopes that it is truely the cloaking feature
        > > > > which is stopping be from being able to debug. My script include
        > > > > looks as shown below.
        > > > >
        > > > > <script type="text/javascript"
        > src="/scripts/ajile.js?cloakoff,debug">
        > > > >
        > > > > Curious is there some constant I can check suck as
        Ajile.<CloakOff>
        > > > > that will show me whether the cloaking setting has been set
        properly
        > > > > from the debugger?
        > > > >
        > > > > --- In ajile@yahoogroups.com, "iskitzdev" <iskitzdev@> wrote:
        > > > > >
        > > > > > Jeff,
        > > > > > I'm glad you've found Ajile useful.
        > > > > >
        > > > > > The problem you've described is most-likely due to Ajile's
        source
        > > > > code
        > > > > > cloaking feature.
        > > > > >
        > > > > > Try loading Ajile as follows:
        > > > > >
        > > > > > <script type="text/javascript"
        > src="/scripts/ajile.js?cloakoff">
        > > > > >
        > > > > > This will turn off Ajile's cloaking of all other scripts.
        > > > > >
        > > > > >
        > > > > > If you're looking to confirm whether Ajile is loading,
        > including, or
        > > > > > importing scripts as expected you can load Ajile as follows:
        > > > > >
        > > > > > <script type="text/javascript" src="/scripts/ajile.js?
        > > > > cloakoff,debug">
        > > > > >
        > > > > > Adding the debug option will turn on Ajile's internal debug log
        > > > > which
        > > > > > will output to Firebug, YUI Logger, and/or MochiKit if
        > available. If
        > > > > > none of those are available, use the following to display
        Ajile's
        > > > > > debug log:
        > > > > >
        > > > > > Ajile.ShowLog(); // call this after the code you're
        debugging.
        > > > > >
        > > > > > You can also control cloaking and debugging using the
        > following in
        > > > > any
        > > > > > of your scripts:
        > > > > >
        > > > > > Ajile.EnableCloak();// pass false to disable cloaking
        > > > > > Ajile.EnableDebug();// pass false to disable debug log
        > > > > >
        > > > > >
        > > > > > -Michael
        > > > > >
        > > > > > --- In ajile@yahoogroups.com, "jeffreyhartpierson"
        > > > > > <jeffreyhartpierson@> wrote:
        > > > > > >
        > > > > > > I work on a medium sized intranet web application and
        recently
        > > > > I've
        > > > > > > been attempting to make use of Ajile for namespacing and
        > > > > importing.
        > > > > > > At first I was very impressed with the available features
        > and the
        > > > > > > attention given to subtle things like browser
        compatibility and
        > > > > such
        > > > > > > but now I've run into a debugging problem which if I can't
        > solve
        > > > > may
        > > > > > > force me to remove Agile and the code I've written around it.
        > > > > > >
        > > > > > > The problem seems to be that when I have the agile .js file
        > > > > included
        > > > > > > in my page that in certain situations Visual Studio is not
        able
        > > > > to
        > > > > > > resolve the source location when trying to debug. My
        particular
        > > > > > > scenario occurs in a function call on the onclick of an img
        > > > > element.
        > > > > > > To test I placed a debugger statement before the function
        > call to
        > > > > > > start up the debugger.
        > > > > > >
        > > > > > > <script type="text/javascript" src="/scripts/ajile.js">
        > > > > > >
        > > > > > > When I have the Ajile library included I get the message
        > > > > following
        > > > > > > message when trying to step into a the function in a
        > different js
        > > > > > > file that has been included via traditional means.
        > > > > > >
        > > > > > > "There is no source code available for the current location."
        > > > > > >
        > > > > > > From what I can understand other people have experienced this
        > > > > type of
        > > > > > > error after using document.write() to directly modify a
        page. I
        > > > > have
        > > > > > > noticed that Ajile makes use of document.write but haven't
        yet
        > > > > looked
        > > > > > > into the full readable source code on source forge yet to
        > see if
        > > > > I
        > > > > > > can understand what it is doing.
        > > > > > >
        > > > > > > If there is anything that you could suggest to remedy this
        > > > > problem I
        > > > > > > would greatly appreciate it as I am very anxious to get rid
        > of a
        > > > > > > great deal of redundant code in our web app by making common
        > > > > > > libraries and including them using Ajile. Since I hold the
        > > > > ability to
        > > > > > > debug the code at a high level of importance, if I can't
        solve
        > > > > this
        > > > > > > problem I fear that I will have to strip out Ajile and go
        > back to
        > > > > our
        > > > > > > medieval ways.
        > > > > > >
        > > > > >
        > > > >
        > > >
        > >
        >
      • mikeizworkin
        Hi Jeff, Glad we were able to find a solution :-) I hope Ajile will continue to be an effective part of your project. Thanks for reporting your experience.
        Message 3 of 12 , Nov 16, 2007
        • 0 Attachment
          Hi Jeff,
          Glad we were able to find a solution :-) I hope Ajile will continue to
          be an effective part of your project.

          Thanks for reporting your experience. Investigating it has given good
          insight into the side effects of renaming Ajile. I'll try to add a FAQ
          entry for the effects of renaming. I'll also look to add a FAQ entry
          for cloaking's effect on debugging.

          Cloaking is meant to do exactly what you saw; that is, make the source
          code invisible and unavailable. It's purpose is to support developers
          who seek to minimize reverse engineering of their code.

          As for why the Load and Namespace directives functioned as expected
          despite Ajile's renaming: These two directives are fairly standalone,
          they don't depend on Ajile's options or automatic path resolution.

          As an aside, I uploaded a modified version of your sample code to your
          folder. It shows how to better make use of Ajile's options and its
          automatic loading. I've included some explanation within the comments
          in the page.html file.

          FYI, while investigating, I discovered and corrected a minor bug with
          Ajile's log that causes unintended code to be printed instead of
          function names. The fix is included in the com.iskitz.ajile.js file
          within the new zip. I'll include that fix in the next release.

          Best of luck,
          Michael

          --- In ajile@yahoogroups.com, "jeffreyhartpierson" <jpierson@...> wrote:
          >
          > Yes, renaming the file allows the options to be set. Note that the
          > Load and Namespace methods did work fine after renaming it all to just
          > ajile.js.
          >
          > After experimenting I was very pleased to find that I can debug just
          > fine after turning cloaking off. Without the cloakoff option I get the
          > original issue that was described.
          >
          > Looks like we have actually addressed two issues one being the
          > renaming and the other was the cloaking interfering with my debugger.
          >
          > Thanks so much for your timely repsonses. It looks like I will be able
          > to keep Ajile in our project after all. Thanks again for all the hard
          > work.
          >
          > --- In ajile@yahoogroups.com, "mikeizworkin" <mikeizworkin@> wrote:
          > >
          > > Absolutely.
          > >
          > > The version's included in the name to make it clear at a glance what
          > > version is contained within the file. Ajile also uses that when
          > > displaying version information in the debug log. The upcoming release
          > > will allow such renaming while still preserving version information.
          > >
          > > Did renaming the file solve your problem?
          > >
          > > --- In ajile@yahoogroups.com, "jeffreyhartpierson" <jpierson@> wrote:
          > > >
          > > > Can I remove the version specifier at least? I'd rather not have
          to do
          > > > a source control rename every time I update the library.
          > > >
          > > > com.iskitz.ajile.0.9.9.2.js
          > > >
          > > > becomes
          > > >
          > > > com.iskitz.ajile.js
          > > >
          > > > --- In ajile@yahoogroups.com, "mikeizworkin" <mikeizworkin@> wrote:
          > > > >
          > > > > Hi Jeff,
          > > > > It looks to me like you may have some other issues at play.
          Did you
          > > > > rename the Ajile module from com.iskitz.ajile.js to ajile.js?
          If you
          > > > > did, you should place ajile in a directory structure that
          accurately
          > > > > reflects it's fully qualified named i.e.
          > > > >
          > > > > /some/path/com/iskitz/ajile.js
          > > > >
          > > > > Ajile expects to be loaded in either of the following ways:
          > > > >
          > > > > <script ... src="some/path/com.iskitz.ajile.js"></script>
          > > > > or
          > > > > <script ... src="some/path/com/iskitz/ajile.js"></script>
          > > > >
          > > > > This is important because Ajile uses it's own location as a base
          > > > > location for inferring the location of other scripts.
          > > > >
          > > > > The message outputted by the debug log seems to indicate that
          > Ajile's
          > > > > path is unknown.
          > > > >
          > > > > If you place Ajile.EnableCloak(false); as the first statement in
          > your
          > > > > first script it should be just as effective as using the load-time
          > > > > option (ajile.js?debug).
          > > > >
          > > > > Once the log is up, you should be able to see Namespace informatin
          > > > > showing whether cloaking and other options are enabled or
          disabled.
          > > > >
          > > > >
          > > > > -Michael
          > > > >
          > > > >
          > > > > --- In ajile@yahoogroups.com, "jeffreyhartpierson" <jpierson@>
          > wrote:
          > > > > >
          > > > > > This morning I tried using the cloakoff setting and
          > > unfortunately I'm
          > > > > > still having this issue. If I have some time I'll see if i can
          > > > > > package up an example that would let others test this same
          issue.
          > > > > >
          > > > > > I don't have any of the logging frameworks that you listed but
          > I did
          > > > > > try to view the log using the Ajile which gave me the following
          > > > > > message.
          > > > > >
          > > > > > ...
          > > > > >
          > > > > > To enable debug logging, use Ajile.EnableDebug() from within
          > any of
          > > > > > your scripts or use Ajile's debug load-time option as follows:
          > > > > >
          > > > > >
          > > > > > <script src="?debug" type="text/javascript"></script>
          > > > > >
          > > > > > ...
          > > > > >
          > > > > > This message leads me to believe that the arguments that I
          > included
          > > > > > in the path must have been misformed or something meaning
          that the
          > > > > > cloakoff setting might have not made it as well. I'll test that
          > > > > > theory for a while in hopes that it is truely the cloaking
          feature
          > > > > > which is stopping be from being able to debug. My script include
          > > > > > looks as shown below.
          > > > > >
          > > > > > <script type="text/javascript"
          > > src="/scripts/ajile.js?cloakoff,debug">
          > > > > >
          > > > > > Curious is there some constant I can check suck as
          > Ajile.<CloakOff>
          > > > > > that will show me whether the cloaking setting has been set
          > properly
          > > > > > from the debugger?
          > > > > >
          > > > > > --- In ajile@yahoogroups.com, "iskitzdev" <iskitzdev@> wrote:
          > > > > > >
          > > > > > > Jeff,
          > > > > > > I'm glad you've found Ajile useful.
          > > > > > >
          > > > > > > The problem you've described is most-likely due to Ajile's
          > source
          > > > > > code
          > > > > > > cloaking feature.
          > > > > > >
          > > > > > > Try loading Ajile as follows:
          > > > > > >
          > > > > > > <script type="text/javascript"
          > > src="/scripts/ajile.js?cloakoff">
          > > > > > >
          > > > > > > This will turn off Ajile's cloaking of all other scripts.
          > > > > > >
          > > > > > >
          > > > > > > If you're looking to confirm whether Ajile is loading,
          > > including, or
          > > > > > > importing scripts as expected you can load Ajile as follows:
          > > > > > >
          > > > > > > <script type="text/javascript" src="/scripts/ajile.js?
          > > > > > cloakoff,debug">
          > > > > > >
          > > > > > > Adding the debug option will turn on Ajile's internal
          debug log
          > > > > > which
          > > > > > > will output to Firebug, YUI Logger, and/or MochiKit if
          > > available. If
          > > > > > > none of those are available, use the following to display
          > Ajile's
          > > > > > > debug log:
          > > > > > >
          > > > > > > Ajile.ShowLog(); // call this after the code you're
          > debugging.
          > > > > > >
          > > > > > > You can also control cloaking and debugging using the
          > > following in
          > > > > > any
          > > > > > > of your scripts:
          > > > > > >
          > > > > > > Ajile.EnableCloak();// pass false to disable cloaking
          > > > > > > Ajile.EnableDebug();// pass false to disable debug log
          > > > > > >
          > > > > > >
          > > > > > > -Michael
          > > > > > >
          > > > > > > --- In ajile@yahoogroups.com, "jeffreyhartpierson"
          > > > > > > <jeffreyhartpierson@> wrote:
          > > > > > > >
          > > > > > > > I work on a medium sized intranet web application and
          > recently
          > > > > > I've
          > > > > > > > been attempting to make use of Ajile for namespacing and
          > > > > > importing.
          > > > > > > > At first I was very impressed with the available features
          > > and the
          > > > > > > > attention given to subtle things like browser
          > compatibility and
          > > > > > such
          > > > > > > > but now I've run into a debugging problem which if I can't
          > > solve
          > > > > > may
          > > > > > > > force me to remove Agile and the code I've written
          around it.
          > > > > > > >
          > > > > > > > The problem seems to be that when I have the agile .js file
          > > > > > included
          > > > > > > > in my page that in certain situations Visual Studio is not
          > able
          > > > > > to
          > > > > > > > resolve the source location when trying to debug. My
          > particular
          > > > > > > > scenario occurs in a function call on the onclick of an img
          > > > > > element.
          > > > > > > > To test I placed a debugger statement before the function
          > > call to
          > > > > > > > start up the debugger.
          > > > > > > >
          > > > > > > > <script type="text/javascript" src="/scripts/ajile.js">
          > > > > > > >
          > > > > > > > When I have the Ajile library included I get the message
          > > > > > following
          > > > > > > > message when trying to step into a the function in a
          > > different js
          > > > > > > > file that has been included via traditional means.
          > > > > > > >
          > > > > > > > "There is no source code available for the current
          location."
          > > > > > > >
          > > > > > > > From what I can understand other people have experienced
          this
          > > > > > type of
          > > > > > > > error after using document.write() to directly modify a
          > page. I
          > > > > > have
          > > > > > > > noticed that Ajile makes use of document.write but haven't
          > yet
          > > > > > looked
          > > > > > > > into the full readable source code on source forge yet to
          > > see if
          > > > > > I
          > > > > > > > can understand what it is doing.
          > > > > > > >
          > > > > > > > If there is anything that you could suggest to remedy this
          > > > > > problem I
          > > > > > > > would greatly appreciate it as I am very anxious to get rid
          > > of a
          > > > > > > > great deal of redundant code in our web app by making
          common
          > > > > > > > libraries and including them using Ajile. Since I hold the
          > > > > > ability to
          > > > > > > > debug the code at a high level of importance, if I can't
          > solve
          > > > > > this
          > > > > > > > problem I fear that I will have to strip out Ajile and go
          > > back to
          > > > > > our
          > > > > > > > medieval ways.
          > > > > > > >
          > > > > > >
          > > > > >
          > > > >
          > > >
          > >
          >
        • jeffreyhartpierson
          Great! thanks again Michael ... release ... load-time ... informatin ... following ... that ... include ... file ... an img ... this ... get rid ... the
          Message 4 of 12 , Nov 16, 2007
          • 0 Attachment
            Great! thanks again Michael

            --- In ajile@yahoogroups.com, "mikeizworkin" <mikeizworkin@...> wrote:
            >
            > Hi Jeff,
            > Glad we were able to find a solution :-) I hope Ajile will continue to
            > be an effective part of your project.
            >
            > Thanks for reporting your experience. Investigating it has given good
            > insight into the side effects of renaming Ajile. I'll try to add a FAQ
            > entry for the effects of renaming. I'll also look to add a FAQ entry
            > for cloaking's effect on debugging.
            >
            > Cloaking is meant to do exactly what you saw; that is, make the source
            > code invisible and unavailable. It's purpose is to support developers
            > who seek to minimize reverse engineering of their code.
            >
            > As for why the Load and Namespace directives functioned as expected
            > despite Ajile's renaming: These two directives are fairly standalone,
            > they don't depend on Ajile's options or automatic path resolution.
            >
            > As an aside, I uploaded a modified version of your sample code to your
            > folder. It shows how to better make use of Ajile's options and its
            > automatic loading. I've included some explanation within the comments
            > in the page.html file.
            >
            > FYI, while investigating, I discovered and corrected a minor bug with
            > Ajile's log that causes unintended code to be printed instead of
            > function names. The fix is included in the com.iskitz.ajile.js file
            > within the new zip. I'll include that fix in the next release.
            >
            > Best of luck,
            > Michael
            >
            > --- In ajile@yahoogroups.com, "jeffreyhartpierson" <jpierson@> wrote:
            > >
            > > Yes, renaming the file allows the options to be set. Note that the
            > > Load and Namespace methods did work fine after renaming it all to just
            > > ajile.js.
            > >
            > > After experimenting I was very pleased to find that I can debug just
            > > fine after turning cloaking off. Without the cloakoff option I get the
            > > original issue that was described.
            > >
            > > Looks like we have actually addressed two issues one being the
            > > renaming and the other was the cloaking interfering with my debugger.
            > >
            > > Thanks so much for your timely repsonses. It looks like I will be able
            > > to keep Ajile in our project after all. Thanks again for all the hard
            > > work.
            > >
            > > --- In ajile@yahoogroups.com, "mikeizworkin" <mikeizworkin@> wrote:
            > > >
            > > > Absolutely.
            > > >
            > > > The version's included in the name to make it clear at a glance what
            > > > version is contained within the file. Ajile also uses that when
            > > > displaying version information in the debug log. The upcoming
            release
            > > > will allow such renaming while still preserving version information.
            > > >
            > > > Did renaming the file solve your problem?
            > > >
            > > > --- In ajile@yahoogroups.com, "jeffreyhartpierson" <jpierson@>
            wrote:
            > > > >
            > > > > Can I remove the version specifier at least? I'd rather not have
            > to do
            > > > > a source control rename every time I update the library.
            > > > >
            > > > > com.iskitz.ajile.0.9.9.2.js
            > > > >
            > > > > becomes
            > > > >
            > > > > com.iskitz.ajile.js
            > > > >
            > > > > --- In ajile@yahoogroups.com, "mikeizworkin" <mikeizworkin@>
            wrote:
            > > > > >
            > > > > > Hi Jeff,
            > > > > > It looks to me like you may have some other issues at play.
            > Did you
            > > > > > rename the Ajile module from com.iskitz.ajile.js to ajile.js?
            > If you
            > > > > > did, you should place ajile in a directory structure that
            > accurately
            > > > > > reflects it's fully qualified named i.e.
            > > > > >
            > > > > > /some/path/com/iskitz/ajile.js
            > > > > >
            > > > > > Ajile expects to be loaded in either of the following ways:
            > > > > >
            > > > > > <script ... src="some/path/com.iskitz.ajile.js"></script>
            > > > > > or
            > > > > > <script ... src="some/path/com/iskitz/ajile.js"></script>
            > > > > >
            > > > > > This is important because Ajile uses it's own location as a base
            > > > > > location for inferring the location of other scripts.
            > > > > >
            > > > > > The message outputted by the debug log seems to indicate that
            > > Ajile's
            > > > > > path is unknown.
            > > > > >
            > > > > > If you place Ajile.EnableCloak(false); as the first statement in
            > > your
            > > > > > first script it should be just as effective as using the
            load-time
            > > > > > option (ajile.js?debug).
            > > > > >
            > > > > > Once the log is up, you should be able to see Namespace
            informatin
            > > > > > showing whether cloaking and other options are enabled or
            > disabled.
            > > > > >
            > > > > >
            > > > > > -Michael
            > > > > >
            > > > > >
            > > > > > --- In ajile@yahoogroups.com, "jeffreyhartpierson" <jpierson@>
            > > wrote:
            > > > > > >
            > > > > > > This morning I tried using the cloakoff setting and
            > > > unfortunately I'm
            > > > > > > still having this issue. If I have some time I'll see if i can
            > > > > > > package up an example that would let others test this same
            > issue.
            > > > > > >
            > > > > > > I don't have any of the logging frameworks that you listed but
            > > I did
            > > > > > > try to view the log using the Ajile which gave me the
            following
            > > > > > > message.
            > > > > > >
            > > > > > > ...
            > > > > > >
            > > > > > > To enable debug logging, use Ajile.EnableDebug() from within
            > > any of
            > > > > > > your scripts or use Ajile's debug load-time option as follows:
            > > > > > >
            > > > > > >
            > > > > > > <script src="?debug" type="text/javascript"></script>
            > > > > > >
            > > > > > > ...
            > > > > > >
            > > > > > > This message leads me to believe that the arguments that I
            > > included
            > > > > > > in the path must have been misformed or something meaning
            > that the
            > > > > > > cloakoff setting might have not made it as well. I'll test
            that
            > > > > > > theory for a while in hopes that it is truely the cloaking
            > feature
            > > > > > > which is stopping be from being able to debug. My script
            include
            > > > > > > looks as shown below.
            > > > > > >
            > > > > > > <script type="text/javascript"
            > > > src="/scripts/ajile.js?cloakoff,debug">
            > > > > > >
            > > > > > > Curious is there some constant I can check suck as
            > > Ajile.<CloakOff>
            > > > > > > that will show me whether the cloaking setting has been set
            > > properly
            > > > > > > from the debugger?
            > > > > > >
            > > > > > > --- In ajile@yahoogroups.com, "iskitzdev" <iskitzdev@> wrote:
            > > > > > > >
            > > > > > > > Jeff,
            > > > > > > > I'm glad you've found Ajile useful.
            > > > > > > >
            > > > > > > > The problem you've described is most-likely due to Ajile's
            > > source
            > > > > > > code
            > > > > > > > cloaking feature.
            > > > > > > >
            > > > > > > > Try loading Ajile as follows:
            > > > > > > >
            > > > > > > > <script type="text/javascript"
            > > > src="/scripts/ajile.js?cloakoff">
            > > > > > > >
            > > > > > > > This will turn off Ajile's cloaking of all other scripts.
            > > > > > > >
            > > > > > > >
            > > > > > > > If you're looking to confirm whether Ajile is loading,
            > > > including, or
            > > > > > > > importing scripts as expected you can load Ajile as follows:
            > > > > > > >
            > > > > > > > <script type="text/javascript" src="/scripts/ajile.js?
            > > > > > > cloakoff,debug">
            > > > > > > >
            > > > > > > > Adding the debug option will turn on Ajile's internal
            > debug log
            > > > > > > which
            > > > > > > > will output to Firebug, YUI Logger, and/or MochiKit if
            > > > available. If
            > > > > > > > none of those are available, use the following to display
            > > Ajile's
            > > > > > > > debug log:
            > > > > > > >
            > > > > > > > Ajile.ShowLog(); // call this after the code you're
            > > debugging.
            > > > > > > >
            > > > > > > > You can also control cloaking and debugging using the
            > > > following in
            > > > > > > any
            > > > > > > > of your scripts:
            > > > > > > >
            > > > > > > > Ajile.EnableCloak();// pass false to disable cloaking
            > > > > > > > Ajile.EnableDebug();// pass false to disable debug log
            > > > > > > >
            > > > > > > >
            > > > > > > > -Michael
            > > > > > > >
            > > > > > > > --- In ajile@yahoogroups.com, "jeffreyhartpierson"
            > > > > > > > <jeffreyhartpierson@> wrote:
            > > > > > > > >
            > > > > > > > > I work on a medium sized intranet web application and
            > > recently
            > > > > > > I've
            > > > > > > > > been attempting to make use of Ajile for namespacing and
            > > > > > > importing.
            > > > > > > > > At first I was very impressed with the available features
            > > > and the
            > > > > > > > > attention given to subtle things like browser
            > > compatibility and
            > > > > > > such
            > > > > > > > > but now I've run into a debugging problem which if I can't
            > > > solve
            > > > > > > may
            > > > > > > > > force me to remove Agile and the code I've written
            > around it.
            > > > > > > > >
            > > > > > > > > The problem seems to be that when I have the agile .js
            file
            > > > > > > included
            > > > > > > > > in my page that in certain situations Visual Studio is not
            > > able
            > > > > > > to
            > > > > > > > > resolve the source location when trying to debug. My
            > > particular
            > > > > > > > > scenario occurs in a function call on the onclick of
            an img
            > > > > > > element.
            > > > > > > > > To test I placed a debugger statement before the function
            > > > call to
            > > > > > > > > start up the debugger.
            > > > > > > > >
            > > > > > > > > <script type="text/javascript" src="/scripts/ajile.js">
            > > > > > > > >
            > > > > > > > > When I have the Ajile library included I get the message
            > > > > > > following
            > > > > > > > > message when trying to step into a the function in a
            > > > different js
            > > > > > > > > file that has been included via traditional means.
            > > > > > > > >
            > > > > > > > > "There is no source code available for the current
            > location."
            > > > > > > > >
            > > > > > > > > From what I can understand other people have experienced
            > this
            > > > > > > type of
            > > > > > > > > error after using document.write() to directly modify a
            > > page. I
            > > > > > > have
            > > > > > > > > noticed that Ajile makes use of document.write but haven't
            > > yet
            > > > > > > looked
            > > > > > > > > into the full readable source code on source forge yet to
            > > > see if
            > > > > > > I
            > > > > > > > > can understand what it is doing.
            > > > > > > > >
            > > > > > > > > If there is anything that you could suggest to remedy
            this
            > > > > > > problem I
            > > > > > > > > would greatly appreciate it as I am very anxious to
            get rid
            > > > of a
            > > > > > > > > great deal of redundant code in our web app by making
            > common
            > > > > > > > > libraries and including them using Ajile. Since I hold
            the
            > > > > > > ability to
            > > > > > > > > debug the code at a high level of importance, if I can't
            > > solve
            > > > > > > this
            > > > > > > > > problem I fear that I will have to strip out Ajile and go
            > > > back to
            > > > > > > our
            > > > > > > > > medieval ways.
            > > > > > > > >
            > > > > > > >
            > > > > > >
            > > > > >
            > > > >
            > > >
            > >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.