Loading ...
Sorry, an error occurred while loading the content.

Re: 100% CPU usage when entering new transaction

Expand Messages
  • Matthew B. Howell, MOS
    I just did an archive of my data - it did not solve the 100% CPU usage problem. In performing the archive, AceMoney actually messed up some of my accounts,
    Message 1 of 6 , Sep 23, 2007
    View Source
    • 0 Attachment
      I just did an archive of my data - it did not solve the "100% CPU
      usage" problem. In performing the archive, AceMoney actually messed up
      some of my accounts, so I needed to restore from my backup. Needless
      to say, I won't be performing another archive anytime soon.

      Matthew
      --- In acemoney@yahoogroups.com, "MechCAD Software" <acemoney@...> wrote:
      >
      > Hi Matthew,
      >
      > Is it happening when you click at New Transaction button, waiting for
      > a dialog to appear or when you finished entering transaction data,
      > waiting to see transaction to show up in the list?
      >
      > How long exactly the delay is? Our performance testing shows small
      > delays before the transaction dialog is diplayed (up to one second)
      > and 100% CPU consumption in 10000 transactions files. If it is one
      > second or less, there is nothing we can do.
      >
      > The latest version supports archiving the old data to mmw files. If
      > you have thousands of transactions, I'd recommend you to archive, say
      > everything up to 12/31/2006 and see if it helps. You will be able to
      > access old data by opening the archive files and run reports on them,
      > but old data won't be slowing you down.
      >
      > Thanks,
      >
      > Alex Simanov
      > MechCAD Software.
      >
      > --- In acemoney@yahoogroups.com, "Matthew B. Howell, MOS"
      > <gavnone2001@> wrote:
      > >
      > > For the last 2 months or so, I have been experiencing 100% CPU usage,
      > > resulting in a massive lag time, every time I go to enter a new
      > > transaction in AceMoney. I have upgraded to version 3.10a as of a few
      > > minutes ago, yet the 100% CPU issue remains. I have changed all of the
      > > settings under the Options menu in various combinations, have exported
      > > older accounts to HTML files and removed them from AceMoney, have
      > > marked older transactions as "reconciled" and activated the "hide
      > > reconciled" feature, have changed the path of my backup folder several
      > > times, have changed the "backup frequency" value to perform
      > > less-frequent backups, and have disabled the "autosave" feature. I
      > > have even re-installed AceMoney a few times. None of these changes,
      > > though, have solved the 100% CPU issue for me.
      > >
      > > Does anyone in this forum know what I can do to solve this issue?
      > >
      > > Matthew
      > >
      >
    • MechCAD Software
      Hi Matthew, Could you please describe what exactly got messed up after archiving? We need to know all the details in order to fix the problem if one exists.
      Message 2 of 6 , Sep 23, 2007
      View Source
      • 0 Attachment
        Hi Matthew,

        Could you please describe what exactly got "messed up" after
        archiving? We need to know all the details in order to fix the problem
        if one exists. It would be great if you could create a sample file and
        send it to support at mechcad.net.

        BTW do you have investments associated with any account which could
        have changed account balance?

        Thanks,

        Alex Simanov
        MechCAD Software.

        --- In acemoney@yahoogroups.com, "Matthew B. Howell, MOS"
        <gavnone2001@...> wrote:
        >
        > I just did an archive of my data - it did not solve the "100% CPU
        > usage" problem. In performing the archive, AceMoney actually messed up
        > some of my accounts, so I needed to restore from my backup. Needless
        > to say, I won't be performing another archive anytime soon.
        >
        > Matthew
        > --- In acemoney@yahoogroups.com, "MechCAD Software" <acemoney@> wrote:
        > >
        > > Hi Matthew,
        > >
        > > Is it happening when you click at New Transaction button, waiting for
        > > a dialog to appear or when you finished entering transaction data,
        > > waiting to see transaction to show up in the list?
        > >
        > > How long exactly the delay is? Our performance testing shows small
        > > delays before the transaction dialog is diplayed (up to one second)
        > > and 100% CPU consumption in 10000 transactions files. If it is one
        > > second or less, there is nothing we can do.
        > >
        > > The latest version supports archiving the old data to mmw files. If
        > > you have thousands of transactions, I'd recommend you to archive, say
        > > everything up to 12/31/2006 and see if it helps. You will be able to
        > > access old data by opening the archive files and run reports on them,
        > > but old data won't be slowing you down.
        > >
        > > Thanks,
        > >
        > > Alex Simanov
        > > MechCAD Software.
        > >
        > > --- In acemoney@yahoogroups.com, "Matthew B. Howell, MOS"
        > > <gavnone2001@> wrote:
        > > >
        > > > For the last 2 months or so, I have been experiencing 100% CPU
        usage,
        > > > resulting in a massive lag time, every time I go to enter a new
        > > > transaction in AceMoney. I have upgraded to version 3.10a as of
        a few
        > > > minutes ago, yet the 100% CPU issue remains. I have changed all
        of the
        > > > settings under the Options menu in various combinations, have
        exported
        > > > older accounts to HTML files and removed them from AceMoney, have
        > > > marked older transactions as "reconciled" and activated the "hide
        > > > reconciled" feature, have changed the path of my backup folder
        several
        > > > times, have changed the "backup frequency" value to perform
        > > > less-frequent backups, and have disabled the "autosave" feature. I
        > > > have even re-installed AceMoney a few times. None of these changes,
        > > > though, have solved the 100% CPU issue for me.
        > > >
        > > > Does anyone in this forum know what I can do to solve this issue?
        > > >
        > > > Matthew
        > > >
        > >
        >
      • Matthew B. Howell, MOS
        Maybe I shouldn t have used the term messed up or that it was AceMoney s fault - in fact, the way that I archived my data (the date that I ultimately chose
        Message 3 of 6 , Sep 23, 2007
        View Source
        • 0 Attachment
          Maybe I shouldn't have used the term "messed up" or that it was
          AceMoney's fault - in fact, the way that I archived my data (the date
          that I ultimately chose to archive with) was the sole reason that my
          data became scrambled, it had everything to do with my not fully
          understanding how the "archive" feature worked. Again, it was my
          fault, not AceMoney's - I apologize for the confusion.

          On a side note, my 100% CPU usage problem is solved - it had to do
          with an ongoing issue with my computer that was causing it. I switched
          AceMoney to another computer on my network and AceMoney is working
          perfectly now.

          Matthew

          --- In acemoney@yahoogroups.com, "MechCAD Software" <acemoney@...> wrote:
          >
          > Hi Matthew,
          >
          > Could you please describe what exactly got "messed up" after
          > archiving? We need to know all the details in order to fix the problem
          > if one exists. It would be great if you could create a sample file and
          > send it to support at mechcad.net.
          >
          > BTW do you have investments associated with any account which could
          > have changed account balance?
          >
          > Thanks,
          >
          > Alex Simanov
          > MechCAD Software.
          >
          > --- In acemoney@yahoogroups.com, "Matthew B. Howell, MOS"
          > <gavnone2001@> wrote:
          > >
          > > I just did an archive of my data - it did not solve the "100% CPU
          > > usage" problem. In performing the archive, AceMoney actually messed up
          > > some of my accounts, so I needed to restore from my backup. Needless
          > > to say, I won't be performing another archive anytime soon.
          > >
          > > Matthew
          > > --- In acemoney@yahoogroups.com, "MechCAD Software" <acemoney@> wrote:
          > > >
          > > > Hi Matthew,
          > > >
          > > > Is it happening when you click at New Transaction button,
          waiting for
          > > > a dialog to appear or when you finished entering transaction data,
          > > > waiting to see transaction to show up in the list?
          > > >
          > > > How long exactly the delay is? Our performance testing shows small
          > > > delays before the transaction dialog is diplayed (up to one second)
          > > > and 100% CPU consumption in 10000 transactions files. If it is one
          > > > second or less, there is nothing we can do.
          > > >
          > > > The latest version supports archiving the old data to mmw files. If
          > > > you have thousands of transactions, I'd recommend you to
          archive, say
          > > > everything up to 12/31/2006 and see if it helps. You will be able to
          > > > access old data by opening the archive files and run reports on
          them,
          > > > but old data won't be slowing you down.
          > > >
          > > > Thanks,
          > > >
          > > > Alex Simanov
          > > > MechCAD Software.
          > > >
          > > > --- In acemoney@yahoogroups.com, "Matthew B. Howell, MOS"
          > > > <gavnone2001@> wrote:
          > > > >
          > > > > For the last 2 months or so, I have been experiencing 100% CPU
          > usage,
          > > > > resulting in a massive lag time, every time I go to enter a new
          > > > > transaction in AceMoney. I have upgraded to version 3.10a as of
          > a few
          > > > > minutes ago, yet the 100% CPU issue remains. I have changed all
          > of the
          > > > > settings under the Options menu in various combinations, have
          > exported
          > > > > older accounts to HTML files and removed them from AceMoney, have
          > > > > marked older transactions as "reconciled" and activated the "hide
          > > > > reconciled" feature, have changed the path of my backup folder
          > several
          > > > > times, have changed the "backup frequency" value to perform
          > > > > less-frequent backups, and have disabled the "autosave" feature. I
          > > > > have even re-installed AceMoney a few times. None of these
          changes,
          > > > > though, have solved the 100% CPU issue for me.
          > > > >
          > > > > Does anyone in this forum know what I can do to solve this issue?
          > > > >
          > > > > Matthew
          > > > >
          > > >
          > >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.