Loading ...
Sorry, an error occurred while loading the content.

16882Re: [YamahaDX] Re: [Jsynthlib-devel] release 1.0 promotion (fwd)

Expand Messages
  • Eb Mayat
    Mar 1 7:19 AM
    • 0 Attachment
      Martin wrote:


      I agree with Daniel that programmers should learn to care more about the 
      end-users. They should distribute a proper installer so that the user only 
      needs to double-click to get things running. A distributed xxxx.jar file 
      doesn't work like that. But at least someone IS working on the project.

      Did you start cmd.exe (on Windows) and type "java -jar 
      jsynthlib-1.0-executable.jar" on the commandline?

      What happens?

      Hello Martin

      It still would not work on an old Mac like Daniel's because the java version on PPC Macs is now outdated. 

      $ java -jar /Volumes/JSynthLib/JSynthLib.app/Contents/Resources/Java/jsynthlib-1.0-executable.jar 
      Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:676)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
       
      Regards,
      Eb


      On Saturday, March 1, 2014 9:01 AM, Martin Tarenskeen <m.tarenskeen@...> wrote:
       


      On Sat, 1 Mar 2014, victor jones wrote:

      > just updated my java still not running

      I agree with Daniel that programmers should learn to care more about the
      end-users. They should distribute a proper installer so that the user only
      needs to double-click to get things running. A distributed xxxx.jar file
      doesn't work like that. But at least someone IS working on the project.

      Did you start cmd.exe (on Windows) and type "java -jar
      jsynthlib-1.0-executable.jar" on the commandline?

      What happens?

      --

      MT


    • Show all 14 messages in this topic