Loading ...
Sorry, an error occurred while loading the content.

Xalan problem

Expand Messages
  • sunnyxi_chen@yahoo.com.cn
    hi,dear Mr/Mrss, Now I am developing a project using Xalan, I use it just like: java - cp .;xerces.jar;xalan.jar;bsf.jar;fop.jar;w3c.jar;xml.jar
    Message 1 of 1 , Oct 24, 2001
    • 0 Attachment
      hi,dear Mr/Mrss,
      Now I am developing a project using Xalan, I use it just
      like:

      "java -
      cp .;xerces.jar;xalan.jar;bsf.jar;fop.jar;w3c.jar;xml.jar
      org.apache.xalan.xslt.Process -in %1 -xsl a.xsl -out
      index.html"

      I met a problem, i found when i write my xml source file in
      chinese, such as

      "<title>ÄãµÄÎļþ</title> "

      and then in my xsl file, i write like this

      </xsl:attribute>
      <xsl:attribute name="alt">
      <xsl:value-of select="position()"/><xsl:text>.
      </xsl:text><xsl:value-of select="title"/>
      </xsl:attribute>

      but i found in the html file, it display like this:

      "<img border="0" height="20" width="380" name="menu2"
      src="imagemaster/menu2.jpg" alt="2.
      &#21019;&#24314;&#20320;&#30340;&#31532;&
      amp;#19968;&#20010;&#25945;&#31243;">
      "
      I need the content of title display as content of alt in
      html file, My OS is windows2000 chinese version, i found if
      i change the OS to english version, the content of alt will
      be ok, I wonder if it is a bug in Xalan to handle chinese
      Font? can anybody give me any suggestion? thanks a lot!
    Your message has been successfully submitted and would be delivered to recipients shortly.