Loading ...
Sorry, an error occurred while loading the content.

Re: text-align issue with fop 0.93

Expand Messages
  • kpuppala
    I haven t got any responses for the below mentioned issue. I was going through the known Issues list for fop 0.93 and it does mention about word spacing not
    Message 1 of 5 , Aug 28, 2007
    • 0 Attachment
      I haven't got any responses for the below mentioned issue. I was
      going through the 'known Issues' list for fop 0.93 and it does
      mention about word spacing not working as expected. The corresponding
      testcase is named block_word_spacing_text_align_justify.xml. There is
      not a whole lot of information provided on this issue. For the pudits
      on this forum, do you see any corelation between the issue I am faced
      and the one already documented? If so, are there any workarounds.


      --- In XSL-FO@yahoogroups.com, kumar puppala <kpuppala@...> wrote:
      >
      >
      > Hi,
      > We have been using apache fop 0.20.5 and are
      > planning to switch to .93 version. One difference I
      > noticed between the two is when we have
      > text-align="justify" set on an fo:block. I don't see
      > the text justified properly as it used to do in the
      > previous version. Are there any known issues here?
      >
      > Thanks,
      > Kumar
      >
      >
      >
      >
      >
      ______________________________________________________________________
      ______________
      > Got a little couch potato?
      > Check out fun summer activities for kids.
      > http://search.yahoo.com/search?
      fr=oni_on_mail&p=summer+activities+for+kids&cs=bz
      >
    • Chris Bowditch
      ... Does the text you are aligning contain any page-number-citations? I believe page number citations aren t properly aligned in fop-0.93. You might get better
      Message 2 of 5 , Aug 29, 2007
      • 0 Attachment
        kpuppala wrote:

        >
        >
        > I haven't got any responses for the below mentioned issue. I was
        > going through the 'known Issues' list for fop 0.93 and it does
        > mention about word spacing not working as expected. The corresponding
        > testcase is named block_word_spacing_text_align_justify.xml. There is
        > not a whole lot of information provided on this issue. For the pudits
        > on this forum, do you see any corelation between the issue I am faced
        > and the one already documented? If so, are there any workarounds.

        Does the text you are aligning contain any page-number-citations? I
        believe page number citations aren't properly aligned in fop-0.93. You
        might get better responses to FOP specific questions on the fop-users
        mailing list. See the following link for details on subscribing:

        http://xmlgraphics.apache.org/fop/maillist.html#fop-user

        Chris

        <snip/>
      • kumar puppala
        Thanks for the response. The text does not contain any page-number-citations. However, the layout is in dual column. If I render the same text in single column
        Message 3 of 5 , Aug 29, 2007
        • 0 Attachment
          Thanks for the response. The text does not contain any
          page-number-citations. However, the layout is in dual
          column. If I render the same text in single column
          layout, the very first line seems to be off but the
          remaining lines seem to align properly. I will post
          this on the other user group.

          thanks,
          Kumar
          --- Chris Bowditch <bowditch_chris@...> wrote:

          > kpuppala wrote:
          >
          > >
          > >
          > > I haven't got any responses for the below
          > mentioned issue. I was
          > > going through the 'known Issues' list for fop 0.93
          > and it does
          > > mention about word spacing not working as
          > expected. The corresponding
          > > testcase is named
          > block_word_spacing_text_align_justify.xml. There is
          > > not a whole lot of information provided on this
          > issue. For the pudits
          > > on this forum, do you see any corelation between
          > the issue I am faced
          > > and the one already documented? If so, are there
          > any workarounds.
          >
          > Does the text you are aligning contain any
          > page-number-citations? I
          > believe page number citations aren't properly
          > aligned in fop-0.93. You
          > might get better responses to FOP specific questions
          > on the fop-users
          > mailing list. See the following link for details on
          > subscribing:
          >
          >
          http://xmlgraphics.apache.org/fop/maillist.html#fop-user
          >
          > Chris
          >
          > <snip/>
          >
          >
          >
          >
          >
          > Yahoo! Groups Links
          >
          >
          >
          >
          >



          ____________________________________________________________________________________
          Shape Yahoo! in your own image. Join our Network Research Panel today! http://surveylink.yahoo.com/gmrs/yahoo_panel_invite.asp?a=7
        Your message has been successfully submitted and would be delivered to recipients shortly.