Loading ...
Sorry, an error occurred while loading the content.

Running Headers

Expand Messages
  • frank_n_kathy
    I am trying to create a running header using an fo:retrieve-marker element in the static-content region of my XSL, and an fo:marker in the flow region.
    Message 1 of 5 , Feb 3, 2006
    • 0 Attachment
      I am trying to create a running header using an fo:retrieve-marker
      element in the static-content region of my XSL, and an fo:marker in the
      flow region. However, I keep getting the following error message from
      FOP:
      [ERROR]:org.apache.fop.apps.StreamRenderer$RenderQueueEntry

      Does FOP support this marker feature for creating running headers?
      If it does, would someone please provide a simple example of its use.
      I've followed examples from both the Pawson and Holman books, but
      nothing seems to work.

      Any helpful advice appreciated!

      Regards,
      Frank
    • J.Pietschmann
      ... What FOP release do you use? ... Yes, see http://xmlgraphics.apache.org/fop/compliance.html Both the maintenance and the development release have gaps in
      Message 2 of 5 , Feb 3, 2006
      • 0 Attachment
        frank_n_kathy wrote:
        > I am trying to create a running header using an fo:retrieve-marker
        > element in the static-content region of my XSL, and an fo:marker in the
        > flow region. However, I keep getting the following error message from
        > FOP:
        > [ERROR]:org.apache.fop.apps.StreamRenderer$RenderQueueEntry

        What FOP release do you use?

        > Does FOP support this marker feature for creating running headers?

        Yes, see http://xmlgraphics.apache.org/fop/compliance.html
        Both the maintenance and the development release have gaps in the
        implementation of retrieve-position, the development release is much
        more complete.


        J.Pietschmann
      • Frank Bitetto
        Hello, I am using Fop-0.20.2. Does this version support using markers? If not, is it a simple upgrade from Apache. I see that there is a Fop-0.20.5 version.
        Message 3 of 5 , Feb 6, 2006
        • 0 Attachment
          Hello,

          I am using Fop-0.20.2. Does this version support using markers? If not, is it a simple upgrade from Apache. I see that there is a Fop-0.20.5 version.

          Thanks,
          Frank

          "J.Pietschmann" <j3322ptm@...> wrote: frank_n_kathy wrote:
          > I am trying to create a running header using an fo:retrieve-marker
          > element in the static-content region of my XSL, and an fo:marker in the
          > flow region. However, I keep getting the following error message from
          > FOP:
          > [ERROR]:org.apache.fop.apps.StreamRenderer$RenderQueueEntry

          What FOP release do you use?

          > Does FOP support this marker feature for creating running headers?

          Yes, see http://xmlgraphics.apache.org/fop/compliance.html
          Both the maintenance and the development release have gaps in the
          implementation of retrieve-position, the development release is much
          more complete.


          J.Pietschmann


          SPONSORED LINKS
          Xml xsl Xsl Xsl fo Xsl tutorial

          ---------------------------------
          YAHOO! GROUPS LINKS


          Visit your group "XSL-FO" on the web.

          To unsubscribe from this group, send an email to:
          XSL-FO-unsubscribe@yahoogroups.com

          Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.


          ---------------------------------





          ---------------------------------
          Brings words and photos together (easily) with
          PhotoMail - it's free and works with Yahoo! Mail.

          [Non-text portions of this message have been removed]
        • J.Pietschmann
          ... Yes, but there were some bugs. Upgrade either to the latest stable release (0.20.5), or the development code (0.9something). In either case prepare to do
          Message 4 of 5 , Feb 6, 2006
          • 0 Attachment
            Frank Bitetto wrote:
            > I am using Fop-0.20.2. Does this version support using markers?

            Yes, but there were some bugs. Upgrade either to the latest
            stable release (0.20.5), or the development code (0.9something).
            In either case prepare to do some changes to the FO code, check
            the FOP FAQ for a few common cases.

            J.Pietschmann
          Your message has been successfully submitted and would be delivered to recipients shortly.