Loading ...
Sorry, an error occurred while loading the content.

Re: [XSL-FO] xrefs

Expand Messages
  • Chris Bowditch
    ... It would be helpful if we could see a bit more of your XML. ... Have you tried Its just a guess at this stage. In
    Message 1 of 4 , Dec 1, 2003
    • 0 Attachment
      Norma Yeazell wrote:
      > I'm trying to get my xrefs to work properly, maybe I'm going about this
      > the wrong way, can anyone help?
      >
      > What I want is to have the actual figure number which is generated to
      > appear beside the word Fig.
      > As in: See Fig. 3 for details.
      >
      > The xml looks like :
      >
      > See <xref xrefid="figure-1" xidtype="figure"></xref> for details.

      It would be helpful if we could see a bit more of your XML.

      >
      > This is what I have right now in my FO and I get "See Fig. 0 for
      > details."
      >
      > <xsl:template match="xref">
      > <fo:basic-link background-color="lightblue"
      > internal-destination="{@xrefid <BLOCKED::mailto:{@xrefid> }">
      > <xsl:text>Fig. </xsl:text>
      > <xsl:number count="figure" level="any" from="mainfunc" format="1
      > "/>

      Have you tried <xsl:number count="figure" format="1"/>

      Its just a guess at this stage. In order to suggest what this needs to
      be I would need more information on the structure of your XML.

      <snip/>

      Chris
    • J.Pietschmann
      ... What does this mean? Do you get errors? Which errors? Is a PDF generated? ... ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ This is not a valid XPath expression, as
      Message 2 of 4 , Dec 1, 2003
      • 0 Attachment
        Norma Yeazell wrote:
        > I'm trying to get my xrefs to work properly, maybe I'm going about this
        > the wrong way, can anyone help?

        What does this mean? Do you get errors? Which errors? Is
        a PDF generated?

        > internal-destination="{@xrefid <BLOCKED::mailto:{@xrefid> }">
        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
        This is not a valid XPath expression, as it should be.

        > <xsl:text>Fig. </xsl:text>
        > <xsl:number count="figure" level="any" from="mainfunc" format="1

        It's hard to decide whether this is correct without having a look
        at the complete input. The spec says
        "If the 'from' attribute is specified, then only nodes after the first
        node before the current node that match the from pattern are
        considered."
        Maybe there is no mainfunc element starting before the xref element in
        question?

        > <xsl:template match="graphic">
        > <fo:wrapper keep-together.within-page="always">
        > <fo:external-graphic src="{@boardno}"/
        > <BLOCKED::mailto:{@boardno}"/> >
        Uh, another XML syntax error. Is this your mail client going berserk or
        what?

        J.Pietschmann
      • Norma Yeazell
        Sorry for some reason my email added some garbage and
        Message 3 of 4 , Dec 1, 2003
        • 0 Attachment
          Sorry for some reason my email added some garbage
          <BLOCKED::mailto:{@xrefid> and <BLOCKED::mailto:{@boardno} this part is
          not in my template.

          -----Original Message-----
          From: J.Pietschmann [mailto:j3322ptm@...]
          Sent: Monday, December 01, 2003 2:24 PM
          To: XSL-FO@yahoogroups.com
          Subject: Re: [XSL-FO] xrefs

          Norma Yeazell wrote:
          > I'm trying to get my xrefs to work properly, maybe I'm going about
          > this the wrong way, can anyone help?

          What does this mean? Do you get errors? Which errors? Is a PDF
          generated?

          > internal-destination="{@xrefid <BLOCKED::mailto:{@xrefid> }">
          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
          This is not a valid XPath expression, as it should be.

          > <xsl:text>Fig. </xsl:text>
          > <xsl:number count="figure" level="any" from="mainfunc"
          > format="1

          It's hard to decide whether this is correct without having a look at the
          complete input. The spec says
          "If the 'from' attribute is specified, then only nodes after the
          first
          node before the current node that match the from pattern are
          considered."
          Maybe there is no mainfunc element starting before the xref element in
          question?

          > <xsl:template match="graphic">
          > <fo:wrapper keep-together.within-page="always">
          > <fo:external-graphic src="{@boardno}"/
          > <BLOCKED::mailto:{@boardno}"/> >
          Uh, another XML syntax error. Is this your mail client going berserk or
          what?

          J.Pietschmann




          To unsubscribe from this group, send an email to:
          XSL-FO-unsubscribe@egroups.com



          Your use of Yahoo! Groups is subject to
          http://docs.yahoo.com/info/terms/




          Confidentiality Notice
          The information contained in this e-mail is confidential and intended for use only by the person(s) or organization listed in the address. If you have received this communication in error, please contact the sender at O'Neil & Associates, Inc., immediately. Any copying, dissemination, or distribution of this communication, other than by the intended recipient, is strictly prohibited.
        Your message has been successfully submitted and would be delivered to recipients shortly.