Loading ...
Sorry, an error occurred while loading the content.

Problem with Internal link with-in static content

Expand Messages
  • nilendu_b
    Hi, I am facing the following problem. I want to display a link a on the header of the page which takes the user to the Table of Contents. I have put the
    Message 1 of 2 , Aug 4, 2003
    • 0 Attachment
      Hi,

      I am facing the following problem. I want to display a link a on the
      header of the page which takes the user to the Table of Contents. I
      have put the link in a block contined in the static content.

      <fo:static-content flow-name="xsl-region-before">
      <fo:block text-align="end" text-decoration="underline"
      color="#0000FF" background-color="#FFFF00" relative-position="static">

      <fo:basic-link internal-destination="TableOfContents" >

      Return to TOC

      </fo:basic-link>

      </fo:block>
      ....
      ....

      The link appear alright, but actual hyperlink ( on which we need to
      click) is invisible and appears above the visible link. I want that
      the hyper-link and the visible link should be at the same palce.

      Please help.

      Thanks in advance

      Nilendu
    • hanpohwan
      Maybe FOP issue. I tried your trick with FOP and XEP. The output from the first doesn t support basic-link within static region(in my case region-after), while
      Message 2 of 2 , Aug 4, 2003
      • 0 Attachment
        Maybe FOP issue. I tried your trick with FOP and XEP. The output
        from the first doesn't support basic-link within static region(in my
        case region-after), while the second does.

        --- In XSL-FO@yahoogroups.com, "nilendu_b" <nilendu_b@y...> wrote:
        > Hi,
        >
        > I am facing the following problem. I want to display a link a on
        the
        > header of the page which takes the user to the Table of Contents.
        I
        > have put the link in a block contined in the static content.
        >
        > <fo:static-content flow-name="xsl-region-before">
        > <fo:block text-align="end" text-decoration="underline"
        > color="#0000FF" background-color="#FFFF00" relative-
        position="static">
        >

        > <fo:basic-link internal-destination="TableOfContents" >
        >
        > Return to TOC
        >
        > </fo:basic-link>
        >
        > </fo:block>
        > ....
        > ....
        >
        > The link appear alright, but actual hyperlink ( on which we need
        to
        > click) is invisible and appears above the visible link. I want
        that
        > the hyper-link and the visible link should be at the same palce.
        >
        > Please help.
        >
        > Thanks in advance
        >
        > Nilendu
      Your message has been successfully submitted and would be delivered to recipients shortly.