Loading ...
Sorry, an error occurred while loading the content.

Centering a table with FOP

Expand Messages
  • Richard Sweeney
    Can it be done?
    Message 1 of 5 , Oct 7, 2002
    • 0 Attachment
      Can it be done?
    • Oleg Tkachenko
      ... At the moment the only way is to include your table into another blind table:
      Message 2 of 5 , Oct 8, 2002
      • 0 Attachment
        Richard Sweeney wrote:
        > Can it be done?
        At the moment the only way is to include your table into another blind
        table:
        <fo:table table-layout="fixed" width="100%">
        <fo:table-column column-width="proportional-column-width(1)"/>
        <fo:table-column column-width="proportional-column-width(3)"/>
        <fo:table-column column-width="proportional-column-width(1)"/>
        <fo:table-body>
        <fo:table-row>
        <fo:table-cell/>
        <fo:table-cell text-align="center">
        ... table to be centered ...
        </fo:table-cell>
        <fo:table-cell/>
        </fo:table-row>
        </fo:table-body>
        </fo:table>

        --
        Oleg Tkachenko
        eXperanto team
        Multiconn International, Israel
      • narinder_g
        Hi Oleg, I have tried this, But when the table is long, again there is text overflow. Narinder ... blind
        Message 3 of 5 , Oct 9, 2002
        • 0 Attachment
          Hi Oleg,
          I have tried this, But when the table is long, again there is text
          overflow.
          Narinder

          --- In XSL-FO@y..., Oleg Tkachenko <olegt@m...> wrote:
          > Richard Sweeney wrote:
          > > Can it be done?
          > At the moment the only way is to include your table into another
          blind
          > table:
          > <fo:table table-layout="fixed" width="100%">
          > <fo:table-column column-width="proportional-column-width(1)"/>
          > <fo:table-column column-width="proportional-column-width(3)"/>
          > <fo:table-column column-width="proportional-column-width(1)"/>
          > <fo:table-body>
          > <fo:table-row>
          > <fo:table-cell/>
          > <fo:table-cell text-align="center">
          > ... table to be centered ...
          > </fo:table-cell>
          > <fo:table-cell/>
          > </fo:table-row>
          > </fo:table-body>
          > </fo:table>
          >
          > --
          > Oleg Tkachenko
          > eXperanto team
          > Multiconn International, Israel
        • Oleg Tkachenko
          ... What do you mean? I thought you are talking about centering the table, but overflow is different problem. Try to turn on hyphenation on table cells, it
          Message 4 of 5 , Oct 10, 2002
          • 0 Attachment
            narinder_g wrote:

            > I have tried this, But when the table is long, again there is text
            > overflow.
            What do you mean? I thought you are talking about centering the table, but
            overflow is different problem. Try to turn on hyphenation on table cells, it
            could help.

            --
            Oleg Tkachenko
            eXperanto team
            Multiconn International, Israel
          • narinder_g
            hi Oleg, What i meant was, as if the inner table is longer than the page, then the outer table s row does not break at the end of the page. And the contents
            Message 5 of 5 , Oct 10, 2002
            • 0 Attachment
              hi Oleg,
              What i meant was, as if the inner table is longer than the page, then
              the outer table's row does not break at the end of the page. And the
              contents crosses the bottom margin of the page.
              Hoping its clear now.
              Thanks, Have a nice day :)
              Narinder
              --- In XSL-FO@y..., Oleg Tkachenko <olegt@m...> wrote:
              > narinder_g wrote:
              >
              > > I have tried this, But when the table is long, again there is
              text
              > > overflow.
              > What do you mean? I thought you are talking about centering the
              table, but
              > overflow is different problem. Try to turn on hyphenation on table
              cells, it
              > could help.
              >
              > --
              > Oleg Tkachenko
              > eXperanto team
              > Multiconn International, Israel
            Your message has been successfully submitted and would be delivered to recipients shortly.