Loading ...
Sorry, an error occurred while loading the content.

Re: running FOP (0.20.3) using VB-components

Expand Messages
  • wbichelaer
    Hi, I always run FOP in debug mode, but you do not see the command prompt window on the server, because it runs in the background. Willem ... my ... VB- ...
    Message 1 of 8 , Jul 15, 2002
    • 0 Attachment
      Hi,

      I always run FOP in debug mode, but you do not see the command prompt
      window on the server, because it runs in the background.

      Willem


      --- In XSL-FO@y..., Oleg Tkachenko <olegt@m...> wrote:
      > wbichelaer wrote:
      >
      > > We have some problems to get FOP 0.20.3 to run in a Microsoft
      > > environment. We are using VB-components which are running in MTS
      > > under a specific account.
      > >
      > > This VB-components uses the shell command to start FOP. If I run
      my
      > > application nothing happens (not even errors), but if I set the
      VB-
      > > component under the administrator account in MTS it all works
      fine.
      > > It looks like I got a security issue, because I'm getting no
      errors
      > > I'm not really sure where its coming from. I gave my specific user
      > > right on the FOP and JDK folder and rights to the folder where FOP
      > > writes its output (all full control)..
      > >
      > > Does anybody have any idea?
      > Run fop in debug mode (add -d option into command line) in order to
      see what's
      > going on.
      >
      > --
      > Oleg Tkachenko
      > Multiconn International, Israel
    • wbichelaer
      Euh...what do you mean? A log output file or the PDF file? About the PDF file I ve mentioned that in my first message. Willem ... prompt
      Message 2 of 8 , Jul 15, 2002
      • 0 Attachment
        Euh...what do you mean? A log output file or the PDF file? About the
        PDF file I've mentioned that in my first message.

        Willem

        --- In XSL-FO@y..., Oleg Tkachenko <olegt@m...> wrote:
        > wbichelaer wrote:
        >
        > > I always run FOP in debug mode, but you do not see the command
        prompt
        > > window on the server, because it runs in the background.
        > So, try to redirect output to a file.
        >
        > --
        > Oleg Tkachenko
        > Multiconn International, Israel
      • wbichelaer
        I read this is the log file: DEBUG] Input mode: [DEBUG] xslt transformation [DEBUG] xml input file: C: Documents and Settings WiBichelaer My
        Message 3 of 8 , Jul 15, 2002
        • 0 Attachment
          I read this is the log file:
          DEBUG] Input mode:
          [DEBUG] xslt transformation
          [DEBUG] xml input file: C:\Documents and Settings\WiBichelaer\My
          Documents\Work\ebonline\ebs\xml\C0F8FF20CB49834A9FCBEEB047C9B3D6.xml
          [DEBUG] xslt stylesheet: C:\Documents and Settings\WiBichelaer\My
          Documents\Work\ebonline\ebs\xsl\algemeen_versie_2.0.xsl
          [DEBUG] Output mode:
          [DEBUG] awt on screen
          [DEBUG] OPTIONS
          [DEBUG] user configuration file: conf\userconfig.xml
          [DEBUG] debug mode on
          [DEBUG] dump configuration
          [DEBUG] quiet mode on
          [DEBUG] Using org.apache.xerces.parsers.SAXParser as SAX2 Parser
          [DEBUG] reading user configuration file
          [DEBUG] Using org.apache.xerces.parsers.SAXParser as SAX2 Parser
          [DEBUG] base directory: file:/C:/Documents and
          Settings/WiBichelaer/My Documents/Work/ebonline/ebs/xml/
          [ERROR] Logger not set
          [DEBUG] Using org.apache.xerces.parsers.SAXParser as SAX2 Parser
          [INFO] building formatting object tree
          [DEBUG] setting up fonts
          [INFO] [1]
          [INFO] [2]
          [INFO] [1]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] [2]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] [3]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] [4]
          [INFO] [5]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] [6]
          [INFO] [7]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] [8]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] [9]
          [INFO] [10]
          [INFO] [11]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] [12]
          [INFO] [13]
          [INFO] [14]
          [INFO] [15]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] [16]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] [17]
          [INFO] [18]
          [INFO] [19]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] [20]
          [ERROR] At least one of minimum, optimum, or maximum IPD must be
          specified on table.
          [INFO] Parsing of document complete, stopping renderer

          So I see an [Error]: Logger not set.

          What can I do with that?

          Willem
        • Oleg Tkachenko
          ... Run fop in debug mode (add -d option into command line) in order to see what s going on. -- Oleg Tkachenko Multiconn International, Israel
          Message 4 of 8 , Jul 15, 2002
          • 0 Attachment
            wbichelaer wrote:

            > We have some problems to get FOP 0.20.3 to run in a Microsoft
            > environment. We are using VB-components which are running in MTS
            > under a specific account.
            >
            > This VB-components uses the shell command to start FOP. If I run my
            > application nothing happens (not even errors), but if I set the VB-
            > component under the administrator account in MTS it all works fine.
            > It looks like I got a security issue, because I'm getting no errors
            > I'm not really sure where its coming from. I gave my specific user
            > right on the FOP and JDK folder and rights to the folder where FOP
            > writes its output (all full control)..
            >
            > Does anybody have any idea?
            Run fop in debug mode (add -d option into command line) in order to see what's
            going on.

            --
            Oleg Tkachenko
            Multiconn International, Israel
          • Oleg Tkachenko
            ... So, try to redirect output to a file. -- Oleg Tkachenko Multiconn International, Israel
            Message 5 of 8 , Jul 15, 2002
            • 0 Attachment
              wbichelaer wrote:

              > I always run FOP in debug mode, but you do not see the command prompt
              > window on the server, because it runs in the background.
              So, try to redirect output to a file.

              --
              Oleg Tkachenko
              Multiconn International, Israel
            • Oleg Tkachenko
              ... I mean redirect fop debug into a file, e.g. fop -xsl docs xml2pdf.xsl -xml docs xslfoRef.xml -awt log.txt 2 &1 -- Oleg Tkachenko Multiconn International,
              Message 6 of 8 , Jul 15, 2002
              • 0 Attachment
                wbichelaer wrote:
                > Euh...what do you mean? A log output file or the PDF file? About the
                > PDF file I've mentioned that in my first message.
                I mean redirect fop debug into a file, e.g.
                fop -xsl docs\xml2pdf.xsl -xml docs\xslfoRef.xml -awt >log.txt 2>&1

                --
                Oleg Tkachenko
                Multiconn International, Israel
              • Oleg Tkachenko
                ... That s actually not a error at all, it s usual fop message :) Well, add log.txt 2 &1 to the end of your real fop command line and see what s going on. --
                Message 7 of 8 , Jul 15, 2002
                • 0 Attachment
                  wbichelaer wrote:

                  > So I see an [Error]: Logger not set.
                  >
                  > What can I do with that?
                  That's actually not a error at all, it's usual fop message :)
                  Well, add >log.txt 2>&1 to the end of your real fop command line and see
                  what's going on.

                  --
                  Oleg Tkachenko
                  Multiconn International, Israel
                Your message has been successfully submitted and would be delivered to recipients shortly.