Loading ...
Sorry, an error occurred while loading the content.

Marker problem

Expand Messages
  • Steven Ford
    I get the following error when using a marker: marker cannot be added to org.apache.fop.fo.flow.Block@54c2b8 marker cannot be added to
    Message 1 of 1 , Dec 4, 2001
    • 0 Attachment
      I get the following error when using a marker:

      marker cannot be added to 'org.apache.fop.fo.flow.Block@54c2b8'marker
      cannot be added to 'org.apache.fop.fo.flow.Block@3be73b' [1] [2]
      [3Warning: Some static content could not fit in the area.


      I retrieve the marker in the xsl-region-before. It shows up fine in
      the first and second pages but fails in the third. Where it fails is
      when a table spans over into a new page.

      I am displaying data grouped by "Center". each center is in a table
      which is in it's own block. At the top of the block I have:

      <fo:marker marker-class-name="center">
      Center: 2014450000 - Clinical Chemistry <!-- from database -->
      </fo:marker>

      I get 3 pages. the first page is fine, the center has a few rows and
      fits on one page. The next center starts on a new page (I use
      <fo:block break-before="page">). page 2 is fine but page 3 is a
      continuation of the block & table that started on page 2 and I get
      the above error.

      Does anyone have an idea what is causing this?

      PS - If you can't tell by my question I am new to XSL-FO
    Your message has been successfully submitted and would be delivered to recipients shortly.