Loading ...
Sorry, an error occurred while loading the content.

Re: [V4Protocol] TS-590 USB Data Mode

Expand Messages
  • Rick Muething
    Ron, I probably missed something. I used code from another application for the TS-590S. It should be USB digital and it also has to switch the internal mux
    Message 1 of 9 , Jun 17, 2012
    • 0 Attachment
      Ron,
      I probably missed something. I used code from another application for the TS-590S.  It should be USB digital and it also has to switch the internal mux from Aux to USB sound card input to the radio.  I’ll check it out ...may be a day or two. I have a TS-590 here just not currently setup.
       
      Rick KN6KB
       
       
      From: Ron Wenig
      Sent: Sunday, June 17, 2012 7:59 AM
      Subject: [V4Protocol] TS-590 USB Data Mode
       
       

      Hi Rick,

      I have a Kenwood TS-590 radio and I am using V4 Chat version 1.0.2.0.
      In the radio setup I have USB Data selected. When the program switches
      frequency it will also switch the radio's mode to FSK instead of USB
      Data. When I select USB the radio will switch to USB then I have to
      manually select Data mode on the radio. Is this because the program is
      sending the wrong command to the radio.

      73, Ron ny3j

    • Rick Muething
      Ron, I found several problems in the code for the TS-590S (a result of not checking the patched in code from another project!) There were also several errors
      Message 2 of 9 , Jun 17, 2012
      • 0 Attachment
        Ron,
         
        I found several problems in the code for the TS-590S (a result of not checking the patched in code from another project!) There were also several errors in the Help for the setup.  I have it running fine now here on my TS-590S.  There is no need for a serial cable for PTT control ...the new code will correctly control the PTT though the normal USB port and set the internal mux of the TS-590S to select the USB sound card output as well as put the radio into the correct mode of USB Data.  I will get an update out for this tomorrow along with the updated help.
         
        Rick
         
        From: Ron Wenig
        Sent: Sunday, June 17, 2012 11:42 PM
        Subject: Re: [V4Protocol] TS-590 USB Data Mode
         
         

        Thanks Rick,

        The new version works great with the TS-590.  I am now using a serial cable for rig control and PTT control and the USB port only for sound.  I am getting TR Latency about 40 to 70 ms and the CW ID keying mode sounds much better than the modulated mode.

        Ron ny3j

        On 6/17/2012 1:45 PM, Rick Muething wrote:
         
        Ron,
        I probably missed something. I used code from another application for the TS-590S.  It should be USB digital and it also has to switch the internal mux from Aux to USB sound card input to the radio.  I’ll check it out ...may be a day or two. I have a TS-590 here just not currently setup.
         
        Rick KN6KB
         
         
        From: Ron Wenig
        Sent: Sunday, June 17, 2012 7:59 AM
        Subject: [V4Protocol] TS-590 USB Data Mode
         


      • Ron Wenig
        Thanks Rick, The new version works great with the TS-590. I am now using a serial cable for rig control and PTT control and the USB port only for sound. I am
        Message 3 of 9 , Jun 17, 2012
        • 0 Attachment
          Thanks Rick,

          The new version works great with the TS-590.  I am now using a serial cable for rig control and PTT control and the USB port only for sound.  I am getting TR Latency about 40 to 70 ms and the CW ID keying mode sounds much better than the modulated mode.

          Ron ny3j

          On 6/17/2012 1:45 PM, Rick Muething wrote:
           

          Ron,
          I probably missed something. I used code from another application for the TS-590S.  It should be USB digital and it also has to switch the internal mux from Aux to USB sound card input to the radio.  I’ll check it out ...may be a day or two. I have a TS-590 here just not currently setup.
           
          Rick KN6KB
           
           
          From: Ron Wenig
          Sent: Sunday, June 17, 2012 7:59 AM
          Subject: [V4Protocol] TS-590 USB Data Mode
           
           

        • Ron Wenig
          Ok Rick, I misunderstood you before. I thought the change was going to be using the serial port. I didn t understand the internal mux. I have updated to
          Message 4 of 9 , Jun 18, 2012
          • 0 Attachment
            Ok Rick,

            I misunderstood you before.  I thought the change was going to be using the serial port.  I didn't understand the internal mux.  I have updated to 1.0.3.0 and am now using just the USB port using the setup instructions in the help section.  I am getting a Latency reading of between 50 and 110.  Rig control works great and it is now setting my radio to USB Data mode.  Things are working really good.  Thanks.

            Ron ny3j

            On 6/17/2012 9:22 PM, Rick Muething wrote:
             

            Ron,
             
            I found several problems in the code for the TS-590S (a result of not checking the patched in code from another project!) There were also several errors in the Help for the setup.  I have it running fine now here on my TS-590S.  There is no need for a serial cable for PTT control ...the new code will correctly control the PTT though the normal USB port and set the internal mux of the TS-590S to select the USB sound card output as well as put the radio into the correct mode of USB Data.  I will get an update out for this tomorrow along with the updated help.
             
            Rick
             
            From: Ron Wenig
            Sent: Sunday, June 17, 2012 11:42 PM
            Subject: Re: [V4Protocol] TS-590 USB Data Mode
             
             

            Thanks Rick,

            The new version works great with the TS-590.  I am now using a serial cable for rig control and PTT control and the USB port only for sound.  I am getting TR Latency about 40 to 70 ms and the CW ID keying mode sounds much better than the modulated mode.

            Ron ny3j

            On 6/17/2012 1:45 PM, Rick Muething wrote:
             
            Ron,
            I probably missed something. I used code from another application for the TS-590S.  It should be USB digital and it also has to switch the internal mux from Aux to USB sound card input to the radio.  I’ll check it out ...may be a day or two. I have a TS-590 here just not currently setup.
             
            Rick KN6KB
             
             
            From: Ron Wenig
            Sent: Sunday, June 17, 2012 7:59 AM
            Subject: [V4Protocol] TS-590 USB Data Mode
             




        • Rick Muething
          Fine Ron, Glad it is working OK. I am using it here. The same simple setup works well with RMS Express using the WINMOR sound card protocol (see
          Message 5 of 9 , Jun 18, 2012
          • 0 Attachment
            Fine Ron,
             
            Glad it is working OK.  I am using it here.
             
            The same simple setup works well with RMS Express using the WINMOR sound card protocol (see ftp://autoupdate.winlink.org/User%20Programs/ ) . RMS Express lets you send messages with attachments to other hams or to internet recipients through the WL2K system.
             
            I really like the simplicity of setup using radios like the the TS-590S and IC–7200  with sound card modes. 
             
            73,
             
            Rick KN6KB
             
             
            From: Ron Wenig
            Sent: Monday, June 18, 2012 3:48 PM
            Subject: Re: [V4Protocol] TS-590 USB Data Mode
             
             

            Ok Rick,

            I misunderstood you before.  I thought the change was going to be using the serial port.  I didn't understand the internal mux.  I have updated to 1.0.3.0 and am now using just the USB port using the setup instructions in the help section.  I am getting a Latency reading of between 50 and 110.  Rig control works great and it is now setting my radio to USB Data mode.  Things are working really good.  Thanks.

            Ron ny3j

            On 6/17/2012 9:22 PM, Rick Muething wrote:
             
            Ron,
             
            I found several problems in the code for the TS-590S (a result of not checking the patched in code from another project!) There were also several errors in the Help for the setup.  I have it running fine now here on my TS-590S.  There is no need for a serial cable for PTT control ...the new code will correctly control the PTT though the normal USB port and set the internal mux of the TS-590S to select the USB sound card output as well as put the radio into the correct mode of USB Data.  I will get an update out for this tomorrow along with the updated help.
             
            Rick
             
            From: Ron Wenig
            Sent: Sunday, June 17, 2012 11:42 PM
            Subject: Re: [V4Protocol] TS-590 USB Data Mode
             
             

            Thanks Rick,

            The new version works great with the TS-590.  I am now using a serial cable for rig control and PTT control and the USB port only for sound.  I am getting TR Latency about 40 to 70 ms and the CW ID keying mode sounds much better than the modulated mode.

            Ron ny3j

            On 6/17/2012 1:45 PM, Rick Muething wrote:
             
            Ron,
            I probably missed something. I used code from another application for the TS-590S.  It should be USB digital and it also has to switch the internal mux from Aux to USB sound card input to the radio.  I’ll check it out ...may be a day or two. I have a TS-590 here just not currently setup.
             
            Rick KN6KB
             
             
            From: Ron Wenig
            Sent: Sunday, June 17, 2012 7:59 AM
            Subject: [V4Protocol] TS-590 USB Data Mode
             




          • Ron Wenig
            Rick, I do use RMS Express and Winmor to send and receive mail over HF and it works flawlessly on the TS-590. My thanks to you and the other programmers at
            Message 6 of 9 , Jun 18, 2012
            • 0 Attachment
              Rick,

              I do use RMS Express and Winmor to send and receive mail over HF and it works flawlessly on the TS-590.  My thanks to you and the other programmers at the Foundation for creating such a great program. 

              We have two ARES nets here in the Philadelphia area where we can send a Winlink email to check into.  As a test I use Paclink on VHF to check into one and RMS Express on HF to check into the other one.  I always get good comments on the flexibility I have to use HF to use for sending email in case the VHF packet infrastructure was down.  I wish I could get more interest in RMS Express on HF but I can't get people to put forth the effort to learn how to setup and use the program.

              73, Ron ny3j

              On 6/18/2012 5:08 PM, Rick Muething wrote:
               

              Fine Ron,
               
              Glad it is working OK.  I am using it here.
               
              The same simple setup works well with RMS Express using the WINMOR sound card protocol (see ftp://autoupdate.winlink.org/User%20Programs/ ) . RMS Express lets you send messages with attachments to other hams or to internet recipients through the WL2K system.
               
              I really like the simplicity of setup using radios like the the TS-590S and IC–7200  with sound card modes. 
               
              73,
               
              Rick KN6KB
               
               


            • Facility 406 DM09
              ... Info? Link? Kurt
              Message 7 of 9 , Jun 18, 2012
              • 0 Attachment
                : get more interest in RMS Express on HF but I can't get people to put
                : forth the effort to learn how to setup and use the program.


                Info? Link?

                Kurt
              • Ron Wenig
                The software is located at: http://www.winlink.org/ClientSoftware The support group is at: http://groups.yahoo.com/group/WINMOR/ Ron ny3j
                Message 8 of 9 , Jun 19, 2012
                • 0 Attachment
                  The software is located at:

                  http://www.winlink.org/ClientSoftware

                  The support group is at:

                  http://groups.yahoo.com/group/WINMOR/

                  Ron ny3j

                  On 6/19/2012 12:27 AM, Facility 406 DM09 wrote:
                   

                  : get more interest in RMS Express on HF but I can't get people to put
                  : forth the effort to learn how to setup and use the program.

                  Info? Link?

                  Kurt



                • Your message has been successfully submitted and would be delivered to recipients shortly.