Loading ...
Sorry, an error occurred while loading the content.

[USAphotomaps] Re: X's, Line Corruption and "Busy" Browser Popups

Expand Messages
  • Doug Cox
    I empathize with you for the problems you re having. But they re extremely weird and extremely unusual, and they ve never happened to me. Well, the corrupted
    Message 1 of 15 , Oct 24, 2009
    View Source
    • 0 Attachment
      I empathize with you for the problems you're having. But they're extremely weird and extremely unusual, and they've never happened to me. Well, the corrupted lines have happened, probably because I was doing more than one thing at a time, and USAPM is sensitive to that -- but not like what is happening to you. Those bad lines of mine were easily deleted with Shift-Delete and didn't recur or affect other lines.

      Doug Cox
      _________________________________
      You wrote (Fri, 23 Oct 2009 21:49:55 -0000):

      --- In USAphotomaps@yahoogroups.com, "cr4130" <yahoogroups@...> wrote:
      >
      > I'm not sure it has been mentioned yet, but when I get the dreaded X'es on a screen which which was already partially filled, they overlay on the already filled tiles. It apparently gets totally clueless about the screen's existing data.
      > > Henry
      >

      Some more observations and clues to the X's and corruption problems.
      I have had the X's appear on a fully tiled screen that was populated before I initiated a Fill operation. (ie: there was nothing to fill)

      I had a major line corruption battle yesterday on a zone in an area that was almost fully populated from east to west. There were some end of line corruptions on a couple of lines that I was trying to clean up by deleting tiles from the start of the corruption to the end of the line (a hotkey sequence for deleting from current tile to end of line would be great, ALT-DEL?), but the X's got so bad that other lines got corrupted after using the "Stop Download" several times even though I made sure to stay in place to fill out the whole screen and repeated the fill after all tiles were filled in when the X's appeared after filling in all the gaps. This implies to me that the X problem actually occurs at some point before a TCP request is sent out unless, for some reason, a request would be generated even if there are no tiles to fill. Could it possibly be a PTR file corruption problem?

      Interestingly enough, a couple of the line corruptions would extend well past the end of the zone to the extreme right edge of the screen at any zoom level.

      After deleting 5 lines worth of data because of new corruptions, I gave up and restored them from one of my 22 day old backups and tried again, but I still could not repair any significant amount of corruption without corrupting other lines.

      I also ran into a corrupted line that would crash the program when I attempted to delete any of the corrupted/black tiles in that line. I had to delete the PTR file to get rid of it.

      Is it possible that my large screen resolution of 2560x1600 could have anything to do with the problem? I had tried using a small window to fill a small area, but it still checked and filled the full screen's worth of data, not just the window's :(

      With almost 25,000 data files for over 30 GB of data in USAPhotoMaps, using it this has become quite frustrating and distressing for me.

      Henry

      _________________________________
    Your message has been successfully submitted and would be delivered to recipients shortly.