Loading ...
Sorry, an error occurred while loading the content.

Re: [TriumphTrophy] sidestand switch ? Clutch switch ? Neutral Switch ? TWO problems

Expand Messages
  • joan tabberer
    You said... 2) For some reason, the sidestand light on the instrument panel never light ups. I thinks there sould be an exclamation mark signal when the
    Message 1 of 10 , May 2, 2013
    • 0 Attachment
      You said...

      2) For some reason, the sidestand light on the instrument panel never light ups. I thinks there sould be an exclamation mark signal when the ignition is ON and the sidestand is deployed ? 
       
      Have you checked the bulb is still good?
       
      Joan
      .
    • clepeterd
      I ll check it. I will also check the idiot light bulb (Overtemp) as it does not seem to work either... Do you know of a place where I can buy brighter turn
      Message 2 of 10 , May 4, 2013
      • 0 Attachment
        I'll check it. I will also check the idiot light bulb (Overtemp) as it does not seem to work either...

        Do you know of a place where I can buy brighter turn indicators ? I can barely see them !

        --- In TriumphTrophy@yahoogroups.com, joan tabberer <rebullet@...> wrote:
        >
        > You said...
        >
        > 2) For some reason, the sidestand light on the instrument panel never light ups. I thinks there sould be an exclamation mark signal when the ignition is ON and the sidestand is deployed ? 
        >  
        > Have you checked the bulb is still good?
        >  
        > Joan
        >
        > .
        >
      • slovcan
        For the Sidestand switch and Temp light - do the TSB/mod for the temp light ground wire relocation. Remove the Sidestand switch and clean the contact on it and
        Message 3 of 10 , May 5, 2013
        • 0 Attachment
          For the Sidestand switch and Temp light - do the TSB/mod for the temp light ground wire relocation.

          Remove the Sidestand switch and clean the contact on it and the contact plate inside the gearbox with a bit of emery cloth secured to the blade of a common screwdriver. Make sure to use a long enough piece of emery cloth that it comes far enough up the screwdriver shaft so it can't accidentally fall of INSIDE the gearbox.

          Clean the clutch switch with a bit of said emery cloth (one screw takes it off). Pry it apart with a tiny screwdiver under the plastic tabs that hold the housing together.

          Clean the kill switch by taking apart the right side switch pod and spraying contact cleaner. Put it back together and work the s=kill switch on/off a dozen or so times.

          Take the big spade terminals off the starter solenoid and clean the spades. Also try to tighten up the female part of the connectors by compressing them with a common screwdriver or small needlenose piers.

          Take out the alternator bolt that has the ground cable fitted to it and claen the contact surfaces and washer.

          Finally (maybe) install an additional ground cable from the battery to the ground point under the seat. Clean this point when doing this.

          That should solve ALL your problems. It is what I did. She cranks over faster on the starter than ever before and starts super easily. I still may do the relay for voltage to the coils, though (Katana mod or Johnson Jolt talked about here recently).

          Cheers,
          Glenn

          --- In TriumphTrophy@yahoogroups.com, "clepeterd" <clepeterd@...> wrote:
          >
          >
          > I'll check it. I will also check the idiot light bulb (Overtemp) as it does not seem to work either...
          >
          > Do you know of a place where I can buy brighter turn indicators ? I can barely see them !
          >
          > --- In TriumphTrophy@yahoogroups.com, joan tabberer <rebullet@> wrote:
          > >
          > > You said...
          > >
          > > 2) For some reason, the sidestand light on the instrument panel never light ups. I thinks there sould be an exclamation mark signal when the ignition is ON and the sidestand is deployed ? 
          > >  
          > > Have you checked the bulb is still good?
          > >  
          > > Joan
          > >
          > > .
          > >
          >
        • gordon2xbbb
          Just hang on a minute....are you sure it is wise to introduce something very abrasive to the insides of a gearbox ??? That s why I would recommend just using
          Message 4 of 10 , May 6, 2013
          • 0 Attachment
            Just hang on a minute....are you sure it is wise to introduce something very abrasive to the insides of a gearbox ???

            That's why I would recommend just using the TIP of a long thin screwdriver blade to GENTLY ABRADE the selector drum neutral segment. That will remove the surface patina and not leave anything in there that can do untold damage to seals and bearings...once it's in the oil you never know where it will get to before it gets trapped in the filter...

            Emery paper or cloth is coated with Carborundum paste - same sort of stuff you use to lapp in valves....you leave any of that stuff in your engine at your peril.
            Would you add a pinch of sand perhaps for good luck ?
            No, I don't think so..

            If you think I'm talking tosh then PLEASE exercise extreme caution and don't cock it up..

            Cheers
            Gordon
            2xBBB
            Stroud, Gloucestershire, UK

            --- In TriumphTrophy@yahoogroups.com, "slovcan" <slovcan@...> wrote:


            and the contact plate inside the gearbox with a bit of emery cloth secured to the blade of a common screwdriver. Make sure to use a long enough piece of emery cloth that it comes far enough up the screwdriver shaft so it can't accidentally fall of INSIDE the gearbox.
          • Don Varnau
            Agreed. The Coolant Temp Warning Light fix (in the Files section) fixed intermittent neutral switch and sidestand switch problems I was having. Don 97 900 ...
            Message 5 of 10 , May 6, 2013
            • 0 Attachment
              Agreed. The Coolant Temp Warning Light fix (in the Files section) fixed
              intermittent neutral switch and sidestand switch problems I was having.

              Don
              '97 900

              ----- Original Message -----
              From: slovcan
              Sent: Sunday, May 05, 2013 11:37 PM
              Subject: [TriumphTrophy] Re: sidestand switch ? Clutch switch ? Neutral
              Switch ? TWO problems


              For the Sidestand switch and Temp light - do the TSB/mod for the temp light
              ground wire relocation.
            • slovcan
              Valid point, Gordon. I did this 8-10000 kms ago. So far no issues and everything works as it should. Mind you, I made 3-4 swipes with the emery cloth and
              Message 6 of 10 , May 6, 2013
              • 0 Attachment
                Valid point, Gordon. I did this 8-10000 kms ago. So far no issues and everything works as it should. Mind you, I made 3-4 swipes with the emery cloth and changed the oil twice since then. So, for caution, just a couple of swipes, run the engine to check results and change the oil. Or, heed Gordon's good advice and just use the tip of the screwdriver.

                Cheers,
                Glenn

                --- In TriumphTrophy@yahoogroups.com, "gordon2xbbb" <gordon.smith29@...> wrote:
                >
                > Just hang on a minute....are you sure it is wise to introduce something very abrasive to the insides of a gearbox ???
                >
                > That's why I would recommend just using the TIP of a long thin screwdriver blade to GENTLY ABRADE the selector drum neutral segment. That will remove the surface patina and not leave anything in there that can do untold damage to seals and bearings...once it's in the oil you never know where it will get to before it gets trapped in the filter...
                >
                > Emery paper or cloth is coated with Carborundum paste - same sort of stuff you use to lapp in valves....you leave any of that stuff in your engine at your peril.
                > Would you add a pinch of sand perhaps for good luck ?
                > No, I don't think so..
                >
                > If you think I'm talking tosh then PLEASE exercise extreme caution and don't cock it up..
                >
                > Cheers
                > Gordon
                > 2xBBB
                > Stroud, Gloucestershire, UK
                >
                > --- In TriumphTrophy@yahoogroups.com, "slovcan" <slovcan@> wrote:
                >
                >
                > and the contact plate inside the gearbox with a bit of emery cloth secured to the blade of a common screwdriver. Make sure to use a long enough piece of emery cloth that it comes far enough up the screwdriver shaft so it can't accidentally fall of INSIDE the gearbox.
                >
              • Greg
                Hi Glenn, How about putting some contact cleaner on a Q-tip. Then use the Q-tip to clean the patina off. No chance of grit. Greg slovcan wrote: Valid point,
                Message 7 of 10 , May 6, 2013
                • 0 Attachment
                  Hi Glenn, How about putting some contact cleaner on a Q-tip. Then use the Q-tip to clean the patina off. No chance of grit.
                  Greg

                  "slovcan" wrote:
                  Valid point, Gordon. I did this 8-10000 kms ago. So far no issues and everything works as it should. Mind you, I made 3-4 swipes with the emery cloth and changed the oil twice since then. So, for caution, just a couple of swipes, run the engine to check results and change the oil. Or, heed Gordon's good advice and just use the tip of the screwdriver.
                  Cheers,
                  Glenn
                • slovcan
                  Yes, Greg. That might have worked, too. I forgot what may have been the key thing that I did. I thinned the aluminum sealing washer a good bit to try to give
                  Message 8 of 10 , May 7, 2013
                  • 0 Attachment
                    Yes, Greg. That might have worked, too. I forgot what may have been the key thing that I did. I thinned the aluminum sealing washer a good bit to try to give the switch that much better contact with the tab.

                    Cheers,
                    Glenn

                    --- In TriumphTrophy@yahoogroups.com, "Greg" <gandrews@...> wrote:
                    >
                    > Hi Glenn, How about putting some contact cleaner on a Q-tip. Then use the Q-tip to clean the patina off. No chance of grit.
                    > Greg
                    >
                    > "slovcan" wrote:
                    > Valid point, Gordon. I did this 8-10000 kms ago. So far no issues and everything works as it should. Mind you, I made 3-4 swipes with the emery cloth and changed the oil twice since then. So, for caution, just a couple of swipes, run the engine to check results and change the oil. Or, heed Gordon's good advice and just use the tip of the screwdriver.
                    > Cheers,
                    > Glenn
                    >
                  Your message has been successfully submitted and would be delivered to recipients shortly.