Loading ...
Sorry, an error occurred while loading the content.

Re: New to board and TMS470

Expand Messages
  • leomecma
    Hi, My name s Leonardo and I starting with ARM uC. I choose TMS470 and I have some questions, maybe you can help me. Do you have the JTAG scheme, between
    Message 1 of 2 , Jun 14 9:51 AM
    • 0 Attachment
      Hi,
      My name's Leonardo and I starting with ARM uC. I choose TMS470 and
      I have some questions, maybe you can help me. Do you have the JTAG
      scheme, between TMS470 and Standard 20 pin JTAG? How Can I do protect
      the program code? I didn't see pins for Bootstrap load. Do you have
      any scheme or documents about this uC, that different of TI's page?
      Are you using any OS? What? Do you have the files?

      Thanks,
      Obs: Sorry, but my english isn't very well.



      --- In TMS470_ARM@yahoogroups.com, "firstyearawd" <firstyearawd@y...>
      wrote:
      >
      > Well I am new here so I figured I would introduce myself and share
      my
      > experiences.
      >
      > My name is Don Kebort and I am an engineer at a company called
      > Agility Communications. I primarily design test boards and test
      > systems for testing tunable lasers. Most of my embedded experience
      > is with the 28x DSPs and the MSP430.
      >
      > I have been interested in playing with ARM for some time now (even
      > did a little GBA development) and I have always been happy with
      TI's
      > support, so I figured the 470 was a good way to get started.
      >
      > So I purchase the IAR kickstart kit after taking TI's little online
      > seminar (50% off EVM). Take it out of the box and install
      software.
      > Example program builds, but I am unable to start the debugger.
      After
      > a few hours talking with support from both TI and IAR and scoping
      the
      > JTAG signals, we determine they sent me an MSP430 emulator instead
      of
      > the ARM emulator. Even said it right on the box. I must be
      blind!
      > I was pleased with the support though I think they (TI, NOT IAR)
      knew
      > it was the wrong emulator in the beginning but didn't want to
      say...
      > Long story short - They say they have overnighted the correct one.
      > Should show up today, we'll see. Again, I was very pleased with
      the
      > support from both companies.
      >
      > In the meantime, I realized my copy of TI's Code Composer Studio
      for
      > OMAP parts supports the TMS470! Good deal! Loaded the SW, plugged
      > in the Spectrum Digital SPI515 emulator and all was well. The only
      > problem is I have no header files to make my life easier. Does
      > anyone have any non-IAR headers to help get me started? Also, are
      > there any stand alone flash programming utilities (over JTAG)?
      >
      > Thanks for the space and I look forward to being part of this
      > community.
      >
      > Don
    Your message has been successfully submitted and would be delivered to recipients shortly.