Loading ...
Sorry, an error occurred while loading the content.

Re: Het can't interrupt CPU [SOLVED]

Expand Messages
  • incredibleengine
    Hi Stosh! Finally I got HET IRQ working! There were two problems: - Board s crystal is not welded on board! It s just attached with sockets. It s difficult to
    Message 1 of 5 , Mar 5, 2009
      Hi Stosh!

      Finally I got HET IRQ working!

      There were two problems:

      - Board's crystal is not welded on board! It's just attached with sockets. It's difficult to perceive that due to very short crystal pins! Due to that or crystal "quality" the oscillator was intermitent and seems to work better when scope probe was in contact with it... I just replaced 12MHz to a 6MHz crystal and oscillation problems was solved.
      Ok, I know they would done that to allow easy crystal replacement but I think it drives to many problems... I guess every crystal should be WELL welded (have had many problems with that).

      - "Low_level_flash_init" file was present at IAR Workspace Window but it wasn't been builded! It was marked as "Exclude from Build".
      All other peripherals (ADC, RTI, CAN, SPI) worked without this file because they don't use RAM memory. But HET needs proper memory intialization contained inside this file!

      Well, I'm relieved to have this working! Thanks for your attention and time trying to help me!

      About Java:
      Yes, there are many Java developers here. I like java too, it's ideas helped me to code better even for C, C++ and embedded software!


      --- In TMS470_ARM@yahoogroups.com, JohnStosh <johnstosh@...> wrote:
      > I hear Java is big in Brazil.  What smart people. I love Java.Have you checked the errata?
    Your message has been successfully submitted and would be delivered to recipients shortly.