Loading ...
Sorry, an error occurred while loading the content.

Re: [SpectrumLab] Re: Unexpected aliasing

Expand Messages
  • wolf_dl4yhf
    Hello Andrew, ... Since I use neither Windows 7 nor do I have one of the audio devices mentioned, I tested it with Windows XP and an E-MU 0202, using the
    Message 1 of 2 , Oct 31, 2010
    • 0 Attachment
      Hello Andrew,

      You wrote (in the "old" Spectrum Lab group) :


      > Still the same issue with V2.76 b8.
      >
      > I can't be completely sure about the soundcards and drivers but I do get the same effect with both a C-Media soundcard (August 2010 drivers) and the Gigabyte Relatek ALC889 HD onboard audio, so quite separate hardware.
      >
      >
      > --- In SpectrumLab@yahoogroups.com, "anding_eunding"<anding_eunding@...> wrote:
      >> Hi Wolf and friends,
      >>
      >> I'm using V2.75 b5 *BETA* with a 48kHz sampling sound card on Windows 7 64 bit. There is some strange aliasing appearing in the spectrum graph.
      >>
      >> A pure sine signal of 21.9kHz input to the soundcard results in both this signal and an alias at 22.2kHz appearing on the graph. Similar results for other signals with the 'folding' frequency being about 22.05kHz. I've double checked that I am sampling at 48kHz according to the FFT window and that the spec of the soundcard is 48kHz. I also tried a couple of spare soundcards and got similar results. In the past I've use these soundcards and earlier versions of SpectrumLab without seeing these funny alises!
      >>
      >> It seems like I'm getting an 'actual' sampling frequency of 44kHz. I wonder if this could be a problem with the Windows 7 drivers for the soundcards, but they are latest versions and supposedly ok with Windows 7 64 bit. Is it possible that somehow Spectrum Lab is putting the soundcards in 44kHz sampling mode in error - I am just thinking alound of course and don't know what the issue is.
      >>
      >> Any thoughts much appreciated.
      >>
      >> Andrew
      >>
      Since I use neither Windows 7 nor do I have one of the audio devices
      mentioned, I tested it with Windows XP and an E-MU 0202, using the
      normal windows driver (not the ASIO driver).
      Then I selected the E-MU for input, switched the audio sampling rate (in
      SL's audio settings) to 48 kSamples/second. Waterfall / Spectrum display
      zoomed out completely (to see 0..24 kHz displayed there).
      An external AF generator was connected to the E-MU's "line" input, sine
      wave, and frequency slowly swept from 2 to 40 kHz.
      Test result:
      - when increasing the AF generator frequency up to 24 kHz, the signal is
      visible on the spectrum, just as it should. No aliasing
      - Between 24 and 25 kHz, the signal 'folds back' at the Nyquist
      frequency (24 kHz) and appears in the spectrum a second time, but (at 25
      kHz) it appears 35 dB weaker than at 23 kHz, caused by the non-ideal
      anti-aliasing filter in the soundcard.

      So everything works as it should, I guess the trouble is -as so often-
      caused by the audio driver, or windows. If possible, you should try ASIO
      drivers (they are often better than the standard multimedia drivers,
      because they only do what they should, and don't try to interpolate /
      resample if the sampling rate requested by the application is not
      supported by the hardware).

      It would be nice to hear from others if their audio hardware operates
      correctly at 48 kHz (using "real" test signals slightly below 24 kHz as
      mentioned above). So I forward this response also to the new group,
      which is SpectrumLabUsers@yahoogroups.com .

      All the best,
      Wolf .
    • anding_eunding
      Thanks Wolf. I did some more digging and found that Windows 7 has a shared mode for audio devices that seems to be active by default. Although applications
      Message 2 of 2 , Oct 31, 2010
      • 0 Attachment
        Thanks Wolf. I did some more digging and found that Windows 7 has a
        "shared mode" for audio devices that seems to be active by default.
        Although applications can request "exclusive mode", if they do not then
        when in shared mode Windows will apply default settings. The default
        settings can be found under PROPERTIES/ADVANCED/DEFAULT FORMAT. The
        default format was 44kHz but I was able to change it to 48kHz, which
        solved these problems!




        --- In SpectrumLabUsers@yahoogroups.com, wolf_dl4yhf <dl4yhf@...> wrote:
        >
        > Hello Andrew,
        >
        > You wrote (in the "old" Spectrum Lab group) :
        >
        >
        > > Still the same issue with V2.76 b8.
        > >
        > > I can't be completely sure about the soundcards and drivers but I do
        get the same effect with both a C-Media soundcard (August 2010 drivers)
        and the Gigabyte Relatek ALC889 HD onboard audio, so quite separate
        hardware.
        > >
        > >
        > > --- In SpectrumLab@yahoogroups.com, "anding_eunding"anding_eunding@
        wrote:
        > >> Hi Wolf and friends,
        > >>
        > >> I'm using V2.75 b5 *BETA* with a 48kHz sampling sound card on
        Windows 7 64 bit. There is some strange aliasing appearing in the
        spectrum graph.
        > >>
        > >> A pure sine signal of 21.9kHz input to the soundcard results in
        both this signal and an alias at 22.2kHz appearing on the graph. Similar
        results for other signals with the 'folding' frequency being about
        22.05kHz. I've double checked that I am sampling at 48kHz according to
        the FFT window and that the spec of the soundcard is 48kHz. I also tried
        a couple of spare soundcards and got similar results. In the past I've
        use these soundcards and earlier versions of SpectrumLab without seeing
        these funny alises!
        > >>
        > >> It seems like I'm getting an 'actual' sampling frequency of 44kHz.
        I wonder if this could be a problem with the Windows 7 drivers for the
        soundcards, but they are latest versions and supposedly ok with Windows
        7 64 bit. Is it possible that somehow Spectrum Lab is putting the
        soundcards in 44kHz sampling mode in error - I am just thinking alound
        of course and don't know what the issue is.
        > >>
        > >> Any thoughts much appreciated.
        > >>
        > >> Andrew
        > >>
        > Since I use neither Windows 7 nor do I have one of the audio devices
        > mentioned, I tested it with Windows XP and an E-MU 0202, using the
        > normal windows driver (not the ASIO driver).
        > Then I selected the E-MU for input, switched the audio sampling rate
        (in
        > SL's audio settings) to 48 kSamples/second. Waterfall / Spectrum
        display
        > zoomed out completely (to see 0..24 kHz displayed there).
        > An external AF generator was connected to the E-MU's "line" input,
        sine
        > wave, and frequency slowly swept from 2 to 40 kHz.
        > Test result:
        > - when increasing the AF generator frequency up to 24 kHz, the signal
        is
        > visible on the spectrum, just as it should. No aliasing
        > - Between 24 and 25 kHz, the signal 'folds back' at the Nyquist
        > frequency (24 kHz) and appears in the spectrum a second time, but (at
        25
        > kHz) it appears 35 dB weaker than at 23 kHz, caused by the non-ideal
        > anti-aliasing filter in the soundcard.
        >
        > So everything works as it should, I guess the trouble is -as so often-
        > caused by the audio driver, or windows. If possible, you should try
        ASIO
        > drivers (they are often better than the standard multimedia drivers,
        > because they only do what they should, and don't try to interpolate /
        > resample if the sampling rate requested by the application is not
        > supported by the hardware).
        >
        > It would be nice to hear from others if their audio hardware operates
        > correctly at 48 kHz (using "real" test signals slightly below 24 kHz
        as
        > mentioned above). So I forward this response also to the new group,
        > which is SpectrumLabUsers@yahoogroups.com .
        >
        > All the best,
        > Wolf .
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.