Loading ...
Sorry, an error occurred while loading the content.

bug ?

Expand Messages
  • kd7ts
    Hi Wolf, I have been observing an interaction of the apply button on the Spec Lab Configuration and Display Control. The situation is using conditional
    Message 1 of 1 , Feb 10, 2013
    • 0 Attachment
      Hi Wolf,

      I have been observing an interaction of the "apply" button on the Spec Lab
      Configuration and Display Control. The situation is using conditional
      actions to control the DTR pin with COM1. This is set in the Spec Lab
      Configuration and Display Control on the TRX tab.

      Testing this gives normal action. When editing with the Spec Lab
      Configuration and Display Control box, even if nothing has changed, the
      DTR is changed to 0, if it was 1, when selecting the apply button. If it
      was 0, then nothing is changed. At the same time, the time marks are
      always removed from the waterfall display.

      This happens for trx, rts and dtr.The effect can be observed by putting
      this on a button.

      str(ptt_port.trx)or str(ptt_port.rts) or str(ptt_port.dtr)

      This has not been an issue, but I wanted to mention it in case it might be
      a clue to some other problem. The cure has been to refrain from doing that
      while in transmit. And as far as the time marks go, they are added back
      eventually as the waterfall scrolls.

      Mike KD7TS
    Your message has been successfully submitted and would be delivered to recipients shortly.