Loading ...
Sorry, an error occurred while loading the content.

Re: 2.78 B26 scroll dropouts

Expand Messages
  • mux_folder2001
    Interesting. Thanks for doing that Joe. When I did it on the laptop at work, I didn t use the INI from home. I just installed SL and set it up from memory to
    Message 1 of 31 , Feb 10, 2013
    • 0 Attachment
      Interesting. Thanks for doing that Joe. When I did it on the laptop at work, I didn't use the INI from home. I just installed SL and set it up from memory to be something like this. Now that I have posted my INI, I can grab it at work and run the real thing to be sure.

      Tony
      --- In SpectrumLabUsers@yahoogroups.com, "jfahrenh" wrote:
      >
      >
      >
      > Hi Tony-
      >
      > I substituted your .INI files for mine this morning and ran my SoftRock receiver.
      >
      > My observations:
      >
      > -There are dropouts just like yours, 11 to 12 seconds apart. Dropout duration varies in length from ~200 ms to ~500 ms.
      > -I can create ~300 ms dropouts at any time by left clicking and holding on the window's title bar. These intentionally-created dropouts do not seem to affect the above 11 to 12 second pattern.
      >
      > This seems to indicate that the issue is somewhat hardware independent- but then again you tried your setup on a laptop and it did not occur.
      >
      > It's supposed to be a somewhat rainy day here, so I'll futz around a bit today changing your settings to look more like mine and see what happens.
      >
      > -Joe F.
      >
      > --- In SpectrumLabUsers@yahoogroups.com, "mux_folder2001" wrote:
      > >
      > > I have placed the settings files in the TonyC folder in the Files area. I have played with so many settings tryng to figure this out that I hope I have everything back where it belongs. I believe that I do.
      > >
      > > I notice that the scrolling is sometimes uneven, but 2.75 is also (even more so).
      > >
      > > The CPU load I posted earlier in the thread was from Spectrumlab, not from Windows. Right now it is 55%.
      > >
      > > Tony
      > >
      > >
      > >
      > > --- In SpectrumLabUsers@yahoogroups.com, wolf_dl4yhf wrote:
      > > >
      > > > Hello Tony,
      > > >
      > > > It may be a display update issue, but due to the heavy buffering you
      > > > would notice that the spectrogram is update less frequently, and
      > > > multiple lines are painted in a single over (up to a few dozen lines per
      > > > call). Do you notice such effects, and what is the 'total CPU load'
      > > > measured by spectrum lab itself ?
      > > >
      > > > Furthermore can you put your SL configuration (settings.ini and
      > > > mconfig.ini from the SL directory) into the group's files folder, or
      > > > send them to me via direct email ? I'd like to use the same spectrum
      > > > buffer settings here for more tests.
      > > >
      > > > Cheers,
      > > > Wolf .
      > > >
      > > >
      > > > Am 09.02.2013 23:01, schrieb mux_folder2001:
      > > > >
      > > > > I just tried above normal and below normal for speclab.exe using task
      > > > > manager and it doesn't seem to affect the problem. I also mdofied the
      > > > > affinity to use a single processor and it also made no difference.
      > > > >
      > > > > I think I said this before but the audio seems to be OK. I use the FFT
      > > > > filter and mixer to listen to the beacons and I do not hear any
      > > > > dropouts. It is only on the waterfall display where the dropouts
      > > > > occur. It seems more like a display update issue than an FFT/audio
      > > > > processing issue.
      > > > >
      > > > > Tony
      > > > >
      > > > > --- In SpectrumLabUsers@yahoogroups.com
      > > > > , wolf_dl4yhf wrote:
      > > > > >
      > > > > > Hi all,
      > > > > >
      > > > > > The ugly about these thread priorities are the possible side effects.
      > > > > > For example, if the priority of the audio-processing thread (with its
      > > > > > CPU-intensive FFT calculations for the digital filters) is lifted above
      > > > > > the priority of the windows multimedia system (which serves the
      > > > > > soundcard or its 'driver software'), you will actually get more
      > > > > dropouts
      > > > > > than before (with the default thread priority).
      > > > > >
      > > > > > Anyway the suggestion is worth being tried out. There is a priority
      > > > > > setting in SL itself (under "Options .. System Settings ..
      > > > > Miscellaneous
      > > > > > .. Audio Thread Priority"). I have no idea which of the settings
      > > > > > (windows via task manager or setting the task priority from within the
      > > > > > application) will actually be effective. But as an experiment, I will
      > > > > > allow that input field to be set to *negative* values to actually lower
      > > > > > the priority of the audio thread 'below normal'. I will upload that
      > > > > > version tonight (european time).
      > > > > >
      > > > > > Cheers,
      > > > > > Wolf .
      > > > > >
      > > > > >
      > > > > > Am 09.02.2013 20:13, schrieb jfahrenh:
      > > > > > >
      > > > > > >
      > > > > > >
      > > > > > > Hi Tony-
      > > > > > >
      > > > > > > If you haven't done so already, you might try bumping SpecLab's
      > > > > > > process priority up above 'normal' via Task Manager. This could
      > > > > > > adversely affect other running processes, though.
      > > > > > >
      > > > > > > -Joe F.
      > > > > > >
      > > > > > > --- In SpectrumLabUsers@yahoogroups.com
      > > > >
      > > > > > > , "mux_folder2001" wrote:
      > > > > > > >
      > > > > > > >
      > > > > > > > I noticed that the debug window shows an FFT Calc Time on 2.78 that
      > > > > > > is a little more than double what I see for 2.75. I am seeing about
      > > > > > > 14ms average on 2.78 and 6.4ms average on 2.75. On the CPU load, I
      > > > > see
      > > > > > > 26% FFT on 2.78 and 14% FFT on 2.75. Maybe thats a clue.
      > > > > > > >
      > > > > > > > I think my only option at this point is to get a different computer
      > > > > > > or go back to 2.75. I am out of ideas for things to try. I've messed
      > > > > > > with every setting, updated my computer. Turned off drivers for
      > > > > > > non-essential hardware. No luck.
      > > > > > > >
      > > > > > > > Such is life.
      > > > > > > >
      > > > > > > > Tony
      > > > > > > >
      > > > > > > > --- In SpectrumLabUsers@yahoogroups.com
      > > > >
      > > > > > > , "mux_folder2001" wrote:
      > > > > > > > >
      > > > > > > > > Today I tried 2.78 B27 on my laptop at work, a 5 year old T7300
      > > > > > > dual core, 2Ghz machine running Windows 7 64 bit. No problems.
      > > > > > > > >
      > > > > > > > > Tony
      > > > > > > > >
      > > > > > > > > --- In SpectrumLabUsers@yahoogroups.com
      > > > >
      > > > > > > , "mux_folder2001" wrote:
      > > > > > > > > >
      > > > > > > > > >
      > > > > > > > > > Hi Wolf,
      > > > > > > > > >
      > > > > > > > > > Well, I have tried two more sound cards, including the internal
      > > > > > > one and they all do this. I have been playing with every setting I
      > > > > can
      > > > > > > find and nothing seems to fix the problem. I found that increasing
      > > > > the
      > > > > > > "audio chunk size" by a small amount and then clicking 'apply", the
      > > > > > > problem would go away for about a minute and the start again with a
      > > > > > > dropout about every 12 seconds.
      > > > > > > > > >
      > > > > > > > > > It also seems that the problem takes a minute or two to develop
      > > > > > > after starting SpectrumLab. It is like a buffer is filling up and
      > > > > then
      > > > > > > the problems start.
      > > > > > > > > >
      > > > > > > > > > Tony
      > > > > > > > > >
      > > > > > > > >
      > > > > > > >
      > > > > > >
      > > > > > >
      > > > > >
      > > > >
      > > > >
      > > >
      > >
      >
    • mux_folder2001
      Wolf, B27 with a chunk size of 100ms seems to work better for me than this new version. With the new one, if I switch on recording, the dropouts come back.
      Message 31 of 31 , Feb 10, 2013
      • 0 Attachment
        Wolf,

        B27 with a chunk size of 100ms seems to work better for me than this new version.

        With the new one, if I switch on recording, the dropouts come back. Also, with recording on or off I get occasional clicking in the speaker. B27 with 100ms chunks seems to work well.

        Tony

        --- In SpectrumLabUsers@yahoogroups.com, wolf_dl4yhf wrote:
        >
        > Ok Tony, nice to hear that. I have uploaded a new "beta" ( .. i.e. most
        > likely with a couple of bugs which are yet to be discovered .. ) to the
        > website. This is V2.78 b29 at the moment, downloadable from
        >
        > http://www.qsl.net/dl4yhf/spectra1.html#download
        >
        > (beware ... subject to frequent changes, because I use these 'betas'
        > myself to install the program on different test PCs)
        >
        > Besides the modified audio buffer sizes (and soundcard I/O), I tried to
        > make the background colour of the 'programmable buttons' on the left
        > side of the main window also 'programmable' through the interpreter.
        > Details at
        >
        > http://www.qsl.net/dl4yhf/speclab/controls.htm#programmable_buttons
        >
        >
        > Cheers,
        > Wolf .
        >
        > Am 10.02.2013 19:39, schrieb mux_folder2001:
        > >
        > >
        > > Dropping the chunk size to 100ms seems to do it. Thanks!
        > >
        > > I could have sworn I tried this and had a bad result but perhaps
        > > something else was amiss at the time. Thanks again for the help.
        > >
        > > Tony
        > >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.