Loading ...
Sorry, an error occurred while loading the content.

Re: Problems with periodic recording in latest version (2.78 B17)

Expand Messages
  • mux_folder2001
    I should have mentioned that I am using Scheduled Actions to do this. Tony
    Message 1 of 7 , Oct 31, 2012
    • 0 Attachment
      I should have mentioned that I am using "Scheduled Actions" to do this.

      Tony

      --- In SpectrumLabUsers@yahoogroups.com, "mux_folder2001" <canthony15@...> wrote:
      >
      > I upgraded to the latest version and now my recordings don't work correctly. I use SL to record an SDR output for my NDB hobby. The recordings are set up as a series of 59 minute captures. The command sequence is:
      >
      > 07:00 wave.record("filename")
      > 07:59 wave.stop
      > 08:00 repeat above two commands
      >
      > This is done for each hour through the night. This has worked flawlessly for two years. Now it doesn't work any more. The first file is captured but all of the rest have zero length.
      >
      > I installed "over the top" of my old installation and I had to make a tweak to the settings.ini file because the frequency offset in the [DISPLAY] section was 360000 from my old setup. This made the frequency scale behavior incorrect with the new version so I set the offset back to zero. Perhaps some other setting is not compatible??
      >
      > Tony
      >
    • mux_folder2001
      Fixed the problem by reinstalling in a fresh directory and then copying over my user script. Tony
      Message 2 of 7 , Oct 31, 2012
      • 0 Attachment
        Fixed the problem by reinstalling in a fresh directory and then copying over my user script.

        Tony

        --- In SpectrumLabUsers@yahoogroups.com, "mux_folder2001" <canthony15@...> wrote:
        >
        > I upgraded to the latest version and now my recordings don't work correctly. I use SL to record an SDR output for my NDB hobby. The recordings are set up as a series of 59 minute captures. The command sequence is:
        >
        > 07:00 wave.record("filename")
        > 07:59 wave.stop
        > 08:00 repeat above two commands
        >
        > This is done for each hour through the night. This has worked flawlessly for two years. Now it doesn't work any more. The first file is captured but all of the rest have zero length.
        >
        > I installed "over the top" of my old installation and I had to make a tweak to the settings.ini file because the frequency offset in the [DISPLAY] section was 360000 from my old setup. This made the frequency scale behavior incorrect with the new version so I set the offset back to zero. Perhaps some other setting is not compatible??
        >
        > Tony
        >
      • mux_folder2001
        I take that back. It is still broken. It rand for 2.5 hours and then stopped recording and all of the rest of the night the files are all zero length.
        Message 3 of 7 , Nov 1, 2012
        • 0 Attachment
          I take that back. It is still broken. It rand for 2.5 hours and then stopped recording and all of the rest of the night the files are all zero length. Something is not right with this release. I am going to try and restore the previous version from a backup.

          Tony

          --- In SpectrumLabUsers@yahoogroups.com, "mux_folder2001" <canthony15@...> wrote:
          >
          >
          > Fixed the problem by reinstalling in a fresh directory and then copying over my user script.
          >
          > Tony
          >
          > --- In SpectrumLabUsers@yahoogroups.com, "mux_folder2001" <canthony15@> wrote:
          > >
          > > I upgraded to the latest version and now my recordings don't work correctly. I use SL to record an SDR output for my NDB hobby. The recordings are set up as a series of 59 minute captures. The command sequence is:
          > >
          > > 07:00 wave.record("filename")
          > > 07:59 wave.stop
          > > 08:00 repeat above two commands
          > >
          > > This is done for each hour through the night. This has worked flawlessly for two years. Now it doesn't work any more. The first file is captured but all of the rest have zero length.
          > >
          > > I installed "over the top" of my old installation and I had to make a tweak to the settings.ini file because the frequency offset in the [DISPLAY] section was 360000 from my old setup. This made the frequency scale behavior incorrect with the new version so I set the offset back to zero. Perhaps some other setting is not compatible??
          > >
          > > Tony
          > >
          >
        • wolf_dl4yhf
          Hi Tony, Thanks for the details - I will investigate this as soon as time permits; maybe tomorrow. All the best, Wolf .
          Message 4 of 7 , Nov 2, 2012
          • 0 Attachment
            Hi Tony,

            Thanks for the details - I will investigate this as soon as time
            permits; maybe tomorrow.

            All the best,
            Wolf .
          • mux_folder2001
            Thanks Wolf, I though I had posted this already but I don t see it... The test using 2.75 b09 was successful last night. So I believe that the problem is
            Message 5 of 7 , Nov 2, 2012
            • 0 Attachment
              Thanks Wolf,

              I though I had posted this already but I don't see it...

              The test using 2.75 b09 was successful last night. So I believe that the problem is related to the new version.

              Tony

              --- In SpectrumLabUsers@yahoogroups.com, wolf_dl4yhf <dl4yhf@...> wrote:
              >
              > Hi Tony,
              >
              > Thanks for the details - I will investigate this as soon as time
              > permits; maybe tomorrow.
              >
              > All the best,
              > Wolf .
              >
            • wolf_dl4yhf
              Hi Tony, I didn t find a reason why the recording should stop at zero bytes length (here, none of the versions behaves like that) but I noticed a problem
              Message 6 of 7 , Nov 4, 2012
              • 0 Attachment
                Hi Tony,

                I didn't find a reason why the recording should stop at zero bytes length (here, none of the versions behaves like that) but I noticed a problem related with the 'Scheduled Actions':

                The table was always using UTC, whereas the user interface adds some adjustable offset to the UTC (for the display). Quite confusing. In the latest *beta* (V2.78 b19, now available) I have changed this, see

                http://www.qsl.net/dl4yhf/spectra1.html#download


                But again, nothing changed in the wave-file-saving process yet. It may help to run Spectrum Lab in debug-mode, as explained in another thread in this group.

                All the best,
                  Wolf .

                Am 03.11.2012 04:22, schrieb mux_folder2001:
                 

                Thanks Wolf,

                I though I had posted this already but I don't see it...

                The test using 2.75 b09 was successful last night. So I believe that the problem is related to the new version.

                Tony

                --- In SpectrumLabUsers@yahoogroups.com, wolf_dl4yhf <dl4yhf@...> wrote:
                >
                > Hi Tony,
                >
                > Thanks for the details - I will investigate this as soon as time
                > permits; maybe tomorrow.
                >
                > All the best,
                > Wolf .
                >


              Your message has been successfully submitted and would be delivered to recipients shortly.