Loading ...
Sorry, an error occurred while loading the content.

Re: [SherlineCNC] Sherline Spindle control via SmoothStepper

Expand Messages
  • Sonny Mounicou
    I don t think so. I m using mine with a usb smooth stepper as well. I m not familiar with that DC-08 board, so I don t know if it could be introducing
    Message 1 of 11 , Sep 18, 2013
    • 0 Attachment
      I don't think so.  I'm using mine with a usb smooth stepper as well.  I'm not familiar with that DC-08 board, so I don't know if it could be introducing issues.  Have you checked to see the 0-10V coming into the G540?  When you tell it to turn on the spindle, what do you see on the 3rd line?  Essentially all that it does is emulate the POT.  You should be able to observe the change.  If you can't, you need to chase the wires to figure out where it is falling flat.

      Be careful with the wires.  They are hot and they sting.  Its also easy to kill the KBIC controller if you aren't careful.

      --Sonny

      On Sep 18, 2013, at 10:31 PM, <kaerickson@...> wrote:

       

      Sonny,

       

      Is there something else I need to do for the USB Smooth Stepper?  I've done everything else you pointed out. 



      --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

      Yes, but you don't need the DC-08 board to do it.  You remove the pot from the sherline control and run the 3 wires over to the VFD port on the G540.  A schematic is on the soigeneris website at:  http://www.soigeneris.com/Document/Gecko/Using_the%20Gecko_G540_VFD_Output.pdf .  I use it on my sherline lathe and it works well.  If you add one of Jeff's inductance sensors, it will pick up the speed to and enable a feedback loop.  

      --Sonny

      On Sep 18, 2013, at 8:31 PM, <kaerickson@...> wrote:

      I'm now trying to get it to function in the auto mode (manual mode works).  I use a SmoothStepper board inplace of a parallel port.  I need some help in configuring the system as now I'm not able to get the spindle to turn but the DRO is showing the desired speed.  I've verified that the three wires from the DC-08 are correctly connected to the G540 board (pins 7, 8 & 9) and the 540BVFD.xml file is installed.



    • Ron Ginger
      ... Have you set the PMW spindle control entries on the smoothstepper config screen? You find it under the plugins config menu ron ginger
      Message 2 of 11 , Sep 19, 2013
      • 0 Attachment
        > Posted by:kaerickson@... kerickson
        > Date: Wed Sep 18, 2013 8:31 pm ((PDT))
        >
        > Is there something else I need to do for the USB Smooth Stepper?
        > I've done everything else you pointed out.

        Have you set the PMW spindle control entries on the smoothstepper config
        screen? You find it under the plugins config menu

        ron ginger
      • Ken Condal
        I have mine working with the G540 and Smoothstepper. There are a number of software settings that need to be made for it to work. Have you read this article?
        Message 3 of 11 , Sep 19, 2013
        • 0 Attachment

          I have mine working with the G540 and Smoothstepper. There are a number of software settings that need to be made for it to work.

           

          Have you read this article? http://www.soigeneris.com/Document/Gecko/Using_the%20Gecko_G540_VFD_Output.pdf

           

          Ken

           

           


          From: SherlineCNC@yahoogroups.com [mailto: SherlineCNC@yahoogroups.com ] On Behalf Of Sonny Mounicou
          Sent: Wednesday, September 18, 2013 11:48 PM
          To: SherlineCNC@yahoogroups.com
          Subject: Re: [SherlineCNC] Sherline Spindle control via SmoothStepper

           

           

          I don't think so.  I'm using mine with a usb smooth stepper as well.  I'm not familiar with that DC-08 board, so I don't know if it could be introducing issues.  Have you checked to see the 0-10V coming into the G540?  When you tell it to turn on the spindle, what do you see on the 3rd line?  Essentially all that it does is emulate the POT.  You should be able to observe the change.  If you can't, you need to chase the wires to figure out where it is falling flat.

           

          Be careful with the wires.  They are hot and they sting.  Its also easy to kill the KBIC controller if you aren't careful.

           

          --Sonny

           

          On Sep 18, 2013, at 10:31 PM, <kaerickson@...> wrote:



        • kerickson
          Ron, Ken, Thanks for the link to the Soigeneris PDF. I think I have everything set per the doc but I m running my 2000 mill off of a new 14 laptop and the
          Message 4 of 11 , Sep 19, 2013
          • 0 Attachment

            Ron, Ken,

             

            Thanks for the link to the Soigeneris PDF.  I think I have everything set per the doc but I'm running my 2000 mill off of a new 14" laptop and the Smooth Stepper setup page is cut off at the bottom and there are no scroll bars for the page plus page 7 of the doc is very blurry making it hard to read.  So I plan to move my mill into my home office this weekend and attempt to get things working on my workstation system. 



            --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

            I have mine working with the G540 and Smoothstepper. There are a number of software settings that need to be made for it to work.

             

            Have you read this article? http://www.soigeneris.com/Document/Gecko/Using_the%20Gecko_G540_VFD_Output.pdf

             

            Ken

             

             

            From: SherlineCNC@yahoogroups.com [mailto: SherlineCNC@yahoogroups.com ] On Behalf Of Sonny Mounicou
            Sent: Wednesday, September 18, 2013 11:48 PM
            To: SherlineCNC@yahoogroups.com
            Subject: Re: [SherlineCNC] Sherline Spindle control via SmoothStepper

             

             

            I don't think so.  I'm using mine with a usb smooth stepper as well.  I'm not familiar with that DC-08 board, so I don't know if it could be introducing issues.  Have you checked to see the 0-10V coming into the G540?  When you tell it to turn on the spindle, what do you see on the 3rd line?  Essentially all that it does is emulate the POT.  You should be able to observe the change.  If you can't, you need to chase the wires to figure out where it is falling flat.

             

            Be careful with the wires.  They are hot and they sting.  Its also easy to kill the KBIC controller if you aren't careful.

             

            --Sonny

             

            On Sep 18, 2013, at 10:31 PM, <kaerickson@...> wrote:



          • kerickson
            I verified that I had the 3 wires for the spindle speed control wired correctly. New status display: PWM Bumped to minimum setting. What does that mean? Do I
            Message 5 of 11 , Sep 20, 2013
            • 0 Attachment

              I verified that I had the 3 wires for the spindle speed control wired correctly.

               

              New status display: PWM Bumped to minimum setting.

               

              What does that mean?  Do I have something configured wrong?

               

               



              --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

              Ron, Ken,

               

              Thanks for the link to the Soigeneris PDF.  I think I have everything set per the doc but I'm running my 2000 mill off of a new 14" laptop and the Smooth Stepper setup page is cut off at the bottom and there are no scroll bars for the page plus page 7 of the doc is very blurry making it hard to read.  So I plan to move my mill into my home office this weekend and attempt to get things working on my workstation system. 



              --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

              I have mine working with the G540 and Smoothstepper. There are a number of software settings that need to be made for it to work.

               

              Have you read this article? http://www.soigeneris.com/Document/Gecko/Using_the%20Gecko_G540_VFD_Output.pdf

               

              Ken

               

               

              From: SherlineCNC@yahoogroups.com [mailto: SherlineCNC@yahoogroups.com ] On Behalf Of Sonny Mounicou
              Sent: Wednesday, September 18, 2013 11:48 PM
              To: SherlineCNC@yahoogroups.com
              Subject: Re: [SherlineCNC] Sherline Spindle control via SmoothStepper

               

               

              I don't think so.  I'm using mine with a usb smooth stepper as well.  I'm not familiar with that DC-08 board, so I don't know if it could be introducing issues.  Have you checked to see the 0-10V coming into the G540?  When you tell it to turn on the spindle, what do you see on the 3rd line?  Essentially all that it does is emulate the POT.  You should be able to observe the change.  If you can't, you need to chase the wires to figure out where it is falling flat.

               

              Be careful with the wires.  They are hot and they sting.  Its also easy to kill the KBIC controller if you aren't careful.

               

              --Sonny

               

              On Sep 18, 2013, at 10:31 PM, <kaerickson@...> wrote:



            • kerickson
              I ve managed to get the spindle speed controller function working correctly. The only question I have now is there a way to adjust/correct for speed variances?
              Message 6 of 11 , Sep 22, 2013
              • 0 Attachment

                I've managed to get the spindle speed controller function working correctly.  The only question I have now is there a way to adjust/correct  for speed variances?

                 

                For S1000 I'm reading 850 rpm

                For S2000 I'm reading 1830 rpm

                For S2800 I'm reading 2600 rpm

                 

                I'm not concerned about the small difference in speed but I was wondering if there is a way to adjust Mach-3 to "fix" it?

                --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

                I verified that I had the 3 wires for the spindle speed control wired correctly.

                 

                New status display: PWM Bumped to minimum setting.

                 

                What does that mean?  Do I have something configured wrong?

                 

                 



                --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

                Ron, Ken,

                 

                Thanks for the link to the Soigeneris PDF.  I think I have everything set per the doc but I'm running my 2000 mill off of a new 14" laptop and the Smooth Stepper setup page is cut off at the bottom and there are no scroll bars for the page plus page 7 of the doc is very blurry making it hard to read.  So I plan to move my mill into my home office this weekend and attempt to get things working on my workstation system. 



                --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

                I have mine working with the G540 and Smoothstepper. There are a number of software settings that need to be made for it to work.

                 

                Have you read this article? http://www.soigeneris.com/Document/Gecko/Using_the%20Gecko_G540_VFD_Output.pdf

                 

                Ken

                 

                 

                From: SherlineCNC@yahoogroups.com [mailto: SherlineCNC@yahoogroups.com ] On Behalf Of Sonny Mounicou
                Sent: Wednesday, September 18, 2013 11:48 PM
                To: SherlineCNC@yahoogroups.com
                Subject: Re: [SherlineCNC] Sherline Spindle control via SmoothStepper

                 

                 

                I don't think so.  I'm using mine with a usb smooth stepper as well.  I'm not familiar with that DC-08 board, so I don't know if it could be introducing issues.  Have you checked to see the 0-10V coming into the G540?  When you tell it to turn on the spindle, what do you see on the 3rd line?  Essentially all that it does is emulate the POT.  You should be able to observe the change.  If you can't, you need to chase the wires to figure out where it is falling flat.

                 

                Be careful with the wires.  They are hot and they sting.  Its also easy to kill the KBIC controller if you aren't careful.

                 

                --Sonny

                 

                On Sep 18, 2013, at 10:31 PM, <kaerickson@...> wrote:



              • Sonny Mounicou
                You can adjust the PWM percent to fine tune speed so that it matches. A good starting point is in the soigeneris pdf. The closer you get the better, but in
                Message 7 of 11 , Sep 22, 2013
                • 0 Attachment
                  You can adjust the PWM percent to fine tune speed so that it matches.  A good starting point is in the soigeneris pdf.  The closer you get the better, but in my experience the numbers are less consistent under 500 rpm than they are above it.

                  I believe you can also enable the closed loop function so that it monitors and adjusts appropriately to counter the load. I have not done it myself as it hasn't mattered all that much.

                  --Sonny


                  On Sun, Sep 22, 2013 at 11:00 AM, <kaerickson@...> wrote:
                   

                  I've managed to get the spindle speed controller function working correctly.  The only question I have now is there a way to adjust/correct  for speed variances?

                   

                  For S1000 I'm reading 850 rpm

                  For S2000 I'm reading 1830 rpm

                  For S2800 I'm reading 2600 rpm

                   

                  I'm not concerned about the small difference in speed but I was wondering if there is a way to adjust Mach-3 to "fix" it?

                  --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

                  I verified that I had the 3 wires for the spindle speed control wired correctly.

                   

                  New status display: PWM Bumped to minimum setting.

                   

                  What does that mean?  Do I have something configured wrong?

                   

                   



                  --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

                  Ron, Ken,

                   

                  Thanks for the link to the Soigeneris PDF.  I think I have everything set per the doc but I'm running my 2000 mill off of a new 14" laptop and the Smooth Stepper setup page is cut off at the bottom and there are no scroll bars for the page plus page 7 of the doc is very blurry making it hard to read.  So I plan to move my mill into my home office this weekend and attempt to get things working on my workstation system. 



                  --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

                  I have mine working with the G540 and Smoothstepper. There are a number of software settings that need to be made for it to work.

                   

                  Have you read this article? http://www.soigeneris.com/Document/Gecko/Using_the%20Gecko_G540_VFD_Output.pdf

                   

                  Ken

                   

                   

                  From: SherlineCNC@yahoogroups.com [mailto: SherlineCNC@yahoogroups.com ] On Behalf Of Sonny Mounicou
                  Sent: Wednesday, September 18, 2013 11:48 PM
                  To: SherlineCNC@yahoogroups.com
                  Subject: Re: [SherlineCNC] Sherline Spindle control via SmoothStepper

                   

                   

                  I don't think so.  I'm using mine with a usb smooth stepper as well.  I'm not familiar with that DC-08 board, so I don't know if it could be introducing issues.  Have you checked to see the 0-10V coming into the G540?  When you tell it to turn on the spindle, what do you see on the 3rd line?  Essentially all that it does is emulate the POT.  You should be able to observe the change.  If you can't, you need to chase the wires to figure out where it is falling flat.

                   

                  Be careful with the wires.  They are hot and they sting.  Its also easy to kill the KBIC controller if you aren't careful.

                   

                  --Sonny

                   

                  On Sep 18, 2013, at 10:31 PM, <kaerickson@...> wrote:




                • David Lorenz
                  Assuming you have an index sensor tied to mach, try running the spindle calibration routine in mach. I had so many problems configuring PWM that I finally had
                  Message 8 of 11 , Oct 30, 2013
                  • 0 Attachment

                    Assuming you have an index sensor tied to mach, try running the spindle calibration routine in mach. I had so many problems configuring PWM that I finally had a bright idea… I redirected my A axis step pin to the PWM control pin in ports and pins, then jogging the A axis (my fastest axis) manually I got a nice smooth ramp up to speed. Aha 1st clue. PWM just wants a stream of reliable pulses so… resetting Axis to normal I went back to spindle control and set it to Step\Dir. Note: you should route the dir pin to a false output such as port 2 pin 16 (if you have no port 2), and wahlah! It started working great, no more lag and stupid messages, although like you the speed was incorrect. After running spindle calibration it was quite good, running it again made it even better! Note: if you have set a minimum speed IE: minimum 400 maximum 3000, change it to minimum 0 before running the calibration, then when you are done and happy change it back. You want it to learn the full power curve! I only takes about 6 minutes to run this and it works amazing. My spindle speed is VERY close using this method now on both my Sherline 4100 lathe and my 2000 mill. Good Luck!

                     

                    From: SherlineCNC@yahoogroups.com [mailto:SherlineCNC@yahoogroups.com] On Behalf Of Sonny Mounicou
                    Sent: Sunday, September 22, 2013 12:15
                    To: SherlineCNC@yahoogroups.com
                    Subject: Re: RE: RE: RE: [SherlineCNC] Sherline Spindle control via SmoothStepper

                     

                     

                    You can adjust the PWM percent to fine tune speed so that it matches.  A good starting point is in the soigeneris pdf.  The closer you get the better, but in my experience the numbers are less consistent under 500 rpm than they are above it.

                     

                    I believe you can also enable the closed loop function so that it monitors and adjusts appropriately to counter the load. I have not done it myself as it hasn't mattered all that much.


                    --Sonny

                     

                    On Sun, Sep 22, 2013 at 11:00 AM, <kaerickson@...> wrote:

                     

                    I've managed to get the spindle speed controller function working correctly.  The only question I have now is there a way to adjust/correct  for speed variances?

                     

                    For S1000 I'm reading 850 rpm

                    For S2000 I'm reading 1830 rpm

                    For S2800 I'm reading 2600 rpm

                     

                    I'm not concerned about the small difference in speed but I was wondering if there is a way to adjust Mach-3 to "fix" it?

                    --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

                    I verified that I had the 3 wires for the spindle speed control wired correctly.

                     

                    New status display: PWM Bumped to minimum setting.

                     

                    What does that mean?  Do I have something configured wrong?

                     

                     

                     

                    --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

                    Ron, Ken,

                     

                    Thanks for the link to the Soigeneris PDF.  I think I have everything set per the doc but I'm running my 2000 mill off of a new 14" laptop and the Smooth Stepper setup page is cut off at the bottom and there are no scroll bars for the page plus page 7 of the doc is very blurry making it hard to read.  So I plan to move my mill into my home office this weekend and attempt to get things working on my workstation system. 

                     

                    --- In SherlineCNC@yahoogroups.com, <sherlinecnc@yahoogroups.com> wrote:

                    I have mine working with the G540 and Smoothstepper. There are a number of software settings that need to be made for it to work.

                     

                    Have you read this article? http://www.soigeneris.com/Document/Gecko/Using_the%20Gecko_G540_VFD_Output.pdf

                     

                    Ken

                     

                     

                    From: SherlineCNC@yahoogroups.com [mailto: SherlineCNC@yahoogroups.com ] On Behalf Of Sonny Mounicou
                    Sent: Wednesday, September 18, 2013 11:48 PM
                    To: SherlineCNC@yahoogroups.com
                    Subject: Re: [SherlineCNC] Sherline Spindle control via SmoothStepper

                     

                     

                    I don't think so.  I'm using mine with a usb smooth stepper as well.  I'm not familiar with that DC-08 board, so I don't know if it could be introducing issues.  Have you checked to see the 0-10V coming into the G540?  When you tell it to turn on the spindle, what do you see on the 3rd line?  Essentially all that it does is emulate the POT.  You should be able to observe the change.  If you can't, you need to chase the wires to figure out where it is falling flat.

                     

                    Be careful with the wires.  They are hot and they sting.  Its also easy to kill the KBIC controller if you aren't careful.

                     

                    --Sonny

                     

                    On Sep 18, 2013, at 10:31 PM, <kaerickson@...> wrote:

                     

                     

                  Your message has been successfully submitted and would be delivered to recipients shortly.