Loading ...
Sorry, an error occurred while loading the content.

help! arrow problems!

Expand Messages
  • Aiden
    ( a little long) I am haveing a bit of a problem, and could use some help. A few months ago i bought some ceder shafts from 3rivers archery, with the intent of
    Message 1 of 3 , Oct 5, 2007
    • 0 Attachment
      ( a little long)

      I am haveing a bit of a problem, and could use some help. A few
      months ago i bought some ceder shafts from 3rivers archery, with the
      intent of building more arrows for target shooting.
      With one thing or another,(2 floods, moveing in and out of the house
      2 times), i just recently got back to this project. I am haveing a
      problem with the arrows takeing the white primerbase coat paint for
      cresting. I began as normal, sanded the shafts with 150 grit
      sandpaper, moved up to 250 resanded, used some steal wool to check
      for any bad spots in the wood, use a tack cloth to clean any
      lingering dust or bit of steel wool, dipped them in fletch lac
      clear. I let the arrows dry for a day, had to take care of some
      stuff at the house, and began to prepare for a demo that weekend.
      The next night I began dipping the arrows in fletch lac white to
      prep for cresting. At this time i noticed that of the 2 dozen shats
      only 2-3 where takeing paint correctly. The rest all streak, or have
      spots that the paint will not take on the shafts at all no matter
      how many times i dip them, I am at a total lose on what to do.
      I have tried resanding, useing thinner to make sure there was
      nothing on the shafts, re dipped in blue clear in case there was
      something wrong with the regular clear, and i am still haveing the
      same streaks and bare spots. HELP!!! anyone have any advice at
      all ??
    • Carolus
      I take it that the problem is only happening with the white Fletch-Lac? In that case I suspect that the Fletch-Lac has become contaminated. Carolus ... -- No
      Message 2 of 3 , Oct 5, 2007
      • 0 Attachment
        I take it that the problem is only happening with the white
        Fletch-Lac? In that case I suspect that the Fletch-Lac has become
        contaminated.
        Carolus
        At 09:06 PM 10/5/2007, you wrote:

        >( a little long)
        >
        >I am haveing a bit of a problem, and could use some help. A few
        >months ago i bought some ceder shafts from 3rivers archery, with the
        >intent of building more arrows for target shooting.
        >With one thing or another,(2 floods, moveing in and out of the house
        >2 times), i just recently got back to this project. I am haveing a
        >problem with the arrows takeing the white primerbase coat paint for
        >cresting. I began as normal, sanded the shafts with 150 grit
        >sandpaper, moved up to 250 resanded, used some steal wool to check
        >for any bad spots in the wood, use a tack cloth to clean any
        >lingering dust or bit of steel wool, dipped them in fletch lac
        >clear. I let the arrows dry for a day, had to take care of some
        >stuff at the house, and began to prepare for a demo that weekend.
        >The next night I began dipping the arrows in fletch lac white to
        >prep for cresting. At this time i noticed that of the 2 dozen shats
        >only 2-3 where takeing paint correctly. The rest all streak, or have
        >spots that the paint will not take on the shafts at all no matter
        >how many times i dip them, I am at a total lose on what to do.
        >I have tried resanding, useing thinner to make sure there was
        >nothing on the shafts, re dipped in blue clear in case there was
        >something wrong with the regular clear, and i am still haveing the
        >same streaks and bare spots. HELP!!! anyone have any advice at
        >all ??
        >
        >
        >
        >No virus found in this incoming message.
        >Checked by AVG Free Edition.
        >Version: 7.5.488 / Virus Database: 269.14.1/1050 - Release Date:
        >10/4/2007 5:03 PM


        --
        No virus found in this outgoing message.
        Checked by AVG Free Edition.
        Version: 7.5.488 / Virus Database: 269.14.1/1050 - Release Date: 10/4/2007 5:03 PM
      • Robert Maddison
        I am no expert on arrow making, but I am on wood finishing,been my job for 25 years.Adhesion problems are always some kind of contamination issue.if is just
        Message 3 of 3 , Oct 6, 2007
        • 0 Attachment
          I am no expert on arrow making, but I am on wood finishing,been my job for
          25 years.Adhesion problems are always some kind of contamination issue.if is
          just the fletch lac thats not taking overcoating then its probably gotten
          contaminated,and a fresh supply should solve the problem.If its the wood
          itself thats rejecting then there is something in the wood
          itself.youmentioned floods,and I assume major clean up
          afterwards.Did you use cleaners like armor all or spray polishes during the
          clean up.If you did some may have come in contact with the shafts,either
          mist in the air or on hands if you handled the shafts, it may even be on the
          sandpaper.Most of these cleaners contain silicone, and the only thing that
          sticks to silicone is more silicone,and it penetrates bare wood so deeply it
          cant be removed.If this is what happened then I am afraid the shafts are
          ruined.If its the fletch lac thats the culprit,make sure you remove all
          trace of it from the shafte before you redip them ot oit will transfer the
          contaminant to the fresh supply.I wish you luck in this.
          Llywyllyn


          [Non-text portions of this message have been removed]
        Your message has been successfully submitted and would be delivered to recipients shortly.