Loading ...
Sorry, an error occurred while loading the content.

24083Re: Fletching problem

Expand Messages
  • arturdubh
    Jan 11, 2008
    • 0 Attachment
      It sounds as though you let them sit too long before fletching. Since
      you say that you have tried roughing them up a bit with steel
      wool/sandpaper, I have to ask: What grit of steel wool/sandpaper?
      Sometimes if the grit is too rough, the glue won't work as well as it
      should. I know, it seems wierd, but there it is...

      I used to have a problem with Fletch-Tite glue not "sticking" (the
      glue would "melt" the finish and take well over 40 minutes to dry; it
      was almost as though the glue wasn't even working); it turned out to
      be the glue wasn't fully compatible with the finish I was using. I
      switched to Duco cement and started leaving the arrow in the
      fletching jig for at least 20 minutes before moving on to the next
      fletch. If the finished shafts have been sitting for more than a
      week, I give them a quick wipe-down with #0000 steel wool (I use it
      between finish coats and before fletching anyway, for the ultra-
      smooth feel of the finished shaft) and a clean cloth (to remove the
      powdered finish left by the steel wool), to remove any surface
      deposits which might inhibit glue adhesion, and I leave the arrow in
      the jig for an extra few minutes (just to make sure the glue
      actually "sticks"). Some of it's over-kill, sure, but at least it
      works.

      You may need to remove the old finish and then re-finish the shafts,
      but I think that would be a "last resort" kind of thing. I hope it
      doesn't come to that.

      --Artúr


      --- In SCA-Archery@yahoogroups.com, Kay Newsom <arrow_wolf1415@...>
      wrote:
      >
      > They have some Minwax stain/sealer. I dipped them a couple of
      years ago. I did 2 dozen shafts at the time. The first dozen I put
      fletches on right away with no problem. This second batch has been
      laying around awhile. Now, nothing will stick to them.
      >
      > Longbow-the Original Weapon of Mass Destruction
      >
      >
      >
      > ----- Original Message ----
      > From: Richard Yeager <chuymonstre@...>
      > To: SCA-Archery@yahoogroups.com
      > Sent: Friday, January 11, 2008 8:04:44 PM
      > Subject: Re: [SCA-Archery] Fletching problem
      >
      > What sort of sealer do you have on your shafts?
      >
      > arrow_wolf1415 <arrow_wolf1415@ yahoo.com> wrote: I'm having a
      serious problem with glueing on fletches. Nothing seems
      > to want to stick. I've tried Fletchtite, Duco Cement and super
      glue.
      > It just seems to evaporate without sticking. Anyone have any
      > suggestions?
      >
      > Kateren
      > Ansteorra
      >
      >
      >
      >
      >
      > ------------ --------- --------- ---
      > Looking for last minute shopping deals? Find them fast with Yahoo!
      Search.
      >
      > [Non-text portions of this message have been removed]
      >
      >
      >
      >
      >
      >
      ______________________________________________________________________
      ______________
      > Never miss a thing. Make Yahoo your home page.
      > http://www.yahoo.com/r/hs
      >
      > [Non-text portions of this message have been removed]
      >
    • Show all 16 messages in this topic