Loading ...
Sorry, an error occurred while loading the content.

problema cu afisarea la un HC-91 (2)

Expand Messages
  • Nicolae Popa
    Revin cu intrebarea de mai jos. Mie unul mi-a intrat mesajul (trimis de mine) direct in folderul de spam... Il retransmit... Raspunsul meu a fost: Banuiesc ca
    Message 1 of 8 , Feb 18, 2011
    • 0 Attachment
      Revin cu intrebarea de mai jos.
      Mie unul mi-a intrat mesajul (trimis de mine) direct in folderul de spam...
      Il retransmit...

      Raspunsul meu a fost:

      Banuiesc ca prin "iesirea composite" se intelege iesirea pe mufa cu 13 pini (7 pe un rand, 6 pe celalalt rand).

      Nu am la televizor o astfel de intrare. Am si un cablu cu mufe identice de tipul celor cu 13 pini, dar nu am unde sa il introduc in TV. Nu am la nici un TV astfel de intrare.

      Eu l-am conectat printr-un cablu care are intr-un capat mufa de cablu coaxial (pentru TV analogic, de tipul obisnuit), iar celalalt capat intra in HC pe intrarea din stanga de tot (mufa tata arata ca una de S-video - ca un jack scurt, cu un singur canal si masa pe exterior).

      Nu stiu sa explic mai bine, nu stiu denumirile diverselor tipuri de conectori.

      --- On Thu, 2/17/11, Liviu Grama <liviu9@...> wrote:


      From: Liviu Grama <liviu9@...>
      Subject: Re: [RomanianHomeComputer] problema cu afisarea la un HC 91
      To: RomanianHomeComputer@yahoogroups.com
      Date: Thursday, February 17, 2011, 2:16 PM


      Pe iesirea composite cum se vede?incearca (daca nu ai facut asta deja) sa cuplezi iesirea videocomplex la intrarea AV a tv-ului si spoune-ne cum se vede;

      --- On Thu, 2/17/11, Nicolae Popa <nickxyzt@...> wrote:


      From: Nicolae Popa <nickxyzt@...>
      Subject: [RomanianHomeComputer] problema cu afisarea la un HC 91
      To: RomanianHomeComputer@yahoogroups.com
      Date: Thursday, February 17, 2011, 1:29 PM


      Salut,

      Tocmai am primit un HC 91. Nefolosit probabil de cand a fost fabricat :)

      Functioneaza bine, raspunde la comenzi, doar ca afiseaza culoarea initiala la PAPER ca fiind violet (si nu alb, cum ar trebui). De asemenea, din textul initial (HC91 - ICE FELIX) se vede doar cuvantul FELIX, dar in partea din stanga jos.

      Afisarea se face in BORDER, nu in PAPER. Am incercat un PRINT PI si il afiseaza langa coltul din dreapta sus al PAPER.

      Pe alte frecvente TV (unde insa se vede prost), se vede corect (alb/alb), doar ca nu reusesc sa stabilizez imaginea (adica este foarte foarte proasta calitativ).

      Ma poate ajuta cineva cu descoperirea cauzei acestei probleme de afisare?

      Nu l-am desfacut sa schimb vreun condensator... inca.
      Si sunt nerabdator sa mai joc un R-Type pe hardware original :)

      Orice sugestie este binevenita.
    • Liviu Grama
      Mai numara odata ,mufa aia are 9 pini (DB9) si pe unul din pini se regaseste semnalul videocomplex (vezi ca s-a mai discutat pe forum si exista si notatiile
      Message 2 of 8 , Feb 19, 2011
      • 0 Attachment
        Mai numara odata ,mufa aia are 9 pini (DB9) si pe unul din pini se regaseste semnalul videocomplex (vezi ca s-a mai discutat pe forum si exista si notatiile din scheme);practic poti folosi o mufa COM1 de PC 586 sau mai vechi si un cablu coaxial cu mufa RCA in celalalt capat; mai precis cumperi un cablu video cu mufe RCA (cele galbene) de la tarabele chinezilor ,tai un capat  si pui in acel capat mufa DB9 semnal + masa si ai rezolvat problema; partea cu afisarea textului pe ecran inca nu am inteles-o ,aici e posibil sa ai probleme cu circuitul video;faptul ca pe alt canal se vede corect ,dar cu imagine proasta nu te ajuta cu nimic deoarece treaba e normala : prinzi pe TV o armonica slaba a modulatorului si TV-ul afiseaza alb-negru;frecventa corecta e aia unde imaginea e curata si stabila chiar daca ai fondul violet sau cum ziceai.

        Stima
        Liviu YO7HLQ
         

        --- On Fri, 2/18/11, Nicolae Popa <nickxyzt@...> wrote:

        From: Nicolae Popa <nickxyzt@...>
        Subject: [RomanianHomeComputer] problema cu afisarea la un HC-91 (2)
        To: romanianhomecomputer@yahoogroups.com
        Date: Friday, February 18, 2011, 9:55 PM

         

        Revin cu intrebarea de mai jos.
        Mie unul mi-a intrat mesajul (trimis de mine) direct in folderul de spam...
        Il retransmit...

        Raspunsul meu a fost:

        Banuiesc ca prin "iesirea composite" se intelege iesirea pe mufa cu 13 pini (7 pe un rand, 6 pe celalalt rand).

        Nu am la televizor o astfel de intrare. Am si un cablu cu mufe identice de tipul celor cu 13 pini, dar nu am unde sa il introduc in TV. Nu am la nici un TV astfel de intrare.

        Eu l-am conectat printr-un cablu care are intr-un capat mufa de cablu coaxial (pentru TV analogic, de tipul obisnuit), iar celalalt capat intra in HC pe intrarea din stanga de tot (mufa tata arata ca una de S-video - ca un jack scurt, cu un singur canal si masa pe exterior).

        Nu stiu sa explic mai bine, nu stiu denumirile diverselor tipuri de conectori.

        --- On Thu, 2/17/11, Liviu Grama <liviu9@...> wrote:

        From: Liviu Grama <liviu9@...>
        Subject: Re: [RomanianHomeComputer] problema cu afisarea la un HC 91
        To: RomanianHomeComputer@yahoogroups.com
        Date: Thursday, February 17, 2011, 2:16 PM

        Pe iesirea composite cum se vede?incearca (daca nu ai facut asta deja) sa cuplezi iesirea videocomplex la intrarea AV a tv-ului si spoune-ne cum se vede;

        --- On Thu, 2/17/11, Nicolae Popa <nickxyzt@...> wrote:

        From: Nicolae Popa <nickxyzt@...>
        Subject: [RomanianHomeComputer] problema cu afisarea la un HC 91
        To: RomanianHomeComputer@yahoogroups.com
        Date: Thursday, February 17, 2011, 1:29 PM

        Salut,

        Tocmai am primit un HC 91. Nefolosit probabil de cand a fost fabricat :)

        Functioneaza bine, raspunde la comenzi, doar ca afiseaza culoarea initiala la PAPER ca fiind violet (si nu alb, cum ar trebui). De asemenea, din textul initial (HC91 - ICE FELIX) se vede doar cuvantul FELIX, dar in partea din stanga jos.

        Afisarea se face in BORDER, nu in PAPER. Am incercat un PRINT PI si il afiseaza langa coltul din dreapta sus al PAPER.

        Pe alte frecvente TV (unde insa se vede prost), se vede corect (alb/alb), doar ca nu reusesc sa stabilizez imaginea (adica este foarte foarte proasta calitativ).

        Ma poate ajuta cineva cu descoperirea cauzei acestei probleme de afisare?

        Nu l-am desfacut sa schimb vreun condensator... inca.
        Si sunt nerabdator sa mai joc un R-Type pe hardware original :)

        Orice sugestie este binevenita.


      • Nicolae Popa
        Multumesc de raspuns. Am conectat HC-ul la televizor dupa instructiunile din mailul precedent. Se vede la fel ca si conectarea prin cablul coaxial. Este clar,
        Message 3 of 8 , Feb 19, 2011
        • 1 Attachment
        • 11 KB
        Multumesc de raspuns.
        Am conectat HC-ul la televizor dupa instructiunile din mailul precedent. Se vede la fel ca si conectarea prin cablul coaxial.
        Este clar, problema nu este de cablu sau de conectori.

        In timp ce scriam acest mail, s-a intamplat minunea... si-a revenit singur. Banuiesc ca la un restart isi va "reveni" la starea anormala, asa ca voi continua cu descrierea problemei (cand apare).

        Am atasat o imagine, cam cum este acum initial, dupa resetare.
        Dupa cum se vede, Border este violet, iar Paper este negru. (Trebuia sa fie alb/alb dupa stiinta mea).
        Patratelele albe au dimensiunea 4x4 pixeli (sunt identice cu cele obtinute in modul grafic).

        Pot sa schimb culorile pentru BORDER, dar nu sunt cele reale, astfel:
        0 - negru 1 - albastru 2 - rosu 3 - violet 4 - negru 5 - albastru (din nou) 6 - rosu (din nou) 7 - violet (din nou)

        Daca dau de exemplu INK 6, se schimba culoarea pentru PAPER(!) in 6.

        Codul sursa pe care il scriu apare in partea de sus, unde am marcat cu rosu (deci in afara zonei PAPER). De fapt, primele 5 caractere sunt invizibile in zona PAPER, restul aflandu-se unde este marcat cu rosu.
        (Pentru 10 PRINT x, vad in zona rosie doar INT a)
        De asemenea, mesajele de tipul 10 OK 0:1, apar in partea de jos, unde am marcat cu albastru (tot fara primele 5 caractere)...

        Sper ca am descris suficient de bine sindromul, astfel incat daca s-a lovit cineva de problema aceasta in trecut, sau are sa-mi faca vreo sugestie (sau diagnostic) sa o poata face.

        Toate bune si multumiri,
        NP

        --- On Sat, 2/19/11, Liviu Grama <liviu9@...> wrote:

        From: Liviu Grama <liviu9@...>
        Subject: Re: [RomanianHomeComputer] problema cu afisarea la un HC-91 (2)
        To: RomanianHomeComputer@yahoogroups.com
        Date: Saturday, February 19, 2011, 8:47 PM

         

        Mai numara odata ,mufa aia are 9 pini (DB9) si pe unul din pini se regaseste semnalul videocomplex (vezi ca s-a mai discutat pe forum si exista si notatiile din scheme);practic poti folosi o mufa COM1 de PC 586 sau mai vechi si un cablu coaxial cu mufa RCA in celalalt capat; mai precis cumperi un cablu video cu mufe RCA (cele galbene) de la tarabele chinezilor ,tai un capat  si pui in acel capat mufa DB9 semnal + masa si ai rezolvat problema; partea cu afisarea textului pe ecran inca nu am inteles-o ,aici e posibil sa ai probleme cu circuitul video;faptul ca pe alt canal se vede corect ,dar cu imagine proasta nu te ajuta cu nimic deoarece treaba e normala : prinzi pe TV o armonica slaba a modulatorului si TV-ul afiseaza alb-negru;frecventa corecta e aia unde imaginea e curata si stabila chiar daca ai fondul violet sau cum ziceai.

        Stima
        Liviu YO7HLQ
         

        --- On Fri, 2/18/11, Nicolae Popa <nickxyzt@...> wrote:

        From: Nicolae Popa <nickxyzt@...>
        Subject: [RomanianHomeComputer] problema cu afisarea la un HC-91 (2)
        To: romanianhomecomputer@yahoogroups.com
        Date: Friday, February 18, 2011, 9:55 PM

         

        Revin cu intrebarea de mai jos.
        Mie unul mi-a intrat mesajul (trimis de mine) direct in folderul de spam...
        Il retransmit...

        Raspunsul meu a fost:

        Banuiesc ca prin "iesirea composite" se intelege iesirea pe mufa cu 13 pini (7 pe un rand, 6 pe celalalt rand).

        Nu am la televizor o astfel de intrare. Am si un cablu cu mufe identice de tipul celor cu 13 pini, dar nu am unde sa il introduc in TV. Nu am la nici un TV astfel de intrare.

        Eu l-am conectat printr-un cablu care are intr-un capat mufa de cablu coaxial (pentru TV analogic, de tipul obisnuit), iar celalalt capat intra in HC pe intrarea din stanga de tot (mufa tata arata ca una de S-video - ca un jack scurt, cu un singur canal si masa pe exterior).

        Nu stiu sa explic mai bine, nu stiu denumirile diverselor tipuri de conectori.

        --- On Thu, 2/17/11, Liviu Grama <liviu9@...> wrote:

        From: Liviu Grama <liviu9@...>
        Subject: Re: [RomanianHomeComputer] problema cu afisarea la un HC 91
        To: RomanianHomeComputer@yahoogroups.com
        Date: Thursday, February 17, 2011, 2:16 PM

        Pe iesirea composite cum se vede?incearca (daca nu ai facut asta deja) sa cuplezi iesirea videocomplex la intrarea AV a tv-ului si spoune-ne cum se vede;

        --- On Thu, 2/17/11, Nicolae Popa <nickxyzt@...> wrote:

        From: Nicolae Popa <nickxyzt@...>
        Subject: [RomanianHomeComputer] problema cu afisarea la un HC 91
        To: RomanianHomeComputer@yahoogroups.com
        Date: Thursday, February 17, 2011, 1:29 PM

        Salut,

        Tocmai am primit un HC 91. Nefolosit probabil de cand a fost fabricat :)

        Functioneaza bine, raspunde la comenzi, doar ca afiseaza culoarea initiala la PAPER ca fiind violet (si nu alb, cum ar trebui). De asemenea, din textul initial (HC91 - ICE FELIX) se vede doar cuvantul FELIX, dar in partea din stanga jos.

        Afisarea se face in BORDER, nu in PAPER. Am incercat un PRINT PI si il afiseaza langa coltul din dreapta sus al PAPER.

        Pe alte frecvente TV (unde insa se vede prost), se vede corect (alb/alb), doar ca nu reusesc sa stabilizez imaginea (adica este foarte foarte proasta calitativ).

        Ma poate ajuta cineva cu descoperirea cauzei acestei probleme de afisare?

        Nu l-am desfacut sa schimb vreun condensator... inca.
        Si sunt nerabdator sa mai joc un R-Type pe hardware original :)

        Orice sugestie este binevenita.



      • Liviu G
        Dupa cum arata imaginea ,primul gand m-a dus la un ROM modificat (patratele alea sunt dispuse uniform ca si cum ar fi fost programate sa fie acolo) ,insa daca
        Message 4 of 8 , Feb 20, 2011
        • 0 Attachment
          Dupa cum arata imaginea ,primul gand m-a dus la un ROM modificat (patratele alea sunt dispuse uniform ca si cum ar fi fost programate sa fie acolo) ,insa daca spui ca si-a revenit singur......

          Sunt curios cum ai capturat imaginea deoarece calitatea e foarte buna;sau e prelucrata digital? ai mai taiat din ea sus si jos? (mi se pare in format 16:9 nu 4:3 cum e normal);

          Ai incercat sa incarci un program grafic facut deja? de ex caseta demo HC91;Pentru incarcare din PC merge excelent TAPIR;de asemenea ai putea incerca un ROM extern cu OPUS (ecranul de start OPUS e un bun test grafic);

          Eu am intalnit urmatoarele situatii cu ROM-uri BASIC sau OPUS:
          - EPROM de HC91 (vechi) care afiseaza bine pe COBRA si pe HC90-91
          - EPROM de COBRA (vechi)care afiseaza foarte prost pe COBRA ,dar excelent pe HC

          In momentul de fata experimentez cu EEPROM Winbond W27E512-12 (am recuperat 2 cip-uri de pe diverse placi electronice) si se comporta perfect si pe COBRA si pe HC cu orice imagine ROM compatibila.
        • Nicolae Popa
          Imaginea este facuta de mine in Paint... cu fidelitate foarte mare. Nu este captura de ecran. N-am incercat sa incarc nimic, pentru ca nu am nici o mufa in
          Message 5 of 8 , Feb 20, 2011
          • 0 Attachment
            Imaginea este facuta de mine in Paint... cu fidelitate foarte mare. Nu este captura de ecran.
            N-am incercat sa incarc nimic, pentru ca nu am nici o mufa in casa, si este week-end, nu am de unde sa cumpar la mine in oras. Maine rezolv. Am dat insa diverse comenzi PRINT, am schimbat culorile, totul merge fara probleme acum.

            Mie (ca si neelectronist) imi suna a problema de condensator electrolitic, care in cele din urma s-a incarcat. Dar e doar o parere.

            Intr-adevar, pe acest calculator ROM-ul este schimbat (scrie pe el ceva cu creionul, neinteligibil insa).

            Mai are insa o problema importanta: nu merge blocul de taste 6,7,8,9,0. De asemenea, nu merg niste combinatii (SS+M, SS+N, SS+B). L-am desfacut si am verificat, contactele merg bine, dar pe fiecare contact este cate o dioda (sunt 8 diode in total). Le-am masurat, si una are tensiunea de strapungere 0.6V, iar alta are 1V (restul au 0.33V).

            Banuiesc ca sunt defecte aceste doua diode (corespunzand fiecare cate unui bloc de taste care nu functioneaza corect). Prin comparatie, am masurat aceste diode si pe un HC-90 (care le are dispuse insa altfel), si acelea toate 8 sunt indentice, de 0.67V.

            Sper sa ajung candva sa experimentez si eu cu alte cip-uri... Nu am scule ca sa le pot interschimba.

            Pe HC-90 am ROM de Sinclair (din 1982), iar chipsetul este produs in Irlanda. Asa l-a schimbat firma de reparatii dupa ce s-a ars. A mers o perioada, dar acum, din pacate, se deschide, dar nu se intampla nimic daca apas vreo tasta. Merge insa butonul de reset. Poate imi da cineva vreo sugestie.

            Multumesc.

            NP

            --- On Sun, 2/20/11, Liviu G <liviu9@...> wrote:

            From: Liviu G <liviu9@...>
            Subject: [RomanianHomeComputer] Re: problema cu afisarea la un HC-91 (2)
            To: RomanianHomeComputer@yahoogroups.com
            Date: Sunday, February 20, 2011, 11:20 AM

             

            Dupa cum arata imaginea ,primul gand m-a dus la un ROM modificat (patratele alea sunt dispuse uniform ca si cum ar fi fost programate sa fie acolo) ,insa daca spui ca si-a revenit singur......

            Sunt curios cum ai capturat imaginea deoarece calitatea e foarte buna;sau e prelucrata digital? ai mai taiat din ea sus si jos? (mi se pare in format 16:9 nu 4:3 cum e normal);

            Ai incercat sa incarci un program grafic facut deja? de ex caseta demo HC91;Pentru incarcare din PC merge excelent TAPIR;de asemenea ai putea incerca un ROM extern cu OPUS (ecranul de start OPUS e un bun test grafic);

            Eu am intalnit urmatoarele situatii cu ROM-uri BASIC sau OPUS:
            - EPROM de HC91 (vechi) care afiseaza bine pe COBRA si pe HC90-91
            - EPROM de COBRA (vechi)care afiseaza foarte prost pe COBRA ,dar excelent pe HC

            In momentul de fata experimentez cu EEPROM Winbond W27E512-12 (am recuperat 2 cip-uri de pe diverse placi electronice) si se comporta perfect si pe COBRA si pe HC cu orice imagine ROM compatibila.


          • Liviu Grama
            Condensator electrolitic putin probabil intrucat este unul singur care ar putea afecta sistemul prea mult si acela este cu tantal ;restul sunt pe alimentare;
            Message 6 of 8 , Feb 20, 2011
            • 0 Attachment
              Condensator electrolitic putin probabil intrucat este unul singur care ar putea afecta sistemul prea mult si acela este cu tantal ;restul sunt pe alimentare; mai degraba vreun TTL "imbatranit" ,poate chiar EPROM-ul - am unul care o ia razna rau de tot pe COBRA cand il apuca insa merge perfect pe HC; sau poate un contact imperfect - am intalnit multe
              Apropo verifica cele 2 sarme strap de pe spatele placii sa nu atinga in alta parte decat trebuie si cealalta sarma (daca exista) care ajunge la extensie.
              Ar mai fii rezistentele - sunt destul de ciudate ca toate s-au distrus daca am incercat sa le dezlipesc de pe placa ,am pornit un HC cu 50 de taste dupa ce am miscat o rezistenta.

              - ROM-ul poate fi "mazgalit" din fabrica (am si eu cateva notate cu pixul)
              - Diodele sigur sunt defecte - am intalnit si eu cateva prin placile mele (mai ales daca sunt din alea transparente ca de sticla); am inlocuit cu succes cu 1n4148

              Ca scule pt experimentat eproame am o suflanta cu aer cald pentru dezlipit integrate si un programator AD-MEM03; materiale: socluri recuperate de pe diverse placi si eproame asemenea; ma tin de ceva vreme sa-mi fac un stergator UV (de cumparat e la vreo 400 RON ) ,tb sa gasesc un bec Hg de 150W (am drosel).

              P.S. Din ce oras esti ?Eu stau aproape de Rm. Valcea

              --- On Sun, 2/20/11, Nicolae Popa <nickxyzt@...> wrote:

              From: Nicolae Popa <nickxyzt@...>
              Subject: Re: [RomanianHomeComputer] Re: problema cu afisarea la un HC-91 (2)1
              To: RomanianHomeComputer@yahoogroups.com
              Date: Sunday, February 20, 2011, 1:26 PM

               

              Imaginea este facuta de mine in Paint... cu fidelitate foarte mare. Nu este captura de ecran.
              N-am incercat sa incarc nimic, pentru ca nu am nici o mufa in casa, si este week-end, nu am de unde sa cumpar la mine in oras. Maine rezolv. Am dat insa diverse comenzi PRINT, am schimbat culorile, totul merge fara probleme acum.

              Mie (ca si neelectronist) imi suna a problema de condensator electrolitic, care in cele din urma s-a incarcat. Dar e doar o parere.

              Intr-adevar, pe acest calculator ROM-ul este schimbat (scrie pe el ceva cu creionul, neinteligibil insa).

              Mai are insa o problema importanta: nu merge blocul de taste 6,7,8,9,0. De asemenea, nu merg niste combinatii (SS+M, SS+N, SS+B). L-am desfacut si am verificat, contactele merg bine, dar pe fiecare contact este cate o dioda (sunt 8 diode in total). Le-am masurat, si una are tensiunea de strapungere 0.6V, iar alta are 1V (restul au 0.33V).

              Banuiesc ca sunt defecte aceste doua diode (corespunzand fiecare cate unui bloc de taste care nu functioneaza corect). Prin comparatie, am masurat aceste diode si pe un HC-90 (care le are dispuse insa altfel), si acelea toate 8 sunt indentice, de 0.67V.

              Sper sa ajung candva sa experimentez si eu cu alte cip-uri... Nu am scule ca sa le pot interschimba.

              Pe HC-90 am ROM de Sinclair (din 1982), iar chipsetul este produs in Irlanda. Asa l-a schimbat firma de reparatii dupa ce s-a ars. A mers o perioada, dar acum, din pacate, se deschide, dar nu se intampla nimic daca apas vreo tasta. Merge insa butonul de reset. Poate imi da cineva vreo sugestie.

              Multumesc.

              NP

              --- On Sun, 2/20/11, Liviu G <liviu9@...> wrote:

              From: Liviu G <liviu9@...>
              Subject: [RomanianHomeComputer] Re: problema cu afisarea la un HC-91 (2)
              To: RomanianHomeComputer@yahoogroups.com
              Date: Sunday, February 20, 2011, 11:20 AM

               

              Dupa cum arata imaginea ,primul gand m-a dus la un ROM modificat (patratele alea sunt dispuse uniform ca si cum ar fi fost programate sa fie acolo) ,insa daca spui ca si-a revenit singur......

              Sunt curios cum ai capturat imaginea deoarece calitatea e foarte buna;sau e prelucrata digital? ai mai taiat din ea sus si jos? (mi se pare in format 16:9 nu 4:3 cum e normal);

              Ai incercat sa incarci un program grafic facut deja? de ex caseta demo HC91;Pentru incarcare din PC merge excelent TAPIR;de asemenea ai putea incerca un ROM extern cu OPUS (ecranul de start OPUS e un bun test grafic);

              Eu am intalnit urmatoarele situatii cu ROM-uri BASIC sau OPUS:
              - EPROM de HC91 (vechi) care afiseaza bine pe COBRA si pe HC90-91
              - EPROM de COBRA (vechi)care afiseaza foarte prost pe COBRA ,dar excelent pe HC

              In momentul de fata experimentez cu EEPROM Winbond W27E512-12 (am recuperat 2 cip-uri de pe diverse placi electronice) si se comporta perfect si pe COBRA si pe HC cu orice imagine ROM compatibila.



            • Nicolae Popa
              Multumesc de raspuns, voi verifica maine firele strap. Primul pas va fi sa schimb cele doua diode defecte. Las la final rezistentele, pentru ca sunt multe si
              Message 7 of 8 , Feb 20, 2011
              • 0 Attachment
                Multumesc de raspuns, voi verifica maine firele strap.
                Primul pas va fi sa schimb cele doua diode defecte.

                Las la final rezistentele, pentru ca sunt multe si dureaza sa le desprind si sa le prind la loc pe toate.

                Cat despre IC-uri sterse cu UV si apoi programate de mine, ramane doar un vis indepartat, nu imi permit si nu am nici spatiu in casa (am si copii mici, si nu pot lasa nimic pe mese pentru ca exista riscul inghitirii). Ca sa nu mai spun ca nu am nici cunostintele necesare. :)

                Eu stau in Slobozia. La Valcea nu am fost niciodata, desi am auzit lucruri bune despre frumusetea orasului.

                --- On Sun, 2/20/11, Liviu Grama <liviu9@...> wrote:

                From: Liviu Grama <liviu9@...>
                Subject: Re: [RomanianHomeComputer] Re: problema cu afisarea la un HC-91 (2)1
                To: RomanianHomeComputer@yahoogroups.com
                Date: Sunday, February 20, 2011, 5:41 PM

                 

                Condensator electrolitic putin probabil intrucat este unul singur care ar putea afecta sistemul prea mult si acela este cu tantal ;restul sunt pe alimentare; mai degraba vreun TTL "imbatranit" ,poate chiar EPROM-ul - am unul care o ia razna rau de tot pe COBRA cand il apuca insa merge perfect pe HC; sau poate un contact imperfect - am intalnit multe
                Apropo verifica cele 2 sarme strap de pe spatele placii sa nu atinga in alta parte decat trebuie si cealalta sarma (daca exista) care ajunge la extensie.
                Ar mai fii rezistentele - sunt destul de ciudate ca toate s-au distrus daca am incercat sa le dezlipesc de pe placa ,am pornit un HC cu 50 de taste dupa ce am miscat o rezistenta.

                - ROM-ul poate fi "mazgalit" din fabrica (am si eu cateva notate cu pixul)
                - Diodele sigur sunt defecte - am intalnit si eu cateva prin placile mele (mai ales daca sunt din alea transparente ca de sticla); am inlocuit cu succes cu 1n4148

                Ca scule pt experimentat eproame am o suflanta cu aer cald pentru dezlipit integrate si un programator AD-MEM03; materiale: socluri recuperate de pe diverse placi si eproame asemenea; ma tin de ceva vreme sa-mi fac un stergator UV (de cumparat e la vreo 400 RON ) ,tb sa gasesc un bec Hg de 150W (am drosel).

                P.S. Din ce oras esti ?Eu stau aproape de Rm. Valcea

                --- On Sun, 2/20/11, Nicolae Popa <nickxyzt@...> wrote:

                From: Nicolae Popa <nickxyzt@...>
                Subject: Re: [RomanianHomeComputer] Re: problema cu afisarea la un HC-91 (2)1
                To: RomanianHomeComputer@yahoogroups.com
                Date: Sunday, February 20, 2011, 1:26 PM

                 

                Imaginea este facuta de mine in Paint... cu fidelitate foarte mare. Nu este captura de ecran.
                N-am incercat sa incarc nimic, pentru ca nu am nici o mufa in casa, si este week-end, nu am de unde sa cumpar la mine in oras. Maine rezolv. Am dat insa diverse comenzi PRINT, am schimbat culorile, totul merge fara probleme acum.

                Mie (ca si neelectronist) imi suna a problema de condensator electrolitic, care in cele din urma s-a incarcat. Dar e doar o parere.

                Intr-adevar, pe acest calculator ROM-ul este schimbat (scrie pe el ceva cu creionul, neinteligibil insa).

                Mai are insa o problema importanta: nu merge blocul de taste 6,7,8,9,0. De asemenea, nu merg niste combinatii (SS+M, SS+N, SS+B). L-am desfacut si am verificat, contactele merg bine, dar pe fiecare contact este cate o dioda (sunt 8 diode in total). Le-am masurat, si una are tensiunea de strapungere 0.6V, iar alta are 1V (restul au 0.33V).

                Banuiesc ca sunt defecte aceste doua diode (corespunzand fiecare cate unui bloc de taste care nu functioneaza corect). Prin comparatie, am masurat aceste diode si pe un HC-90 (care le are dispuse insa altfel), si acelea toate 8 sunt indentice, de 0.67V.

                Sper sa ajung candva sa experimentez si eu cu alte cip-uri... Nu am scule ca sa le pot interschimba.

                Pe HC-90 am ROM de Sinclair (din 1982), iar chipsetul este produs in Irlanda. Asa l-a schimbat firma de reparatii dupa ce s-a ars. A mers o perioada, dar acum, din pacate, se deschide, dar nu se intampla nimic daca apas vreo tasta. Merge insa butonul de reset. Poate imi da cineva vreo sugestie.

                Multumesc.

                NP

                --- On Sun, 2/20/11, Liviu G <liviu9@...> wrote:

                From: Liviu G <liviu9@...>
                Subject: [RomanianHomeComputer] Re: problema cu afisarea la un HC-91 (2)
                To: RomanianHomeComputer@yahoogroups.com
                Date: Sunday, February 20, 2011, 11:20 AM

                 

                Dupa cum arata imaginea ,primul gand m-a dus la un ROM modificat (patratele alea sunt dispuse uniform ca si cum ar fi fost programate sa fie acolo) ,insa daca spui ca si-a revenit singur......

                Sunt curios cum ai capturat imaginea deoarece calitatea e foarte buna;sau e prelucrata digital? ai mai taiat din ea sus si jos? (mi se pare in format 16:9 nu 4:3 cum e normal);

                Ai incercat sa incarci un program grafic facut deja? de ex caseta demo HC91;Pentru incarcare din PC merge excelent TAPIR;de asemenea ai putea incerca un ROM extern cu OPUS (ecranul de start OPUS e un bun test grafic);

                Eu am intalnit urmatoarele situatii cu ROM-uri BASIC sau OPUS:
                - EPROM de HC91 (vechi) care afiseaza bine pe COBRA si pe HC90-91
                - EPROM de COBRA (vechi)care afiseaza foarte prost pe COBRA ,dar excelent pe HC

                In momentul de fata experimentez cu EEPROM Winbond W27E512-12 (am recuperat 2 cip-uri de pe diverse placi electronice) si se comporta perfect si pe COBRA si pe HC cu orice imagine ROM compatibila.




              • Liviu Grama
                Nu incerca sa dezlipesti rezistentele pentru ca se vor sparge - sunt foarte firave (cum spuneam nu am reusit sa recuperez nici macar una - e vorba de alea
                Message 8 of 8 , Feb 21, 2011
                • 0 Attachment
                  Nu incerca sa dezlipesti rezistentele pentru ca se vor sparge - sunt foarte firave (cum spuneam nu am reusit sa recuperez nici macar una - e vorba de alea colorate albastru deschis cu 5 benzi pentru marcarea valorii);in plus exista si riscul sa se exfolieze trasee de cablaj; doar incearca sa apesi putin cu degetul pe ele si urmaresti daca se schimba semnificativ imaginea pe TV; se exclud parazitii datorati potentialului electrostatic al mainii; eu am obiceiul de a flamba placile in functionare pentru a depista existenta lipiturilor reci apasand cu degetul pe componente pana se arcuieste placa 1-2 mm.

                  Pentru inlocuirea diodelor e bine ca inainte sa le tai piciorusele cu un cleste si apoi sa extragi resturile cu o penseta (ar fi buna o pompa de fludor) si letcon de 25W.
                  --- On Sun, 2/20/11, Nicolae Popa <nickxyzt@...> wrote:

                  From: Nicolae Popa <nickxyzt@...>
                  Subject: Re: [RomanianHomeComputer] Re: problema cu afisarea la un HC-91 (2)1
                  To: RomanianHomeComputer@yahoogroups.com
                  Date: Sunday, February 20, 2011, 10:56 PM

                   

                  Multumesc de raspuns, voi verifica maine firele strap.
                  Primul pas va fi sa schimb cele doua diode defecte.

                  Las la final rezistentele, pentru ca sunt multe si dureaza sa le desprind si sa le prind la loc pe toate.

                  Cat despre IC-uri sterse cu UV si apoi programate de mine, ramane doar un vis indepartat, nu imi permit si nu am nici spatiu in casa (am si copii mici, si nu pot lasa nimic pe mese pentru ca exista riscul inghitirii). Ca sa nu mai spun ca nu am nici cunostintele necesare. :)

                  Eu stau in Slobozia. La Valcea nu am fost niciodata, desi am auzit lucruri bune despre frumusetea orasului.

                  --- On Sun, 2/20/11, Liviu Grama <liviu9@...> wrote:

                  From: Liviu Grama <liviu9@...>
                  Subject: Re: [RomanianHomeComputer] Re: problema cu afisarea la un HC-91 (2)1
                  To: RomanianHomeComputer@yahoogroups.com
                  Date: Sunday, February 20, 2011, 5:41 PM

                   

                  Condensator electrolitic putin probabil intrucat este unul singur care ar putea afecta sistemul prea mult si acela este cu tantal ;restul sunt pe alimentare; mai degraba vreun TTL "imbatranit" ,poate chiar EPROM-ul - am unul care o ia razna rau de tot pe COBRA cand il apuca insa merge perfect pe HC; sau poate un contact imperfect - am intalnit multe
                  Apropo verifica cele 2 sarme strap de pe spatele placii sa nu atinga in alta parte decat trebuie si cealalta sarma (daca exista) care ajunge la extensie.
                  Ar mai fii rezistentele - sunt destul de ciudate ca toate s-au distrus daca am incercat sa le dezlipesc de pe placa ,am pornit un HC cu 50 de taste dupa ce am miscat o rezistenta.

                  - ROM-ul poate fi "mazgalit" din fabrica (am si eu cateva notate cu pixul)
                  - Diodele sigur sunt defecte - am intalnit si eu cateva prin placile mele (mai ales daca sunt din alea transparente ca de sticla); am inlocuit cu succes cu 1n4148

                  Ca scule pt experimentat eproame am o suflanta cu aer cald pentru dezlipit integrate si un programator AD-MEM03; materiale: socluri recuperate de pe diverse placi si eproame asemenea; ma tin de ceva vreme sa-mi fac un stergator UV (de cumparat e la vreo 400 RON ) ,tb sa gasesc un bec Hg de 150W (am drosel).

                  P.S. Din ce oras esti ?Eu stau aproape de Rm. Valcea

                  --- On Sun, 2/20/11, Nicolae Popa <nickxyzt@...> wrote:

                  From: Nicolae Popa <nickxyzt@...>
                  Subject: Re: [RomanianHomeComputer] Re: problema cu afisarea la un HC-91 (2)1
                  To: RomanianHomeComputer@yahoogroups.com
                  Date: Sunday, February 20, 2011, 1:26 PM

                   

                  Imaginea este facuta de mine in Paint... cu fidelitate foarte mare. Nu este captura de ecran.
                  N-am incercat sa incarc nimic, pentru ca nu am nici o mufa in casa, si este week-end, nu am de unde sa cumpar la mine in oras. Maine rezolv. Am dat insa diverse comenzi PRINT, am schimbat culorile, totul merge fara probleme acum.

                  Mie (ca si neelectronist) imi suna a problema de condensator electrolitic, care in cele din urma s-a incarcat. Dar e doar o parere.

                  Intr-adevar, pe acest calculator ROM-ul este schimbat (scrie pe el ceva cu creionul, neinteligibil insa).

                  Mai are insa o problema importanta: nu merge blocul de taste 6,7,8,9,0. De asemenea, nu merg niste combinatii (SS+M, SS+N, SS+B). L-am desfacut si am verificat, contactele merg bine, dar pe fiecare contact este cate o dioda (sunt 8 diode in total). Le-am masurat, si una are tensiunea de strapungere 0.6V, iar alta are 1V (restul au 0.33V).

                  Banuiesc ca sunt defecte aceste doua diode (corespunzand fiecare cate unui bloc de taste care nu functioneaza corect). Prin comparatie, am masurat aceste diode si pe un HC-90 (care le are dispuse insa altfel), si acelea toate 8 sunt indentice, de 0.67V.

                  Sper sa ajung candva sa experimentez si eu cu alte cip-uri... Nu am scule ca sa le pot interschimba.

                  Pe HC-90 am ROM de Sinclair (din 1982), iar chipsetul este produs in Irlanda. Asa l-a schimbat firma de reparatii dupa ce s-a ars. A mers o perioada, dar acum, din pacate, se deschide, dar nu se intampla nimic daca apas vreo tasta. Merge insa butonul de reset. Poate imi da cineva vreo sugestie.

                  Multumesc.

                  NP

                  --- On Sun, 2/20/11, Liviu G <liviu9@...> wrote:

                  From: Liviu G <liviu9@...>
                  Subject: [RomanianHomeComputer] Re: problema cu afisarea la un HC-91 (2)
                  To: RomanianHomeComputer@yahoogroups.com
                  Date: Sunday, February 20, 2011, 11:20 AM

                   

                  Dupa cum arata imaginea ,primul gand m-a dus la un ROM modificat (patratele alea sunt dispuse uniform ca si cum ar fi fost programate sa fie acolo) ,insa daca spui ca si-a revenit singur......

                  Sunt curios cum ai capturat imaginea deoarece calitatea e foarte buna;sau e prelucrata digital? ai mai taiat din ea sus si jos? (mi se pare in format 16:9 nu 4:3 cum e normal);

                  Ai incercat sa incarci un program grafic facut deja? de ex caseta demo HC91;Pentru incarcare din PC merge excelent TAPIR;de asemenea ai putea incerca un ROM extern cu OPUS (ecranul de start OPUS e un bun test grafic);

                  Eu am intalnit urmatoarele situatii cu ROM-uri BASIC sau OPUS:
                  - EPROM de HC91 (vechi) care afiseaza bine pe COBRA si pe HC90-91
                  - EPROM de COBRA (vechi)care afiseaza foarte prost pe COBRA ,dar excelent pe HC

                  In momentul de fata experimentez cu EEPROM Winbond W27E512-12 (am recuperat 2 cip-uri de pe diverse placi electronice) si se comporta perfect si pe COBRA si pe HC cu orice imagine ROM compatibila.





                Your message has been successfully submitted and would be delivered to recipients shortly.