Loading ...
Sorry, an error occurred while loading the content.

16088Re: [RoboMower] Possible battery issue? - RL1000

Expand Messages
  • David Christopher
    Jun 14, 2009
    • 0 Attachment
      Hey guys -- an update on my issue -- I purchased a pair of EB20-12's from
      Digikey, installed them, and I'm basically having the same problem! After I
      installed the new batteries in the pack, I let it charge for well over 24
      hours -- and it still showed a moving "charging icon". I decided to let it
      mow anyway, and it cam back in a bit less than 2 1/2 hours. But now it's
      always "actively charging" according to the icon/image -- even after 24, 48,
      72 hours. I just tried to let it go mow, and I noticed when it left the
      dock the battery icon showed an almost empty image...and it basically cut
      the perimeter than needed to come back due to lack of charge.

      So it seems perhaps the batteries were not the issue -- it is possibly the
      power pack? A loose connection on the dock? I'd hate to spend even more
      money now on a new power pack only to find that's not the issue either.

      Any ideas?

      Thanks
      Dave (NJ)

      On Sun, May 31, 2009 at 10:07 AM, dmc_123_dmc
      <david.christopher@...>wrote:

      >
      >
      > Hi all, hoping to get some advice...
      >
      > All of a sudden my Robomower RL1000 will not reach a full charge. The
      > little battery icon (while docked) is always moving (indicating still
      > charging), even after 48 hours or longer of no use (docked). If I send the
      > robot out to mow, it only lasts about 30-40 minutes and comes back in. Prior
      > to this it would last about 3 hours.
      >
      > I've had the robot just slightly less than two years. Could this be a bad
      > battery already (after less than 2 years)?? Or maybe something with the
      > charger/power pack?
      >
      > It happened all of a sudden, like on one mow it lasted 3 hours, and the
      > next, 30 minutes -- and won't ever get to a full charge indication now.
      >
      > Thanks for all the help.
      >
      > David
      >
      >
      >


      [Non-text portions of this message have been removed]
    • Show all 25 messages in this topic